VirtualBox

Ticket #13207 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

virtualBox 4.3.12 Guest Additions broken with Xorg 1.16 Debian SID -> fixed in releases after 23 July 2014, 4.2 series and later

Reported by: mcaseiro Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.12 Keywords: xorg 1.16
Cc: Guest type: Linux
Host type: Windows

Description

After upgrading my debian sid, the xorg version was modified for 1.16.0 This version is unsuported by vboxGuestAdditions instaler.

Tried to cheat vboxaddition with X version 1.15.0. The instalation proceeds ok with the vboxvideo_drv.s0 on xorg drivers.

All kernel modules are ok.

But I got an error when starting X saying ABI major version 15 is not compatible with version 18 of new xorg.

Added option ignore ABI on xorg.conf makes the X start properly, but it takes a while to render gdm and I´ve got no pointer or keyboard input.

Checked the Xorg log files and detected that vboxmouse_drv was not found. So i installed again the vboxaddition with --target option, and manually copied the vboxmouse_drv_70.so to /usr/lib/xorg/modules/input

Then I got X trying to load this module, it finds but crash saying that there was an ELF error, I guess it´s a missmatch version on the compilation.

Can any one help? How is the preview drelease data of the next virtualbox version since the 4.3.14 is broken for some windows like mine (win 7). There was a topic about it but they said it could be a anti-virus program to cause this crash. So I´m stucted in 4.3.12

Change History

comment:1 Changed 3 years ago by mcaseiro

X.Org X Server 1.16.0
Release Date: 2014-07-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-4-amd64 i686 Debian
Current Operating System: Linux node-1 3.14-1-686-pae #1 SMP Debian 3.14.12-1 (2014-07-11) i686
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.14-1-686-pae root=UUID=44abf5c2-1d02-44f7-ad31-d4f4d4269dd1 ro quiet
Build Date: 17 July 2014  11:01:50PM
xorg-server 2:1.16.0-1 (http://www.debian.org/support)
Current version of pixman: 0.32.6
        Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Sat Jul 19 16:02:37 2014
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(WW) module ABI major version (15) doesn't match the server's version (18)
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning:          Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
>                   Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
(EE)
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x43) [0xb76ab423]
(EE) 1: /usr/bin/X (0xb750f000+0x1a0572) [0xb76af572]
(EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb74ed40c]
(EE) 3: /usr/lib/xorg/modules/drivers/vboxvideo_drv.so (HGSMIHeapAlloc+0x19) [0xb6c35679]
(EE) 4: /usr/lib/xorg/modules/drivers/vboxvideo_drv.so (VBoxHGSMIBufferAlloc+0x2d) [0xb6c3447d]
(EE) 5: /usr/lib/xorg/modules/drivers/vboxvideo_drv.so (VBoxHGSMIUpdatePointerShape+0x74) [0xb6c349a4]
(EE) 6: /usr/lib/xorg/modules/drivers/vboxvideo_drv.so (0xb6c21000+0x107d5) [0xb6c317d5]
(EE) 7: /usr/bin/X (0xb750f000+0xc1a9c) [0xb75d0a9c]
(EE)
(EE) Segmentation fault at address 0xf50

comment:2 Changed 3 years ago by mcaseiro

reconfigured udev, and installed xserver-xorg-input-all give´s me back mouse and keyboard. Using Driver "mouse" on xorg.conf;

But still working only with vesa video driver. Vboxvideo_drv.so still crashs X.

comment:3 Changed 3 years ago by frank

  • Priority changed from blocker to major

comment:4 Changed 3 years ago by AMD1212

Xorg 1.16 arrived this morning in Debian Testing, so all Debian Testing installations running on virtual box are also affected by not having proper graphics.

I am tired of the 1024x768 resolution, so if there are some "closed Beta GA's" please let me know if you want me to test.

comment:5 Changed 3 years ago by michael

This Additions build should work with X.Org Server 1.16.

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.15-95180.iso

comment:6 Changed 3 years ago by AMD1212

Thanks a lot Michael,

i can confirm that the version you posted build correctly...and upon a first test-run everything is working for me.

I have my two 1920x1200 Monitors back, im productive again (-;

  • Xorg working
  • Keymap working
  • vboxsf working

Please let me know if i can test anything else.

comment:7 Changed 3 years ago by michael

  • Summary changed from virtualbox 4.3.12 gestAdditions broken with Xorg 1.16 Debian SID to virtualbox 4.3.12 gestAdditions broken with Xorg 1.16 Debian SID -> fixed in releases after 23 July 2014, 4.3 series and later

Thanks for the confirmation. I must admit that I wasn't expecting problems as I had already tested RC 2 and 3 of the new X server, but testing is still good.

comment:8 Changed 3 years ago by michael

  • Summary changed from virtualbox 4.3.12 gestAdditions broken with Xorg 1.16 Debian SID -> fixed in releases after 23 July 2014, 4.3 series and later to virtualBox 4.3.12 Guest Additions broken with Xorg 1.16 Debian SID -> fixed in releases after 23 July 2014, 4.2 series and later

comment:9 Changed 3 years ago by mcaseiro

Perfect, excelent job, works perfectly...

Thanks a lot

;)

comment:10 Changed 3 years ago by DebianGuestWinHost

Hm. I experience the same problem with 4.3.15 (which I needed to move up to because of this problem  https://forums.virtualbox.org/viewtopic.php?f=6&t=62615), but the link to the 4.3.15 guest additions build is dead; it returns a 404.

Can you post a working link?

comment:11 follow-up: ↓ 12 Changed 3 years ago by michael

comment:12 in reply to: ↑ 11 Changed 3 years ago by DebianGuestWinHost

Replying to michael:

Sorry for the delay, I was on holiday.

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.15-95679.iso

Thank you; confirmed working.

comment:13 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use