VirtualBox

Ticket #1316 (closed defect: fixed)

Opened 6 years ago

Last modified 5 years ago

confused by mixed 32/64 bit Linux environment

Reported by: peter.eisentraut Owned by:
Priority: major Component: host support
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I am using the virtualbox_1.5.6-28266_Debian_etch_i386.deb package from your web site on a Debian lenny/sid sid with kernel linux-image-2.6.24-1-686. The kernel modules are compiled using /etc/init.d/vboxdrv setup. Everything is working fine.

But when I use kernel linux-image-2.6.24-1-amd64, which is a 64-bit kernel but running with 32-bit userland, VirtualBox complains after I start a VM from the GUI that the installed kernel module belongs to a different version than the currently running software. I believed this for a while and tried to reinstall the software a few times, without success. Note that VirtualBox works fine with the equivalent 32-bit kernel. I assume the problem is somewhere where the GUI communicates with the kernel module and is not expecting that it might be talking to a 64-bit kernel. I understand that this setup is a bit unusual, but everything else seems to be working fine with it. Since Debian lenny will be released with these kinds of kernels, it would be nice if this issue could be addressed sometime.

Change History

comment:1 Changed 6 years ago by frank

This issue cannot be addressed. If you are running a 64-bit host kernel you need to install the 64-bit version of VirtualBox.

comment:2 Changed 6 years ago by peter.eisentraut

I can see how this might be difficult to fix. But perhaps you could make the failure mode cleaner. It currently says, the version of the module is not from the same version as the program, which is not the case. Maybe you could say, the kernel is incompatible with the userland or the bitnesses don't match or something that would point the user to the cause more accurately.

comment:3 Changed 6 years ago by frank

Yes right, the error message is not very clear in that case. We will try to improve this.

comment:4 Changed 6 years ago by frank

  • Host type changed from other to Linux

comment:5 Changed 6 years ago by frank

  • Component changed from other to host support

comment:6 in reply to: ↑ description Changed 5 years ago by hack64

Debian Lenny i386 has basic 64 bit support. I installed the "amd64-libs" Debian official package and borrow some libraries from Debian amd64 packages. Thus, the virtualbox-2.1_2.1.0-41146_Debian_lenny_amd64.deb works fine with Debian Lenny 32 bit userland. (linux-image-2.6.26-1-amd64 + 32 bit userland + 64 bit multilib + 64 bit virtualbox)

You can request Debian Squeeze(Lenny+1) to provide "amd64-libs-qt4" to support 64 bit virtualbox in i386 installation. (Debian amd64 has "ia32-libs-gtk" to support 32 bit GTK+ and Qt4 applications.)

comment:7 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to fixed

That should be fixed by now. If not reopen please.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use