VirtualBox

Ticket #13143 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

SNMP 2 ifMIB ifXTable ifConnectorPresent incorrect setting => Fixed in SVN

Reported by: tenox Owned by:
Priority: major Component: network/hostif
Version: VirtualBox 4.3.12 Keywords: snmp
Cc: Guest type: all
Host type: Windows

Description

Consider following OID:

Name: ifConnectorPresent Oid: 1.3.6.1.2.1.31.1.1.1.17 Module: IF-MIB Description: This object has the value 'true(1)' if the interface sublayer has a physical connector and the value 'false(2)' otherwise.

VirtualBox incorrectly marks virtual interfaces created on the host machine as one having "physical connector" present.

For example: OID=.1.3.6.1.2.1.31.1.1.1.18.11 Value=Local Area Connection OID=.1.3.6.1.2.1.31.1.1.1.17.11 Value=1 (true) This is correct because Local Area Connection is a physical network adapter and has a physical connector

OID=.1.3.6.1.2.1.31.1.1.1.18.13 Value=Teredo Tunneling Pseudo-Interface OID=.1.3.6.1.2.1.31.1.1.1.17.13 Value=2 (false) This is correct because Tunneling interfaces do not have a physical connector

OID=.1.3.6.1.2.1.31.1.1.1.18.28 Value=VirtualBox Host-Only Network OID=.1.3.6.1.2.1.31.1.1.1.17.28 Value=1 (true) This is incorrect because VirtualBox is a software and doesn't have any physical connectors

Change History

comment:1 Changed 3 years ago by aleksey

Could you verify that the problem is fixed in this test build? Please post here any issues with backward compatibility should they arise.

comment:2 Changed 3 years ago by tenox

Tested. The issue is fixed! Now all virtual network connection report as (false) 2 value. Many thanks for this! Great work!

comment:3 Changed 3 years ago by tenox

Also tested with more machines. The issue appears to be resolved. Hope this doesn't cause any unforeseen effects.

comment:4 Changed 3 years ago by aleksey

  • Summary changed from SNMP 2 ifMIB ifXTable ifConnectorPresent incorrect setting to SNMP 2 ifMIB ifXTable ifConnectorPresent incorrect setting => Fixed in SVN

comment:5 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use