VirtualBox

Opened 10 years ago

Closed 8 years ago

Last modified 5 years ago

#13096 closed defect (fixed)

Error when VirtualBox checks for Updates => Fixed in SVN

Reported by: Lucas J. Carlson Owned by:
Component: webservices Version: VirtualBox 4.3.12
Keywords: Cc:
Guest type: other Host type: Windows

Description

I have been having this problem since I updated from 4.3.8 to 4.3.10 and 4.3.12. When VirtualBox checks for updates, I get this error: The network operation failed with the following error: Unknown reason. I am a computer tech and have done firewall troubleshooting both in Windows Firewall and on the Router. That's not the issue. I even redownloaded/installed 4.3.8 back onto my system and have the same problem. I have Windows 7 Home Premium 64-bit installed on this laptop (HP Pavilion g7-1139WM Notebook PC) and Windows XP Professional installed on the other laptop (Dell Latitude D600). I couldn't find a VBox.log only the VBoxSRV.log and the selectorwindow.log because I formatted this laptop and haven't installed or ran any guest OS's yet. It's not an urgent thing to fix. I just thought I would let you know as I can still manually check for updates through the browser on your website, but it is nice when the software automatically tells me when there is a new version. I really love the work that you guys put into VirtualBox. I LOVE this software and use it every day especially for games that won't install on a 64-bit system. Keep up the good work.

Attachments (2)

VBoxSVC.log (1.4 KB ) - added by Lucas J. Carlson 10 years ago.
A copy of my VBoxSVC.log
selectorwindow.log (787 bytes ) - added by Lucas J. Carlson 10 years ago.
A copy of my selectorwindow.log

Download all attachments as: .zip

Change History (16)

by Lucas J. Carlson, 10 years ago

Attachment: VBoxSVC.log added

A copy of my VBoxSVC.log

by Lucas J. Carlson, 10 years ago

Attachment: selectorwindow.log added

A copy of my selectorwindow.log

comment:1 by bl184999, 10 years ago

There is a related thread in the forum about this.

https://forums.virtualbox.org/viewtopic.php?t=61635

comment:2 by Mihai Hanor, 10 years ago

Last edited 10 years ago by Mihai Hanor (previous) (diff)

comment:3 by Frank Mehnert, 10 years ago

Summary: Error when VirtualBox checks for UpdatesError when VirtualBox checks for Updates => Fixed in SVN

Thanks for the report. The problem will be fixed in the upcoming 4.3.14 release (4.3.14 RC1 is available here.

comment:4 by Frank Mehnert, 10 years ago

Resolution: fixed
Status: newclosed

Fixed in VBox 4.3.14.

comment:5 by CyberManifest, 9 years ago

Looks like it's back again in Virtualbox 5.0.0 r101573... I'm experiencing the same problems as mentioned and this is on a MacBook Pro Retina 15" Mac OS X Yosemite 10.10.4 Host.

http://f.cl.ly/items/221n2p292e0l2S0w3B0v/Screen%20Shot%202015-08-12%20at%2011.15.39%20PM.png

comment:6 by CyberManifest, 9 years ago

Resolution: fixed
Status: closedreopened

comment:7 by Clayton Carney, 9 years ago

Windows 10 Home 64-bit. VBox 5.0.1r102010. Same problem.

Network Operations Manager

Checking for a new VirtualBox version...

The network operation failed with the following error: Unknown reason.

Have tried disabling Windows Firewall and Windows Defender. Same result with Standard User logon. However, with an Administrators Group logon, problems does not occur, even with Firewall and Defender enabled.

comment:8 by CyberManifest, 9 years ago

Still getting the error after upgrading to Mac OS X Yosemite 10.10.5 Host

comment:9 by Elijah, 9 years ago

still the same problem when checking for updates

comment:10 by Frank Mehnert, 9 years ago

Confirmed. Will be fixed in the next maintenance release.

comment:11 by Frank Mehnert, 8 years ago

Resolution: fixed
Status: reopenedclosed

Fix is part of VBox 5.0.4.

comment:12 by gmlevin, 7 years ago

Problem seems to have returned in Version 5.1.14 r112924 (Qt5.6.2). Not mentioned in the change log for 5.1.16.

comment:13 by easydoor, 6 years ago

I have the same problem. Win 8.1, long time I can not update because of this annoying ssl message. I tried everything above, To delete certificate, to delete file vbox-ssl-cacertificate.crt, to uninstall, VB, the install again, and nothing.

In last let it say 7-8 version I have all the time this problem. Now Im on the latest release 5.2.8

Is there any tutorial how to solve this annoying problem?

Last edited 6 years ago by easydoor (previous) (diff)

comment:14 by davisum, 5 years ago

On Windows 10 on an IPv6-only network, the File -> Check for updates... returns the following:

The network operation failed with the following error: During network request: Connection refused

I'm guessing that the VirtualBox "check for updates: functionality is only using IPv4 literal addresses and not using DNS or IPv6 API???

All my other applications on this IPv6-only network are working fine and can get to both IPv6 and IPv4 servers because we have a NAT64 translator on our network.

My guess is that all VirtualBox needs to do is use either DNS address lookups or IPv6 API for this functionality?

To work around this I have to turn IPv4 back on for my Windows box, do the update, and then turn it back off.

If this functionality could work correctly on an IPv6-only network then this work-around would not need to be employed.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use