VirtualBox

Ticket #1302 (reopened defect)

Opened 6 years ago

Last modified 4 years ago

unable to control resolution of Linux host with guest additions

Reported by: hramrach Owned by:
Priority: minor Component: other
Version: VirtualBox 1.6.2 Keywords:
Cc: Guest type: other
Host type: other

Description

I tried to install Ubuntu Gutsy into VirtualBox.

After instaling the guest additions I get large resolution that does not fit on the screen - both in splash screen and gdm login screen. The console is OK, and I can set the resolution for the user but I would prefer the resolution of the splash and login screens to be the same.

This may be also related to the OS X problem with window borders - there are 1px borders around the window which are chopped off the client area without resizing the client properly. This in turn makes scrollbars appear in the Virtualbox window, and space for these is again taken from the client, without resising. This makes any toolbars at the bottom of the screen (either Windows or Gnome) quite hard to use.

Change History

comment:1 Changed 6 years ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

This should be properly fixed in VirtualBox 1.6.2.

comment:2 Changed 6 years ago by hramrach

  • Status changed from closed to reopened
  • Resolution fixed deleted

This still does not work.

The VBox additions now limit the X11 resolution to some thing smaller than the host screen but the framebuffer resolution is still limited only by video ram size.

Current Ubuntu (Hardy) defaults to 800x600 for splash screen and gdm login screen but Linux Mint 4.0 still shows the issue.

When the system is installed (or started from Live CD) the X and framebuffer resolution is large, and when guest additions are installed the X resolution shrinks but the framebuffer resolution is still large - probably 1280x1024 on 1024x1280 host screen.

comment:3 Changed 6 years ago by michael

  • Status changed from reopened to closed
  • Resolution set to fixed

See section 9.12 of the user manual (Configuring the maximum resolution of guests when using the graphical frontend).

comment:4 Changed 6 years ago by hramrach

  • Status changed from closed to reopened
  • Resolution fixed deleted

The behaviour contradicts what is stated in that section.

After installing guest additions the fb resolution is larger than screen resolution.

comment:5 Changed 6 years ago by michael

Do I understand you correctly - the problem is solved for you in X11, but not during the splash screens before X is loaded? If this is the case then there is currently not much we can do, as the guest additions are not yet loaded at that point.

comment:6 Changed 6 years ago by frank

  • Version changed from VirtualBox Mac OS Beta 3 to VirtualBox 1.6.2

Any response?

comment:7 Changed 6 years ago by hramrach

Any fix?

My guess is that to fix this problem the maximum (or at least recommended) resolution reported by the VESA BIOS would have to be changed but I did not find anything about that in the manual.

comment:8 Changed 6 years ago by frank

Actually the last comment of Michael was a question, therefore I asked for a response.

There is currently no means to limit the resolution reported by the VESA BIOS but such an implementation would be not difficult. To find out if the maximum VESA resolution is actually the required feature you could limit the resolution by limiting the available video memory for the guest. With 800x600@32bpp require a video memory of 1.8MB, so with 2MB your splash screen would probably not be bigger than 800x600. With 3MB your splash screen should not be bigger than 1024x768@32bpp. With 5MB the maximum resolution is 1280x1024@32bpp.

comment:9 Changed 6 years ago by hramrach

Yes, that approach sort of worked for me with Fedora. However, it did not seem so straightforward when I tried, perhaps the LiveCD used 16bpp when the video ram seemed too small.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use