VirtualBox

Ticket #12999 (closed defect: obsolete)

Opened 6 years ago

Last modified 4 years ago

Ghost Vbox in Dock Reappears Mac OS X won't shutdown

Reported by: dannyil Owned by:
Component: other Version: VirtualBox 4.3.10
Keywords: Dock, Shutdown Cc:
Guest type: Windows Host type: Mac OS X

Description

There was already a ticket but was closed because it was fixed. But still have the problem (albeit intermittently) on 4.3.10

So, uninstalled all previous versions.... checked that there were no processes and artifacts in memory.... all clear..... restarted..... Installed Vbox 4.3.10 (latest version). restarted.... Installed extensions restarted.... Run guest windows XP SP3 and worked fine.... saved machine state. Closed Everything closed normally!!!! compared to 4.3.8 this was the first time it happened. reopened guest Ran a few programs in windows saved machine state icon didn't leave the dock as expected ran same guest again.... saved and closed, quit normally, no artifact dock icon remained..... same problem as ticket #12241 https://www.virtualbox.org/ticket/12241 It is fixed partially, but sometimes still doesn't close correctly.....

Attachments

vboxlog.zip Download (79.0 KB) - added by dannyil 6 years ago.
Logs for the past couple of hours
ps-Af.out Download (35.4 KB) - added by mfrazzz 6 years ago.
Output of "ps -Af" on Macbook Pro host after Ghost icon
ioreg-l.out.gz Download (103.6 KB) - added by mfrazzz 6 years ago.
Output of "ioreg -l" on Macbook Pro host after Ghost icon (gzipped)

Change History

Changed 6 years ago by dannyil

Logs for the past couple of hours

comment:1 Changed 6 years ago by galitsyn

Just to make sure you are not running external App which could hold VBox icon in dock, could you please attach "ps -Af" output taken at the moment when the icon got stuck?

Last edited 6 years ago by galitsyn (previous) (diff)

comment:2 Changed 6 years ago by galitsyn

Additionally, might make sense to attach "ioreg -l" output obtained at the moment when icon stuck.

comment:3 Changed 6 years ago by galitsyn

Is this still reproducible for you? If so, could you please attach "pa -Af" and "ioreg -l"?

comment:4 Changed 6 years ago by mfrazzz

I am having this also, but not intermittent for me, happens anytime I close an Ubuntu based guest, and I get 1 or 2 ghost icons in the Dock that will not go away. No running remnants appear in the processes, and cannot Force Quit the ghosts. Once this happens, I cannot do a clean shutdown or reboot of the host Macbook Pro (Late 2012 model). I am running Virtualbox 4.3.14 r95030. I'll attach the ps -Af and ioreg -l as you requested.

Last edited 6 years ago by mfrazzz (previous) (diff)

Changed 6 years ago by mfrazzz

Output of "ps -Af" on Macbook Pro host after Ghost icon

Changed 6 years ago by mfrazzz

Output of "ioreg -l" on Macbook Pro host after Ghost icon (gzipped)

comment:5 Changed 6 years ago by mfrazzz

Update: With each starting of the guest, and shutting it down, a new ghost icon is left in the dock. I currently have 4 ghost icons from starting and shutting down a couple of different guest VMs (total of 2 guest Linux VMs, with them each being started and shutdown 2 times each). A restart of the guest VM does not leave a ghost icon in the dock. Only a shutdown (either doing a command line shutdown 0, using GUI shutdown option, or the VBox "Close" (same behavior for Save State, ACPI Shutdown, or Power Off)).

Last edited 6 years ago by mfrazzz (previous) (diff)

comment:6 Changed 6 years ago by mfrazzz

FWIW: I'm now on Virtualbox 4.3.16 r95972 on Mac OSX 10.9.5 and still experiencing this. I've also noticed that the native Oracle Beehive Conferencing client behaves the same way with leaving a phantom dock icon. Due to this issue, I can never properly shutdown my Macbook anymore as I always have a leftover Virtualbox icon in my dock. May have to look at going back to VMware or Parallels because of this.

Please let me know if there is further logs or system stats you need to help with this.

comment:7 Changed 4 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use