VirtualBox

Ticket #12954 (closed defect: duplicate)

Opened 12 months ago

Last modified 11 months ago

Virtual Box VMs randomly enter "stopping" state (VERR_VM_FATAL_WAIT_ERROR)

Reported by: JohnBe Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.10 Keywords:
Cc: Guest type: other
Host type: other

Description (last modified by frank) (diff)

Since upgrading to OSX Mavericks, I've had issues with VirtualBox boxes randomly entering the "stopping" state.

$ vagrant status
Current machine states:
 chef                      stopping (virtualbox)

$ vagrant halt chef

$ vagrant up chef
Bringing machine 'chef' up with 'virtualbox' provider...
==> chef: Clearing any previously set forwarded ports...
There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["modifyvm", "c7dcf83b-67bc-475e-b5d6-f94a4a94d148", "--natpf1", "delete", "ssh"]

Stderr: VBoxManage: error: Code NS_ERROR_FAILURE (0x80004005) - Operation failed (extended info not available)
VBoxManage: error: Context: "LockMachine(a->session, LockType_Write)" at line 462 of file VBoxManageModifyVM.cpp

$ VBoxManage debugvm chef log --debug
VBoxManage: error: Code NS_ERROR_FAILURE (0x80004005) - Operation failed (extended info not available)
VBoxManage: error: Context: "LockMachine(pArgs->session, LockType_Shared)" at line 641 of file VBoxManageDebugVM.cpp

$ vagrant --version
Vagrant 1.5.3
$ VBoxManage --version
4.3.10r93012

Any boxes I bring up randomly enter this state multiple times a day, with the only way to revive them being to destroy them.

I've tried clearing out both the VirtualBox VMs and the vagrant.d directories and reinstalling both vagrant and VirtualBox without any change.

Change History

comment:1 Changed 12 months ago by frank

  • Description modified (diff)

I would expect to see at least one VBox.log file of such affected VM. See section 12.1.2 of the user manual.

comment:2 Changed 12 months ago by JohnBe

Tried to attach them to the ticket but ran into file size limits - the logs are huge. Here are links to gists of VBox.log for two affected VMs:

 https://gist.github.com/JohnBrodie/10978595  https://gist.github.com/JohnBrodie/10978666

Happy to provide anything else you may need to aid in troubleshooting.

comment:3 Changed 11 months ago by frank

  • Summary changed from Virtual Box VMs randomly enter "stopping" state to Virtual Box VMs randomly enter "stopping" state (VERR_VM_FATAL_WAIT_ERROR)

Thanks for the log files. Next time you might consider compressing them :) We saw this Guru Meditation before but so far we have no idea why this happens but we are investigating.

comment:4 Changed 11 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #12727. Posted a test build there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use