VirtualBox

Ticket #12879 (closed defect: fixed)

Opened 14 months ago

Last modified 12 months ago

Can't mount shared folders with guest additions 4.3.10 => Fixed in SVN

Reported by: pcfens Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.3.10 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

Linux machines running guest additions 4.3.10 give an error when trying to mount shared folders using the command:

sudo mount -t vboxsf /media/shared /shared_folder

The error showing up in syslog (multiple times) on the guest system is

Mar 27 15:07:33 saucy64 kernel: [   28.911001] sf_read_super_aux err=-71

I confirmed the behavior with packer built VMs running Ubuntu (12.04, 13.10, and 14.04 (daily build)). Building the same machines in VirtualBox 4.3.10 with guest additions 4.3.8 didn't have the error and performed as expected.

A VBox.log file from the Ubuntu 13.10 machine with the error is attached.

Attachments

Ubuntu13.10Error-VBox.log Download (52.4 KB) - added by pcfens 14 months ago.

Change History

Changed 14 months ago by pcfens

comment:1 Changed 14 months ago by justinlintz

Confirmed this issue as well on VMS running Ubuntu 12.04, 10.04 with Host Type of OSX 10.9.2

comment:2 Changed 14 months ago by Explorer09

Try this workaround:

sudo ln -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions \
/usr/lib/VBoxGuestAdditions

I don't know what happened to this new version of Guest Additions, but it seems that it missed a symlink during installation. This breaks the path of /sbin/mount.vboxsf so that the mount command fails.

Last edited 14 months ago by Explorer09 (previous) (diff)

comment:3 Changed 14 months ago by LastWord

I confirm this issue with Kubuntu as my guest OS.

I upgraded from Guest Additions ver. 4.3.8 to 4.3.10 and it broke my shared folders.

I also confirm that workaround mentioned earlier worked for me.

comment:4 follow-up: ↓ 16 Changed 14 months ago by michael

I hope that I have fixed it so that a work-around is no longer needed. A test build is available here:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.11-93070.iso

comment:5 Changed 14 months ago by michael

Marked ticket 12889 a duplicate of this one.

Version 0, edited 14 months ago by michael (next)

comment:6 Changed 14 months ago by socratis

Confirmed as working with VBoxGuestAdditions_4.3.11-93070.iso and guest Ubuntu 12.04.

comment:7 Changed 14 months ago by frank

  • Summary changed from Can't mount shared folders with guest additions 4.3.10 to Can't mount shared folders with guest additions 4.3.10 => Fixed in SVN

comment:8 Changed 14 months ago by Robb

Confirm problem as given in description with VirtualBox 4.3.10 r93012 on Mac 10.9.2 host with Ubuntu 12.04 guest.

Symlink workaround from Explorer09 works.

Using VBoxGuestAdditions_4.3.11-93070.iso resolves the issue as well.

comment:9 Changed 13 months ago by kekeke

VBoxGuestAdditiions_4.3.11-93070.iso resolved the problem for me as well - thanks for the fix.

comment:10 Changed 13 months ago by ScalaIsCool

Had the same issue with Win7 host and saucy32 guest. Used the test case ISO link provided above and it resolved the issue. When will the new ISO be included in an official VirtualBox release?

comment:11 Changed 13 months ago by frank

The new .iso will be part of the next maintenance release.

comment:12 Changed 13 months ago by eevenson

Thanks for the test iso -- it works as a fix for me as well. Looking forward to the next maintenance release.

comment:13 Changed 13 months ago by chulkilee

When can we get the next maintenance release? :(

comment:14 Changed 13 months ago by the-noob

+1 for the maintenance release, sync folders is major feature and manually applying the workaround is not always straightforward

comment:15 Changed 13 months ago by MartinB3

+1 please release a fix!

comment:16 in reply to: ↑ 4 Changed 13 months ago by kekeke

Replying to michael:

I hope that I have fixed it so that a work-around is no longer needed. A test build is available here:

https://www.virtualbox.org/download/testcase/VBoxGuestAdditions_4.3.11-93070.iso

Unfortunately, this link is no longer working. Any chance it can be restored?

comment:17 follow-up: ↓ 18 Changed 13 months ago by michael

For now it would probably be simplest if people just used the work-around from comment:2, which is exactly what the test build would do.

Last edited 13 months ago by michael (previous) (diff)

comment:18 in reply to: ↑ 17 Changed 13 months ago by W2PC

Replying to michael:

For now it would probably be simplest if people just used the work-around from comment:2, which is exactly what the test build would do.

yeah if only we could automate this workaround in puppet so we did not have to ssh in and run the hack. Do we have a ETA on the maintenance release?

I do way to much vagrant/puppet to have to do this to each machine all day long.

comment:19 Changed 13 months ago by juriansluiman

Can someone give an ETA for the next release? We are also using vagrant/ansible a lot and this bug is really annoying to hotfix it over and over again.

The list of builds is not up to date at the 4.3.x page but generally speaking there was a release every month or so. 4.3.10 was released on 2014-03-25 (so just over a month ago). Is it expected to have 4.3.11 released within a few days now? The patch has been applied in svn four weeks ago and I guess a lot of people have stumbled upon this issue :)

comment:20 Changed 13 months ago by blitz_danielsmith

What is the ETA on 4.3.11?

comment:21 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.12.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use