VirtualBox

Ticket #12851 (reopened defect)

Opened 6 years ago

Last modified 10 months ago

High cpu-load (up to 100%) on idle

Reported by: Sworddragon Owned by:
Component: other Version: VirtualBox 4.3.6
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

My host is Linux 3.13.6 x86_64 and the guest is Windows XP SP3 32 bit with all current updates installed. The guest additions with experimental 3D support are installed too.

If the Windows XP guest is booted up and reached the idle state (0-1% cpu-load in the task manager) I'm noticing that on my Linux host the cpu-load is constantly at ~15% of one core (AMD Phenom II X6 1045T). If I'm booting up the Windows XP guest into the safe mode and it reached the idle state the cpu-load on my Linux guest goes even up to the maximum (~600%/600%).

Attachments

VBox.log Download (107.4 KB) - added by Sworddragon 3 years ago.
VBoxCPUUsage.log Download (94.0 KB) - added by PedroCR 18 months ago.
Log of a similar situation
VirtualBoxCPUUsage.jpg Download (458.1 KB) - added by PedroCR 18 months ago.
Screenshot of VM and top and the same time showing the issue
VBox.log.1 Download (102.5 KB) - added by mhanor 13 months ago.
Debian host running Windows 10 1803 64 bit (installed)
Screenshot at 2018-10-20 19-22-41.png Download (274.1 KB) - added by mhanor 13 months ago.
cpuusage11.png Download (40.1 KB) - added by mhanor 13 months ago.
process profiling on Win10 1803 VM process, issue manifesting itself
cpuusage12.png Download (38.6 KB) - added by mhanor 13 months ago.
profiling on Win10 1709 VM process, no issue, VM up for the same amount of time

Change History

comment:1 Changed 6 years ago by Sworddragon

Little correction:

the cpu-load is constantly at ~15% of one core

The cpu-load is ~15% but shared between all 6 cores (every core is using between 1-3%).

comment:2 Changed 3 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:3 Changed 3 years ago by Sworddragon

  • Status changed from closed to reopened
  • Resolution obsolete deleted

I'm still seeing this issue with VirtualBox 5.0.24.

comment:4 Changed 3 years ago by aeichner

Please attach a VBox.log of the affected VM, the output of "top -H" for the VM process which has all threads listed so we can see which thread hogs the CPU and if possible a coredump of the VM process created with gcore (see here for the description how to provide the core dump to us).

comment:5 Changed 3 years ago by Sworddragon

Have you tried to reproduce the issue? On my Ubuntu installation (64 bit) it happened across all versions of it within the last 2 years on all Windows guests I have used (Windows XP and Windows 10). Maybe you can reproduce this issue on a recent Ubuntu system (preferably 64 bit) with a Windows 10 guest and installed guest additions. Starting the Windows 10 guest and waiting until it is in idle should cause still significant CPU usage on the host.

Edit: On testing this the issue gets a bit better observable (higher CPU usage on idle) if the number of CPU's in VirtualBox for the guest is set to the supported maximum for the system.

Last edited 3 years ago by Sworddragon (previous) (diff)

comment:6 Changed 3 years ago by aeichner

There is no point in trying to reproduce it at this stage because without the VBox.log your exact VM setup is not known. There are far too many subtle differences in VM configurations which can have an impact on the issue and I won't invest any time trying to reproduce it blindly with different configurations. Providing a VBox.log is the absolute minimum, a core dump is optional but might help to get an insight into the VM state.

Changed 3 years ago by Sworddragon

Changed 18 months ago by PedroCR

Log of a similar situation

Changed 18 months ago by PedroCR

Screenshot of VM and top and the same time showing the issue

comment:7 Changed 18 months ago by PedroCR

I'm seeing the same issue in 5.2.10 as packaged by Ubuntu 18.04. I've attached the log and a screenshot displaying the issue happening with top clearly showing what I assume to be the 2 virtual CPU threads consuming CPU continuously even though the guest isn't using almost any.

comment:8 Changed 18 months ago by PedroCR

I'm using a Lenovo T460s (Linux amd64 host) to run a Windows 7 Guest. The issue either didn't exist or was much less noticeable with 5.0 and 5.1 (also Ubuntu packaged).

comment:9 Changed 18 months ago by socratis

Correct me if I'm wrong, but I see the following regarding the CPU consumption:

gnome-shell    15.5
EMT-1          14.8
EMT-2          12.8
...
VirtualBox      0.7

So, why is this a "VirtualBox consumes CPU" issue?

comment:10 Changed 16 months ago by PedroCR

socratis, EMT-1 and EMT-2 are the two Virtualbox CPU threads. Those are the ones consuming CPU at idle.

comment:11 Changed 16 months ago by PedroCR

This issue still happens continuously on my machine. Is there anything else I can do to help debug it?

comment:12 Changed 13 months ago by mhanor

I thought of opening a new ticket, but I think I'll post here for now. A similar issue is occuring with Windows 10 1803 64 bit, running as a guest on Windows 10 1803 64 bit or on Debian 10 64 bit as host. I've observed the issue after Windows 10 1803 was released. On Windows 10 as host, the EMT thread CPU usage, of the VM process, drops if I start another paused VM, but even then the CPU usage is still indicative something is still spinning in the EMT thread. In full spin, the CPU usage is higher of the EMT thread is higher on the Windows 10 host, consuming 100% of the processing time of one CPU core. I'm attaching a log from the Debian host, but also a screenshot of some process profiling done with Visual Studio, on an OSE build VirtualBox process, some time ago, booting the Windows 10 1803 and 1709 64 bits ISOs, with the same VM uptime for both VM instances. You should be able to reproduce this just by booting the installation ISO and letting it reach the first setup GUI. This issue doesn't occur with Windows 10 1709.

Last edited 13 months ago by mhanor (previous) (diff)

Changed 13 months ago by mhanor

Debian host running Windows 10 1803 64 bit (installed)

Changed 13 months ago by mhanor

Changed 13 months ago by mhanor

process profiling on Win10 1803 VM process, issue manifesting itself

Changed 13 months ago by mhanor

profiling on Win10 1709 VM process, no issue, VM up for the same amount of time

comment:13 Changed 10 months ago by mhanor

This is still an issue, with 6.0.0 (including the latest test build). The problem can also be reproduced with Windows 10 1809

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use