VirtualBox

Ticket #1281 (closed defect: duplicate)

Opened 6 years ago

Last modified 3 years ago

No serial port on Windows 2000 guest machine

Reported by: Matthai Owned by:
Priority: major Component: uart
Version: VirtualBox 1.5.6 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I am using the latest version (1.5.6) of Vbox on Ubuntu. I have Win 2000 guest virtual machine. I have enabled one serial port (COM1) - port mode is Host device, port path is /dev/ttyS0.

However, in Win2000 I can't see any COM port. I got an error at shutdown:

Ioctl failed for serial host device '/dev/ttyS0' (VERR_INVALID_POINTER). The device will not work properly.

Error ID: DrvHostSerialFail Severity: Warning

In VBox.log there are several lines with this:

00:05:36.795 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.805 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.815 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.825 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.836 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.846 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false 00:05:36.856 ERROR [COM]: aRC=0x80070005 aIID={fd443ec1-0006-4f5b-9282-d72760a66916} aComponent={Mouse} aText={The console is not powered up} aPreserve=false

And machine does not shut down normally, but it is aborted. Any idea?

Change History

comment:1 Changed 6 years ago by lesliev

I had this problem with a Linux host, XP as guest and a USB serial port bridge. I solved it by going to "Add Hardware" in the Control Panel and adding the COM port manually. It was not detected, I had to go to the bottom of the list of "Installed Hardware" and select "Add a new hardware device". After that the COM port was listed and I could add it and work with it.

comment:2 Changed 6 years ago by frank

  • Guest type changed from other to Windows

comment:3 Changed 6 years ago by frank

  • Component changed from other to uart

comment:4 Changed 5 years ago by frank

  • Host type changed from other to Linux

Matthai, is this problem still relevant?

comment:5 Changed 5 years ago by karelklic

The same thing happened to me with a Debian Lenny host and Windows XP SP3 as a guest. I enabled a serial port and it was not visible in the guest OS. I played with it a lot and tried various settings, but I have never seen a COM port in the guest OS.

In the guest OS's Device Manager when I enabled "Show hidden devices" there was a yellow exclamation mark on the "Non-Plug And Play Drivers/Serial" device icon. The VBox.log file contained "Serial1: no unit" line.

The problem was at the end solved by "Add Hardware" tip from lesliev. The COM port works when added and configured manually (IRQ, address in the guest WXP).

Sun xVM VirtualBox 2.1.4. AFAIK I made no mistake in the host OS settings, permissions, group membership etc.

comment:6 Changed 3 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #7411. Yes, the other ticket was opened much later but I still added a comment there.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use