VirtualBox

Ticket #12745 (closed defect: fixed)

Opened 13 months ago

Last modified 9 months ago

Windows 8 crashes when installing guest additions 4.3.8

Reported by: amaxware Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Vbox 4.3.8 starts/runs Windows 8 fine, but when trying to install guest additions, Windows crashes.

Attachments

VBox.log Download (94.0 KB) - added by amaxware 13 months ago.
VBox_Legorol.log Download (105.2 KB) - added by Legorol 12 months ago.
Malcolms Win8-2014-03-31-18-31-07.log Download (94.9 KB) - added by Malcolm 12 months ago.
Log of startup and hang of win 8.1 VM with 3D enabled

Change History

Changed 13 months ago by amaxware

comment:1 follow-up: ↓ 2 Changed 13 months ago by frank

How does the crash look like? According to your log file the VM process doesn't crash. Does the guest show some BSOD?

comment:2 in reply to: ↑ 1 Changed 13 months ago by amaxware

Replying to frank:

How does the crash look like? According to your log file the VM process doesn't crash. Does the guest show some BSOD?

It gets about 1/2 thru the guest additions install and then the OS just quits, no real BSOD, but when Win8 tries to restart it can not, goes into a recovery/restore which does work.

I did notice that on the guest addition, the options are greyed out i.e. it has the experimental 3-D video selected and I have no choice.

comment:3 Changed 13 months ago by frank

The grayed out "experimental 3D video" checkbox in the installer is normal for Windows 8 / 8.1.

What happens if you boot the guest with 3D disabled (VM settings)?

comment:4 Changed 13 months ago by Legorol

I am experiencing the same problem. The issue is actually not that there is a crash when the guest addition is installed, but that the guest can't boot after the guest additions have been installed.

Host: Windows 7 Ultimate x64
Guest: Windows 8.1 Enterprise x64 Evaluation

Guest has 3D acceleration already disabled in VM settings.

Guest was running fine in VirtualBox 4.3.6 with Guest Additions 4.3.6. Updated to VirtualBox 4.3.8. Ever since I updated Guest Additions to 4.3.8, the guest does not boot successfully, instead it boots to Recovery mode.

Workaround: enabling 3D acceleration in VM settings allowed guest to successfully boot.

Resolved by using System Restore in guest to roll back to Guest Additions 4.3.6.

See this thread on the forum:  https://forums.virtualbox.org/viewtopic.php?f=2&t=60333

Last edited 13 months ago by Legorol (previous) (diff)

comment:5 Changed 13 months ago by dewhite04

Your workaround description was helpful, but I wanted to add that during the time I had 3d acc. enabled to gain access to the Windows environment so I could rollback drivers, I was experiencing black screens and artifacted redraws, which I was able to abate by changing from fullscreen to windowed mode temporarily. I thought this might be helpful to others.

comment:6 Changed 13 months ago by jkoreska

I have the same issue for Windows 8, 8.1, and 2012 R2 guests as described here:  https://forums.virtualbox.org/viewtopic.php?f=6&t=60432&p=282335#p282335

I've rolled back to 4.3.6 for now.

comment:7 Changed 13 months ago by frank

I'm not able to reproduce this, at least not with a Windows 8 guest (which the original report is for). We will also try a Windows 8.1 guest.

From the comments above I read two important facts: (1) There is apparently a regression with the 4.3.8 Windows Guest Additions. And (2), this applies only to VMs which have 3D support disabled in the VM settings, is that correct?

comment:8 Changed 13 months ago by frank

And please all, attach more VBox.log files of your VM sessions, perhaps there is a pattern in the VM configuration.

Changed 12 months ago by Legorol

comment:9 Changed 12 months ago by Legorol

Attached log demonstrating the issue in a freshly installed Windows Server 2012 R2 Evaluation (Datacenter with GUI) VM. I assume you can check the VM configuration in the log file. Note that 2D video acceleration is turned on, but 3D is off.

These are the only things I did in the VM:

  1. Install Windows Server 2012 R2 Evaluation (Datacenter with GUI)
  2. Install language pack
  3. Install Windows Updates
  4. Minor adjustments: change computer name, time zone, screen resolution

At this point, I shut down the VM, took a snapshot, and booted up. Tried to install Guest Additions. About halfway through the installation, the VM suddenly reset with no warning.

The OS was able to boot up again. I could log in, and received a message from Windows telling me the PC was unexpectedly shut down.

I shut down the machine again, and saved the log.

In the log, you can see the following events:
00:03:16: Guest Additions installation
00:03:33: Reset initated by ACPI

I hope this helps narrow the problem down.

Last edited 12 months ago by Legorol (previous) (diff)

comment:10 Changed 12 months ago by chrisse

I had the same problem with:
host: Win 7 Home Premium x64
guest: Win 8.1 Pro x64
but I took snapshoot after pure install of Win 8.1 and was able to rollback every unsuccesful attempt of installing guest additions.

1st attempt:
Enabled PAE/NX
Enabled 2D Acceleration
result: black screen and reboot

2nd attempt:
Enabled PAE/NX
Enabled 2D Acceleration
Enabled 3D Acceleration (as someone above suggested)
result: black screen and reboot

3rd attempt:
Disabled PAE/NX
Disabled 2D Acceleration
Disabled 3D Acceleration
result: black screen for less than second and after this blink guest additions' installation wizard prompts with "reboot now" / "reboot later". Everything works.

Last edited 12 months ago by chrisse (previous) (diff)

comment:11 Changed 12 months ago by Legorol

Just to add to chrisse's report, I would note that by default, PAE/NX is not enabled for x64 guests (indeed it shouldn't be). All my cases where I encountered the problem had PAE/NX disabled.

comment:12 Changed 12 months ago by zagnut9999

Chrisse's 3rd attempted worked for me as well. "Using last known good configuration" in boot menu allowed me to get back in to my machine as I had failed to take a snapshot.

comment:13 Changed 12 months ago by Legorol

Problem still occurs in 4.3.10.

I can confirm some of chrisse's observations, and conclude the following:

The problem for me occurs when 2D Acceleration is ENABLED, but 3D Acceleration is DISABLED.
The problem for me does not occur when BOTH 2D Acceleration and 3D Acceleration are disabled, or both enabled.

(I always have PAE/NX disabled for x64 guests)

Last edited 12 months ago by Legorol (previous) (diff)

comment:14 Changed 12 months ago by frank

We think we fixed this bug as well. Please re-download the 4.3.10 package and make sure to update the 4.3.10 Guest Additions. The correct 4.3.10 revision is 93012.

comment:15 Changed 12 months ago by Legorol

The problem is fixed for me in 4.3.10 revision 93012.

Changed 12 months ago by Malcolm

Log of startup and hang of win 8.1 VM with 3D enabled

comment:16 in reply to: ↑ description ; follow-up: ↓ 17 Changed 12 months ago by Malcolm

Replying to amaxware:

Vbox 4.3.8 starts/runs Windows 8 fine, but when trying to install guest additions, Windows crashes.

I put a post in another thread but thought I'd add it here as well. I've got the same problem with 4.3.10

Host: Win 7 Pro 64 bit Guest: Win 8.1 Pro 64 Bit. allocated 4Gb RAM and 4 cpu's VB: 4.3.10r93012 Guest Additions: 4.3.10

For me it looks like the problem is 3D acceleration. I had it enabled, tried to install the Guest Additions, and the install crashed. I disabled 3D and was able to install, and reboot and everything looks fine. I re-enable 3D and it boots, but then hangs when the additions load. This is quite reproducable. I attach a log of a start attempt with 3D enabled. I just ticked 3D and start. As soon as the system tray icon appears the system hangs and I have to power off. In this case I switched to another VM, and when I came back the screen was black, and VB stopped responding. When I restarted the VM it went to the Windows repair screen. Hope this helps Malcolm

comment:17 in reply to: ↑ 16 ; follow-up: ↓ 19 Changed 12 months ago by misha

Replying to Malcolm:

For me it looks like the problem is 3D acceleration. I had it enabled, tried to install the Guest Additions, and the install crashed.

How does it crash? VM bsods? if this is the case please attach a  minidump for the bsod.

comment:18 Changed 11 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

No response, closing.

comment:19 in reply to: ↑ 17 Changed 9 months ago by Teermit

Replying to misha:

Replying to Malcolm:

For me it looks like the problem is 3D acceleration. I had it enabled, tried to install the Guest Additions, and the install crashed.

How does it crash? VM bsods? if this is the case please attach a  minidump for the bsod.

Hi. My host: Windows 8.1 x64; guest: Windows 8 x86 VirtualBox version 4.3.12 If 3D acceleration turned on, VirtualBox crashes while installing guest additions. It is not crash of guest OS, VirtualBox process crashes in host OS

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use