VirtualBox

Ticket #12737 (closed defect: fixed)

Opened 15 months ago

Last modified 5 days ago

Cannot restore machine state for Win7 guest when using 3D acceleration

Reported by: 3vi1J Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.3.8 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

I've had a Win7 guest VM that I'm running under a Linux host (Ubuntu). Saving and restoring the guest machine state for this VM worked fine in 4.2, but has not worked since the first 4.3 release, even though I am working with brand new 4.3 save states.

I can start the VM from scratch (no saved session) and it will run fine. I can save the session/state, and it exits normally. But, when I try to restore a saved session, "Restoring Virtual Machine" halts at around 93% and I immediately get a VirtualBox popup that says:


Failed to open a session for the virtual machine Win7.

No error info.

Result Code: NS_ERROR_CALL_FAILED (0x800706BE) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}


At that point, the machine shows as "Aborted", and restarting it reboots it from scratch.

Now for the interesting part: If I disable 3D acceleration in the VirtualBox display options for the machine, I can save and restore the state with no problem. When enabled, 3D acceleration works fine (the machine does have the latest guest utils/drivers installed), and I was using it when I was save/restoring under 4.2 with no issue.

I'm not sure why having 3D acceleration makes any difference. I've tried restoring the machine both with my native HD4000 graphics and my nvidia 670MX chipset (via bumblebee) and get the same results. As I said, 3D acceleration works fine within the guest (as do my many other native 3D apps).

I am attaching the log. Please let me know any other info you require to help troubleshoot this persistent issue. I've looked around the forums/bugs, but have been unable to locate someone with this specific problem.

Attachments

after_restore_crash-VBox.log Download (68.7 KB) - added by 3vi1J 15 months ago.
VBox.log for Win7 guest, right after attempting to restore state.
VBox.log Download (68.4 KB) - added by rugubara 11 months ago.
log of crashed virtualBox session - restore whith full 3D support in Windows guest

Change History

Changed 15 months ago by 3vi1J

VBox.log for Win7 guest, right after attempting to restore state.

comment:1 Changed 14 months ago by 3vi1J

Tested with 4.3.10: Same issue.

comment:2 Changed 14 months ago by frank

So your VM process is crashing. Could you provide a core dump taken from a VBox 4.3.10 session? If so, please do also provide a VBox 4.3.10 VBox.log file

Changed 11 months ago by rugubara

log of crashed virtualBox session - restore whith full 3D support in Windows guest

comment:3 Changed 11 months ago by rugubara

Hi, Frank.

I also experience this issue. In order to see it, the Windows Guest VirtualBox tools should be installed with full (experimental) 3D support. Installing it with basic 3D support effectively works around this issue like disabling 3D does.

I took a liberty to follow the core dump manual to try to produce one. it's 18 MB when compressed. The size limit for attachment here is 0.5 MB. ftp.oracle.com mentioned in the core dump manual doesn't accept connections.

anton@r9-008cln ~/WJNJRUPB8EDCN.wks.jnj.com $ ftp ftp.oracle.com
Connected to ftp.oracle.com (141.146.1.166).
421 Service not available, remote server has closed connection
ftp> quit

Please advise the means to transfer the core dump to you. I attached the Vbox.log of this crash.

comment:4 Changed 11 months ago by h-w

Would a minidump be smaller?:  http://msdn.microsoft.com/en-us/library/bb787181%28VS.85%29.aspx (I assume this works for Windows 7)

You could split the dump (on Windows I use Cygwin for this):

# to create split archives
$ gzip -c my_large_file | split -b 1024MiB - myfile_split.gz_
# to uncompress and consolidate
$ cat myfile_split.gz_* | gunzip -c > my_large_file

Another option would be a transfer link to Dropbox etc.

comment:5 Changed 7 months ago by bugs_claudio

Hi,

I saw the same issue with a Windows7 32-bit VM before and now with a Windows 8.1 64-bit VM. On Ubuntu 14.04 and Ubuntu 14.10 (proper official release). I am running the lastest Virtualbox release from the moment (4.3.18 r96516) with guest additions (downloaded from the Virtualbox console) and no extension pack.

I pinned it down to the following combination:

  • 3D support enabled in the VM properties.
  • Using Intel driver open source driver.

If I change one of those two parameters, the problem goes away. My laptop has two video cards: claudio@bologna:/var/log$ lspci |grep 'VGA\|3D' 00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b) 04:00.0 3D controller: NVIDIA Corporation GK107M [GeForce GT 750M] (rev a1)

VBox logs are identical as above, but the interesting part can be found in syslog (and kern.log):

Oct 25 00:27:08 bologna kernel: [ 802.649812] VDMA[4203]: segfault at 54 ip 00007f421a749150 sp 00007f41f40af100 error 4 in i965_dri.so[7f421a590000+51c000]

Feel free to contact me for additional info or tests,

Regards,

Claudio

Last edited 7 months ago by bugs_claudio (previous) (diff)

comment:6 Changed 6 months ago by rugubara

The VBox 4.3.20 still have the same issue.

comment:7 Changed 6 months ago by lincoln

Another bit of information. The restore only fails when an Aero theme is active. Changing the VM to use a non-Aero theme works around the problem.

comment:8 Changed 6 weeks ago by galitsyn

Could you please try this test build and confirm if the issue has been fixed for you?

comment:9 Changed 11 days ago by frank

Please test the latest test build from our test builds page. Thank you!

comment:10 Changed 11 days ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Hopefully fixed in VBox 4.3.28.

comment:11 Changed 5 days ago by 3vi1J

Original submitter here. I just tested with 4.3.28 on Linux, and the issue is indeed fixed! Thanks for finally squashing this annoying bug.

comment:12 Changed 5 days ago by frank

Thank you for the feedback!

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use