VirtualBox

Ticket #12736 (closed defect: fixed)

Opened 17 months ago

Last modified 17 months ago

MacOSX 10.8 Guest crashes after EFI Boot with "Divide" error after upgrading from 4.3.6 to 4.3.8 [FIXED in SVN]

Reported by: ThetaPhi Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.8 Keywords:
Cc: Guest type: other
Host type: Linux

Description

I know, those requests are closed quite often with "running MacOSX guests is not supported", but this is a new regression with a guest that was running before the upgrade.

See the attached screenshot of the guest window. After failing. The OSX guest is booting with EFI and is an unmodified OSX/Darwin installation, so definitely no Hackintosh! The "Divide error" occurs directly after EFI handling over to Darwin, no additional log output.

The strange thing is: This only happens on one host CPU type (Intel(R) Xeon(R) CPU X3440 @ 2.53GHz), on my other computer (Intel(R) Core(TM) i7-3610QM CPU @ 2.30GHz) the guest starts after upgrading 4.3.6 to 4.3.8 like it did before.

I also attached the VBox log of the failing guest.

This could be related to ticket #8651 - the failing CPU has no SSE4 features, but the working one has. But I did not enable this experimental feature! It is the unmodified guest VM reverted to snapshot that was running before.

After downgrading virtualbox to 4.3.6, it is booting again.

Attachments

osx_boot_failure.png Download (56.1 KB) - added by ThetaPhi 17 months ago.
Failure in guest window (via RDP).
VBox.log Download (112.6 KB) - added by ThetaPhi 17 months ago.
log file, showing no errors, but gives more details on the failing guest VM

Change History

Changed 17 months ago by ThetaPhi

Failure in guest window (via RDP).

Changed 17 months ago by ThetaPhi

log file, showing no errors, but gives more details on the failing guest VM

comment:1 Changed 17 months ago by ThetaPhi

Sorry, the failing CPU *has* SSE4 features, but those are not eanbled in the guest. See log file.

comment:2 Changed 17 months ago by frank

For SSE 4.1/4.2 see here. You have to enable it manually for each VM.

comment:3 Changed 17 months ago by bird

I've reproduced it here, I don't think it's SSE 4.x related, I believe it's some issue related to CPUID and/or MSR changes that went into 4.3.8. Stay tuned...

comment:4 Changed 17 months ago by ThetaPhi

Thanks. If you have any news or a fix, I can do a test if you have a .deb package for Ubuntu Precise 64bits. This was a quick reply, many thanks!

Greetings also to the Oracle Java team, this is the virtual machine doing the Apache Lucene/Solr CI builds on MacOSX running a Jenkins Slave!

comment:5 Changed 17 months ago by bird

  • Status changed from new to closed
  • Resolution set to fixed
  • Summary changed from MacOSX 10.8 Guest crashes after EFI Boot with "Divide" error after upgrading from 4.3.6 to 4.3.8 to MacOSX 10.8 Guest crashes after EFI Boot with "Divide" error after upgrading from 4.3.6 to 4.3.8 [FIXED in SVN]

Apple was reading MSR 0x35 to get core & thread counts, we weren't giving it the right values. Fix committed.

Until we publish a build containing fix, the issue can be worked around like this:

VBoxManage setextradata <vmname> VBoxInternal/CPUM/MSRs/MsrCoreThreadCount/First 0x00000035

comment:6 Changed 17 months ago by ThetaPhi

Hi, the work around seems to work. I updated to latest version and applied this extradata key to the VM configuration. It starts up successfully.

comment:7 Changed 17 months ago by socratis

THANK YOU !!! I couldn't use 4.3.8 because of this. I waited a couple of days, to see if anyone else had that issue, before filing a bug report, but ThetaPhi was ahead of me. 10.5, 10.6, 10.7, 10.8 and 10.9 clients and from all of them only 10.6 was booting. Now all of them do, except 10.5, but that I believe is another bug report that I have to open.

comment:8 Changed 17 months ago by Wikicoda

Where do i add the above command?

VBoxManage setextradata <vmname> VBoxInternal/CPUM/MSRs/MsrCoreThreadCount/First 0x00000035

Version 0, edited 17 months ago by Wikicoda (next)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use