VirtualBox

Ticket #12645 (closed defect: worksforme)

Opened 7 years ago

Last modified 7 years ago

Windows 8.1 X64 Can't allocate more than 3584 MB to any guest OS.

Reported by: c0mputerguy72 Owned by:
Component: other Version: VirtualBox 4.3.6
Keywords: Cc:
Guest type: all Host type: Windows

Description

When running any guest with above 3584 MB allocated I receive the following error.

Error received:

"Failed to open a session for the virtual machine WIN701.
VT-x is disabled in the BIOS. (VERR_VMX_MSR_VMXON_DISABLED).
Result Code: E_FAIL (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}"

When I allocate below 3585 MB the guest Boots.
VT-x has been confirmed to be enabled in the BIOS.
System Info from Virtual Box Log:
00:00:00.001995 main Build Type: release
00:00:00.001995 main OS Product: Windows 8
00:00:00.001995 main OS Release: 6.2.9200
00:00:00.001995 main OS Service Pack:
00:00:00.017016 main DMI Product Name: 4318CTO
00:00:00.023970 main DMI Product Version: ThinkPad W510
00:00:00.023970 main Host RAM: 16315MB total, 13280MB available
00:00:00.023970 main Executable: C:\Program Files\Oracle\VirtualBox\VBoxSVC.exe
00:00:00.023970 main Process ID: 6512
00:00:00.023970 main Package type: WINDOWS_64BITS_GENERIC

This has been tested on multiple machines with different installs and is not machine specific.

Virtual Box Log Attached.

Attachments

VBox.log Download (26.7 KB) - added by c0mputerguy72 7 years ago.
VBox-Latest.log Download (89.1 KB) - added by c0mputerguy72 7 years ago.

Change History

Changed 7 years ago by c0mputerguy72

comment:1 Changed 7 years ago by frank

  • priority changed from blocker to major

comment:2 Changed 7 years ago by frank

  • Status changed from new to closed
  • Resolution set to worksforme

Actually this is not a bug at all. VirtualBox can only handle guests with a lot of RAM if VT-x or AMD-V is available. This is just a limitation of the VMM implementation. For some reason, VT-x is disabled in your host BIOS. Please enable VT-x and you will be able to run guests with more than 3584MB RAM.

comment:3 Changed 7 years ago by c0mputerguy72

VT-x is enabled and has been confirmed. Recently the laptop had Ubuntu X64 12.04 installed. The VT-x setting was not changed. I have also confirmed that Hyper-V is not enabled either. After installing Windows 8.1 X64 on the same laptop the issue reared its ugly head.

comment:4 Changed 7 years ago by c0mputerguy72

  • Status changed from closed to reopened
  • Resolution worksforme deleted

VT-x is enabled and has been confirmed. Recently the laptop had Ubuntu X64 12.04 installed. The VT-x setting was not changed. I have also confirmed that Hyper-V is not enabled either. After installing Windows 8.1 X64 on the same laptop the issue reared its ugly head.

comment:5 Changed 7 years ago by frank

What do you mean by "VT-x is enabled and has been confirmed"? How do you confirm that VT-x is enabled? Please attach a VBox.log file from a VM session where you select less than 3.5GB guest memory.

Changed 7 years ago by c0mputerguy72

comment:6 Changed 7 years ago by c0mputerguy72

The problem has been replicated on two laptops (ASUS and Lenovo). Both with VT-x enabled although as in the VBox log Virtual Box says it can't see it, "CPU does NOT support HW virtualization." Log is attached. Thank you for looking into it.

comment:7 Changed 7 years ago by frank

The log file clearly says that VT-x is disabled in the BIOS. Please double-check the BIOS settings.

comment:8 Changed 7 years ago by c0mputerguy72

Frank..... I am sooo sorry and apologize for wasting your time. The VT-x was enabled and confirmed. What was causing the error was "trusted execution" was enabled under the Security section. When I disabled it, that fixed the problem. However, thank you for taking the time and looking into this issue.

Best Regards

comment:9 Changed 7 years ago by c0mputerguy72

This ticket can be closed.

comment:10 Changed 7 years ago by frank

  • Status changed from reopened to closed
  • Resolution set to worksforme

Thanks for this information.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use