VirtualBox

Ticket #12598 (closed enhancement: duplicate)

Opened 5 years ago

Last modified 4 years ago

No cancel button in creation wizards

Reported by: jxerome Owned by:
Priority: major Component: GUI
Version: VirtualBox 4.3.6 Keywords:
Cc: Guest type: other
Host type: Mac OS X

Description

There is no cancel button in the creation wizards (VM and disk). Therefore, if you click by mistake on the "new" button, or if you change your mind, you have no choice but to create a new VM or disk.

Attachments

creation-wizard.tiff Download (111.9 KB) - added by jxerome 5 years ago.
creation-wizard-2.tiff Download (120.2 KB) - added by jxerome 5 years ago.
creation-wizard-disk.tiff Download (144.0 KB) - added by jxerome 5 years ago.

Change History

Changed 5 years ago by jxerome

Changed 5 years ago by jxerome

Changed 5 years ago by jxerome

comment:1 follow-up: ↓ 5 Changed 5 years ago by frank

... or you press the escape key.

comment:2 Changed 5 years ago by jxerome

... if you're a virtualbox expert but in this case you don't need a wizard.

comment:3 Changed 5 years ago by frank

Sorry, this has nothing to do with VirtualBox. Escape is the standard key for aborting actions on every PC. That might be different from the Mac OS X guidelines, therefore I leave this ticket open.

comment:4 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Actually a duplicate of #12541.

comment:5 in reply to: ↑ 1 Changed 4 years ago by YAZombie

Replying to frank:

... or you press the escape key.

… or you could just consider that a UX is a system per se that must follow its own internal rules to be consistent, where the standards are only secondary and must be implemented in addition to said consistency. In this case (and many others in Virtualbox as far as I can tell), adding a "Cancel" button when a function requires or leaves the option of a mouse actions is merely a way to make the UX consistent. Their absence is an inconsistency.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use