VirtualBox

Ticket #12586 (closed defect: fixed)

Opened 15 months ago

Last modified 12 months ago

VirtualBox Manager crashes in Qt when re-starting guest export

Reported by: marshals Owned by:
Priority: major Component: VMM
Version: VirtualBox 4.3.6 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

VB-4.3.6 with a Windows Server 2003 guest on a Windows 7 Pro host. I can reproduce this every time with:

  • In VMM, select File and Export Appliance.
  • Select appliance and click on Next and Next and Export.
  • In progress popup, click on red X button and wait for it to cancel.
  • Click on Export again and Manager crashes.

If I debug, VS2008 tells me:

Unhandled exception at 0x555a3f89 in VirtualBox.exe: 0xC0000005: Access violation writing location 0x0000017c00000193.

and the top of the callstack is in QtCoreVBox4.dll.

I presume the VBox.log is of no use, it seems independent of which guest I export, but let me know if there's anything I can provide.

Attachments

VBoxSVC - reexport.log Download (1.4 KB) - added by marshals 15 months ago.
log after reexport crash
VBox.log Download (53.8 KB) - added by marshals 15 months ago.
fwiw
VirtualBox.dmp Download (70.0 KB) - added by marshals 14 months ago.
minidump
12586.vbox Download (6.7 KB) - added by marshals 14 months ago.
new vm

Change History

comment:1 Changed 15 months ago by VVP

yes, please, provide the VBox.log or other logging files. It may be useful anyway.

comment:2 Changed 15 months ago by frank

I guess the VBoxSVC.log file is more useful in that case.

comment:3 Changed 15 months ago by VVP

please, before clicking the second time on the button "export" check that VBoxSVC is alive (running). Also the VBoxSVC.log file is still needed.

comment:4 Changed 15 months ago by marshals

sorry for not noticing your notes - for some reason i am not being emailed of them

Changed 15 months ago by marshals

log after reexport crash

comment:5 Changed 15 months ago by marshals

according to Task Manager, VBoxSVC remained alive, even after the crash.

Changed 15 months ago by marshals

fwiw

comment:6 Changed 14 months ago by VVP

apologize for awaiting. I have checked this several times on a Windows 7 enterprise host (not on a Windows 7 Pro). But I can't reproduce the crash on release build. is it possible that you use debug build (you mentioned - "If I debug, VS2008 tells me...")?

comment:7 Changed 14 months ago by frank

marshals, can you provide a minidump for this crash?

comment:8 follow-up: ↓ 9 Changed 14 months ago by VVP

just in case, here information about creating minidump - https://www.virtualbox.org/wiki/Core_dump

comment:9 in reply to: ↑ 8 Changed 14 months ago by marshals

Replying to VVP:

just in case, here information about creating minidump - https://www.virtualbox.org/wiki/Core_dump

when it crashes, windows offers me the chance to debug. if i debug with vs2008, i get the chance to save a minidump, which i've done and i'll attach here. note that this is with a stock 4.3.6 release.

Last edited 14 months ago by marshals (previous) (diff)

Changed 14 months ago by marshals

minidump

comment:10 follow-up: ↓ 11 Changed 14 months ago by VVP

marshals, investigation of minidump didn't very help us. would you provide a full dump (kernel dump) for this crash?

comment:11 in reply to: ↑ 10 Changed 14 months ago by marshals

Replying to VVP:

marshals, investigation of minidump didn't very help us. would you provide a full dump (kernel dump) for this crash?

I ran procdump, then started VB and reproduced the crash:

C:\Users\marshals\ProcDump>procdump.exe -h -w -ma -mp VirtualBox.exe

ProcDump v6.00 - Writes process dump files
Copyright (C) 2009-2013 Mark Russinovich
Sysinternals - www.sysinternals.com
With contributions from Andrew Richards

Full dump and MiniPlus dump arguments are not compatible.


C:\Users\marshals\ProcDump>procdump.exe -h -w -ma VirtualBox.exe

ProcDump v6.00 - Writes process dump files
Copyright (C) 2009-2013 Mark Russinovich
Sysinternals - www.sysinternals.com
With contributions from Andrew Richards

Waiting for process named VirtualBox.exe...

Process:               VirtualBox.exe (13124)
CPU threshold:         n/a
Performance counter:   n/a
Commit threshold:      n/a
Threshold seconds:     n/a
Number of dumps:       1
Hung window check:     Enabled
Exception monitor:     Disabled
Exception filter:      *
Terminate monitor:     Disabled
Dump file:             C:\Users\marshals\ProcDump\VirtualBox_YYMMDD_HHMMSS.dmp

[14:29:42] Hung Window
Writing dump file C:\Users\marshals\ProcDump\VirtualBox_140131_142942.dmp ...
Writing 116MB. Estimated time (less than) 3 seconds.
Dump written.

Dump count reached.

I'll try to attach the dump.

Version 0, edited 14 months ago by marshals (next)

comment:12 Changed 14 months ago by marshals

I can't attach the dump to the ticket - it's 116M and the attachment limit is only 0.5M.

How can I get the dump to you?

comment:13 follow-up: ↓ 14 Changed 14 months ago by frank

Sorry, there is no anonymous FTP server available. Can you upload the dump to some hosting service and provide us the URL? Please don't forget to compress the file. If you don't want to have this link public you can also email me at frank _dot_ mehnert _at_ oracle _dot_ com. Thank you!

comment:14 in reply to: ↑ 13 Changed 14 months ago by marshals

Replying to frank:

If you don't want to have this link public you can also email me at frank _dot_ mehnert _at_ oracle _dot_ com.

Done - let me know if u don't get the link by email or cannot otherwise access the zip.

comment:15 follow-up: ↓ 16 Changed 14 months ago by VVP

thx, full dump was more informative, but anyway the reason of the failure is strange. I found the place in the code. It looks trivial. And I can't reproduce the crash on Win7 with 4.3.6 release. could you try to export a simple VM without any additional\extra settings? just create VM, attach any working VDI image to IDE and make export.

comment:16 in reply to: ↑ 15 Changed 14 months ago by marshals

Replying to VVP:

thx, could you try to export a simple VM without any additional\extra settings? just create VM, attach any working VDI image to IDE and make export.

here's what i did to create a vm:

  • new vm, name 12586, and create
  • choose fixed size hdd, 10G, and create

no other changes to settings from defaults. i chose 10G bcos that gives me enough time to subsequently cancel an export - ymmv. i then followed the original recipe to trigger the crash on re-export after cancel. i have reproduced this crash with these recipes on 2 different host pcs, (a) an i3220 running win7hp64bit and (b) a w3530 running win7pro64bit, both with vb-4.3.6.

i'll attach the vbox file from the w3530 pc, in case it is any use. since this is a fresh vm, there is no log file. i presume the vdi is not worth getting to you.

what else would you like me to do?

Last edited 14 months ago by marshals (previous) (diff)

Changed 14 months ago by marshals

new vm

comment:17 follow-up: ↓ 18 Changed 14 months ago by VVP

I suppose that something broken in CDROM export. Did your original VM contain CDROM too? If you don't need CDROM just remove it from VM and try export again. I hope it'll help.

comment:18 in reply to: ↑ 17 Changed 14 months ago by marshals

Replying to VVP:

I suppose that something broken in CDROM export. Did your original VM contain CDROM too? If you don't need CDROM just remove it from VM and try export again. I hope it'll help.

yes, that seems to be the problem. if i create the vm as above, then remove the cd-rom, i can cancel an export and re-export without a crash. when i add back a cd-rom, i can reproduce the crash as before.

so, i presume u have found the cause and can fix it now?

comment:19 Changed 14 months ago by VVP

it was fixed in svn.

comment:20 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.10.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use