VirtualBox

Ticket #12561 (closed defect: duplicate)

Opened 5 years ago

Last modified 22 months ago

With dual monitor setup, VirtualBox Crashes when in seamless mode and try to a phsical monitor is removed. Win7-64 host, linux guest

Reported by: zzxt Owned by:
Component: other Version: VirtualBox 4.3.4
Keywords: crash dual monitor Cc:
Guest type: other Host type: other

Description

How to reproduct. On a windows 7 64bit host with two physical monitor. Setup a VM with two Vmonitors, boot up the VM and login, then ctrl+L to go into seamless mode, each Vmonitor will use one physical monitor. Then disconnect one physcial monitor (by unplugging the cable), windows 7 will detect its gone. Then try click on anywhere inside the VM Vmonitor, it will hang, then crash.

However, if it is not in seamless mode when removing the physical monitor, it won't crash.

I don't think the graphic cards matters, I had this issue on a few different machines with nvidia/intel graphics.

This is especially anonying on laptops conntected to an external monitor. When I put the laptop to sleep, and go somewhere and wake up again without the external monitor, the VBox would crash.

I'm programmer, so if there's any information needed, I'm glad to help.

Change History

comment:1 Changed 5 years ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #12562.

comment:2 Changed 22 months ago by kler

I have a similar issue, and found a workaround.

In my case it's seems that it's not related to multiple displays, but to sound. My monitor is connected via displayport, and my monitor is also my default sound device.

Workaround is to disable sound in guest. I'm using my virtual environment for development, so in my case this is acceptable.

Settings -> Audio -> Uncheck: "Enable audio"

  • VirtualBox version: Version 5.1.26 r117224 (Qt5.6.2)
  • Host: macOS Sierra 10.12.6
  • Guest: Ubuntu 16.04.3 LTS

comment:3 Changed 22 months ago by pentagonik

The crash should be fixed with the latest test build, which is available here: https://www.virtualbox.org/wiki/Testbuilds

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use