Ticket #12513 (closed defect: fixed)

Opened 2 years ago

Last modified 20 months ago

3D acceleration in Ubuntu 13.10 guest broken - workaround -> fixed as of 11 March 2014, version 4.3.x and later

Reported by: DrRob Owned by:
Priority: minor Component: 3D support
Version: VirtualBox 4.3.6 Keywords: Ubuntu 13.10,
Cc: Guest type: Linux
Host type: Windows


I run Ubuntu inside VirtualBox on a Windows laptop. Until some months ago the 3D acceleration was working fine, which meant that the desktop effects were nice and slick, but something happened, I think when I upgraded to 13.10, and it broke.

Very long story shorter - a VirtualBox library was failing to load:

From Xorg.0.log: [ 25.572] (EE) AIGLX error: dlopen of /usr/lib/x86_64-linux-gnu/dri/ failed ( cannot open shared object file: No such file or directory)

I won't pretend that I fully understand what's broken, but it seems that ldconfig can't see the VirtualBox guest additions libraries that are in /opt/VBoxGuestAdditions-4.3.6/lib, which are linked from /usr/lib64/, two of which in turn are linked from /usr/lib/x86_64-linux-gnu/dri/.

Partly that seems to be because /usr/lib/x86_64-linux-gnu/dri/ isn't in the ldconfig paths (x86_64-linux-gnu_EGL.conf -> /etc/alternatives/x86_64-linux-gnu_egl_conf references /usr/lib/x86_64-linux-gnu/mesa-egl instead).

Also, even if these libs were in the right path for ldconfig, ldconfig doesn't seem to pick them up because their names don't begin with "lib".

I've no idea how this worked in an earlier version of Ubuntu, and I don't have time to reinstall an earlier version to find out.

For now I've cheated by adding:

export LD_LIBRARY_PATH=/usr/lib64

to the end of /etc/profile and rebooted. It's ugly but it has done the trick - 3D acceleration works again, and Ubuntu feels fast again.

Confusingly, after this change, the newly-written Xorg.0.log file /still/ contains the AIGLX error line quoted above.

However, /usr/lib/nux/unity_support_test -p reports a full list of "yes", whereas before it gave a "no" for "Not software rendered" and "Unity 3D supported".

Change History

comment:1 Changed 23 months ago by michael

The Additions installer assumes that if /usr/lib64 exists on a 64-bit system then it is the default location for libraries. Ubuntu does not normally use or have this directory. Any idea why it exists on your guest system?

comment:2 Changed 23 months ago by frank

If you have dlocate installed,

dlocate /usr/lib64

could provide a hint.

comment:3 Changed 21 months ago by nemasu

Just ran into the same problem...actually I don't see how everyone isn't. ldconfig will not pick up libraries that do not start with 'lib'.

Edit: If you're using systemd and kdm my workaround was adding a line to the kdm.service file like so ([Service] section):


Last edited 21 months ago by nemasu (previous) (diff)

comment:4 Changed 21 months ago by michael

An answer to the question we asked would still be nice.

comment:5 Changed 21 months ago by michael

  • Summary changed from 3D acceleration in Ubuntu 13.10 guest broken - workaround to 3D acceleration in Ubuntu 13.10 guest broken - workaround -> fixed as of 11 March 2014, version 4.3.x and later

This should be fixed now. A test build is available at

comment:6 Changed 20 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.10.

Note: See TracTickets for help on using tickets.
ContactPrivacy policyTerms of Use