VirtualBox

Ticket #1248 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

CPUID doesn't expose "SYSENTER/SYSEXIT" in spite of supporting it

Reported by: nurnware Owned by:
Priority: minor Component: other
Version: VirtualBox 1.5.6 Keywords: cpuid sysenter sysexit
Cc: Guest type: other
Host type: other

Description

Hi,

the CPUID-instruction passes through the cpu's name etc. but lacks the bit 11 (CPU_FEATURE_SEP) that indicates support for sysenter. I tried to alter a kernel that I have developed to skip the check for this particular bit and it worked. So there seems to be support for SYSENTER/SYSEXIT anyway.

best, nurnware

Change History

comment:1 Changed 6 years ago by frank

Actually this is not a bug but a feature. It might even seem that sysenter/sysexit work correctly but we disabled this feature for guests with intention. If I remember correctly, the reason is that our patch manager cannot track the IOPL if the guest is executing these instructions.

comment:2 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

Works as designed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use