VirtualBox

Ticket #12459 (new defect)

Opened 9 years ago

Last modified 6 years ago

Host-only adapter interface resets IP address back to default.

Reported by: GCPeters Owned by:
Component: network/hostif Version: VirtualBox 4.3.4
Keywords: Cc:
Guest type: Windows Host type: Windows

Description (last modified by vushakov) (diff)

There is an old defect #8796 that describes this same problem for an older version of Virtual Box. I don't want this issue to get lost under an old defect so I've created this new one since this was not an issue with the last 2 versions prior to 4.3.4.

Starting with my upgrade to v4.3.4, every couple of days I have to reset my host-only adapter's interface IP back to my user configured one of 192.168.56.1. It keeps resetting to 169.254.x.x, but only after a few days and I have not been able to identify any trigger.

Windows 7-64-bit with a hosted Windows 2008 R2 server. The previous version did not have this problem so hopefully this will help to identify the cause.

The reset of the DHCP settings for the host-only adapter remains intact, it's only the interface's IP address.

Change History

comment:1 Changed 9 years ago by GCPeters

I've noticed that the only time it resets is when the Host machine is restarted. Each time I reboot the Host machine I have to go in and reset the host-only adapter's interface IP.

comment:2 Changed 6 years ago by vushakov

  • Description modified (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use