VirtualBox

Ticket #12424 (closed defect: fixed)

Opened 15 months ago

Last modified 14 months ago

VMs cannot start

Reported by: Panos Kavalagios Owned by:
Priority: blocker Component: other
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

When you try to start a VM the following error occurs:

Failed to open a session for the virtual machine MS Windows XP.

VT-x is not available. (VERR_VMX_NO_VMX).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Attachments

VBox.log Download (29.5 KB) - added by Panos Kavalagios 15 months ago.
Zulu.log Download (80.8 KB) - added by fanZel 14 months ago.

Change History

Changed 15 months ago by Panos Kavalagios

comment:1 Changed 15 months ago by Panos Kavalagios

The bug seems to be an improved version of bug #12222. There you couldn't restore a VM. Now you can't even start it.

A workaround is to stick with version 4.2.20 that works perfect.

Last edited 15 months ago by Panos Kavalagios (previous) (diff)

comment:2 Changed 15 months ago by frank

You can fix your VM by executing

VBoxManage modifyvm "MS Windows XP" --longmode off

We have to check how we can fix such busted VM configurations automatically.

comment:3 Changed 15 months ago by Panos Kavalagios

Hello Frank,

Your workaround has worked and I was able to boot the VM, but apparently bug #12222 hasn't been fixed, as a restore attempt on a saved VM session produced the following error:

Failed to open a session for the virtual machine MS Windows XP.

Failed to load unit 'PATM' (VERR_SSM_STRUCTURE_MAGIC).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

back to 4.2.20 again, which seems to be the only workaround.

comment:4 Changed 15 months ago by Jacob Klein

I have been tracking a 'PATM' VERR_SSM_STRUCTURE_MAGIC error in:
Ticket #12414 ==> https://www.virtualbox.org/ticket/12414
No response yet from Frank or Oracle dev team. :-/

Version 1, edited 15 months ago by Jacob Klein (previous) (next) (diff)

comment:5 Changed 15 months ago by Panos Kavalagios

Jacob,

It looks like a duplicate of bug #12222. It has been re-opened twice. We are waiting the next release that might fix our issue. Let's keep the present issue only for the VM start issue, when VT-x is not enabled and the config reports longmode on.

comment:6 Changed 15 months ago by frank

The SSM issue is really a duplicate of #12222, the initial report in this ticket is not.

comment:7 Changed 15 months ago by Jacob Klein

Sorry for any confusion.

comment:8 Changed 15 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

The initial issue should be also fixed with VBox 4.3.6.

comment:9 Changed 15 months ago by Panos Kavalagios

Confirmed on many old Windows and Linux Guests. It works fine.

comment:10 Changed 14 months ago by fanZel

Don't know if the fix in 4.3.6 covers all variants of this issue. At least my Win XP guest still runs in the SSM error, c.f. Zulu.log

Changed 14 months ago by fanZel

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use