VirtualBox

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#12424 closed defect (fixed)

VMs cannot start

Reported by: Panos Kavalagios Owned by:
Component: other Version: VirtualBox 4.3.4
Keywords: Cc:
Guest type: Windows Host type: Linux

Description

When you try to start a VM the following error occurs:

Failed to open a session for the virtual machine MS Windows XP.

VT-x is not available. (VERR_VMX_NO_VMX).

Result Code: NS_ERROR_FAILURE (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Attachments (2)

VBox.log (29.5 KB ) - added by Panos Kavalagios 11 years ago.
Zulu.log (80.8 KB ) - added by fanZel 11 years ago.

Download all attachments as: .zip

Change History (12)

by Panos Kavalagios, 11 years ago

Attachment: VBox.log added

comment:1 by Panos Kavalagios, 11 years ago

The bug seems to be an improved version of bug #12222. There you couldn't restore a VM. Now you can't even start it.

Version 0, edited 11 years ago by Panos Kavalagios (next)

comment:2 by Frank Mehnert, 11 years ago

You can fix your VM by executing

VBoxManage modifyvm "MS Windows XP" --longmode off

We have to check how we can fix such busted VM configurations automatically.

comment:3 by Panos Kavalagios, 11 years ago

Hello Frank,

Your workaround has worked and I was able to boot the VM, but apparently bug #12222 hasn't been fixed, as a restore attempt on a saved VM session produced the following error:

Failed to open a session for the virtual machine MS Windows XP.

Failed to load unit 'PATM' (VERR_SSM_STRUCTURE_MAGIC).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

back to 4.2.20 again, which seems to be the only workaround.

comment:4 by Jacob Klein, 11 years ago

I have been tracking a 'PATM' VERR_SSM_STRUCTURE_MAGIC error in VirtualBox 4.3.4:
Ticket #12414 ==> https://www.virtualbox.org/ticket/12414
No response yet from Frank or Oracle dev team. :-/

Last edited 11 years ago by Jacob Klein (previous) (diff)

comment:5 by Panos Kavalagios, 11 years ago

Jacob,

It looks like a duplicate of bug #12222. It has been re-opened twice. We are waiting the next release that might fix our issue. Let's keep the present issue only for the VM start issue, when VT-x is not enabled and the config reports longmode on.

comment:6 by Frank Mehnert, 11 years ago

The SSM issue is really a duplicate of #12222, the initial report in this ticket is not.

comment:7 by Jacob Klein, 11 years ago

Sorry for any confusion.

comment:8 by Frank Mehnert, 11 years ago

Resolution: fixed
Status: newclosed

The initial issue should be also fixed with VBox 4.3.6.

comment:9 by Panos Kavalagios, 11 years ago

Confirmed on many old Windows and Linux Guests. It works fine.

comment:10 by fanZel, 11 years ago

Don't know if the fix in 4.3.6 covers all variants of this issue. At least my Win XP guest still runs in the SSM error, c.f. Zulu.log

by fanZel, 11 years ago

Attachment: Zulu.log added
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use