VirtualBox

Ticket #12417 (closed defect: fixed)

Opened 20 months ago

Last modified 17 months ago

CD Device attached to SATA blocks XP from booting => Fixed in SVN

Reported by: billsc26 Owned by:
Priority: trivial Component: virtual disk
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: Windows
Host type: Windows

Description

When a CD device is attached to the SATA interface, XP won't boot. Having an IDE CD attachment works as expected.

Attachments

VBox.zip Download (18.4 KB) - added by billsc26 20 months ago.
VBox2.zip Download (13.2 KB) - added by billsc26 20 months ago.

Change History

Changed 20 months ago by billsc26

comment:1 Changed 20 months ago by michaln

  • Priority changed from major to trivial
  • Status changed from new to closed
  • Resolution set to invalid

Windows XP does not support AHCI devices, which is why XP VMs are by default configured as IDE only. In other words, XP is expected to not work with SATA devices.

If you configured your VM differently and load some 3rd party AHCI drivers in the guest, but can't even bother mentioning such crucial piece of information in the bug description, I'm afraid we can't afford to waste time trying to guess what really may or may not be going on.

The "won't boot" synopsis is also not particularly clear. As far as we're concerned, XP is expected to not boot with SATA. If you do expect it to boot (e.g. because you have a physical system similarly configured with SATA devices and it does boot), then again please do not expect us to waste time trying to guess.

comment:2 Changed 20 months ago by billsc26

Wow. I expect that kind of attitude from users but not from admins/mods.

I am running the Intel 8.9.0.1023 SATA driver, thanks for asking. You know, the ones RECOMMENDED on page 81 of the 4.3.4 manual for XP.

Again, not sure how to be more clear about "won't boot". The OS boots just fine with a SATA hard drive and an IDE CD. Add a CD attachment to the SATA controller and the OS won't start. Black screen.

Last edited 20 months ago by billsc26 (previous) (diff)

comment:3 Changed 20 months ago by billsc26

  • Status changed from closed to reopened
  • Resolution invalid deleted

comment:4 Changed 20 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to invalid

I think you misunderstood the manual. The VirtualBox manual does not recommend to use Windows XP with a SATA driver at all. The manual only recommends to use the Intel AHCI driver if you think it's a good idea (and you really know what you are doing!) to use Windows XP with SATA at all which, again, is not recommended by the VirtualBox manual. The manual clearly states that there is no support for AHCI in Windows before Windows Vista.

Also please read michalns comment again. He wrote that Windows XP is not supposed to boot with a SATA CD drive. If you can prove the opposite on bare metal then please share your exact configuration, in particular your SATA CD device type, your SATA controller type and if you boot from a SATA CD drive or if you boot with a SATA CD drive attached. We think that both will not work on bare metal.

comment:5 Changed 20 months ago by billsc26

My secondary computer boots XP just fine with a SATA DVD drive. Yes, I had to load the AHCI drivers for XP but the point is the computer boots. Without the drivers, it doesn't see the DVD but my point is that it boots.

Vbox won't even let the OS boot with the CD attachment.

I did not say "boot from" CD. I don't know how to be much more clear:

  • Windows XP VM with a virtual HD on SATA and CD (empty or filled, doesn't matter) on IDE. Boots ok. This works fine on bare metal.
  • Windows XP VM (same one) after adding a virtual CD attachment to the SATA controller - frozen black screen and no boot. Can confirm this works fine on bare metal as well.

If you want to play the game of "it isn't supported" - fine, but there is no reason the OS should work with an IDE CD attachment and then not even boot with a SATA CD attachment.

comment:6 Changed 20 months ago by frank

  • Status changed from closed to reopened
  • Resolution invalid deleted

This isn't a game. The initial report was lacking vital information for an unusual configuration.

The reason that a guest would not boot with a SATA CD/DVD-ROM drive attached could be a guest OS bug. There are many known bugs, for instance the Windows 2000 bug which can prevent the installation of Windows 2000 in a VM, see the user manual section 12.3.3. This is only an example and has nothing to do with your SATA problem.

I still didn't see the information I requested, the type of your SATA DVD device and the type of your AHCI controller.

And I would also like to know when exactly the guest OS screen is frozen: shortly after showing the VBox logo, shortly after showing the Windows logo? And what happens if you try to boot Windows in safe mode?

comment:7 Changed 20 months ago by billsc26

I'm not trying to get crosswise with the process or be difficult, I'm sorry if I didn't provide the information required but it's because I didn't know what was needed or would be helpful. Or maybe I just didn't explain it very well.

On the bare metal machine, I think it's an ICH7R (ASUS P5WDG2 WS PRO). The DVD is a Plextor SATA DVD burner. I don't have the model number for the Plextor as I'm not at the machine. The machine was originally commissioned with XP and an add-in P-SCSI controller and DVD. When the SCSI controller failed, an IDE HD was installed. Some time later when a DVD was needed, an SATA DVD was added. I don't remember specifically, but I would imagine the SATA drivers were loaded at some point after XP was installed but before they were actually needed.

On the VM - When a SATA CD is added to the configuration and XP is booted, it seems to spend a little more time than "normal" in the bootloader (XP splash screen). The screen then goes black and the OS appears hung. While collecting information for this report, I just noticed that the OS does eventually boot. It takes about 10-15 minutes to get to the login screen and is unusually slow past that point (still waiting to try and get the desktop to come up).

The VM is "slow" as if there is an I/O problem, not a CPU problem - if that makes sense. When I look in the VBox log file, I see a bunch of messages like:

00:09:23.205060 AHCI#0P1: Flush returned rc=VERR_PDM_MEDIA_NOT_MOUNTED 00:09:37.363879 AHCI#0: Port 1 reset

Changed 20 months ago by billsc26

comment:8 Changed 20 months ago by michaln

  • Component changed from other to virtual disk

Yes, the problem is reproducible. It is triggered by a failing ATAPI packet command, which typically occurs when no disc is in the drive. For some reason, the guest driver gets confused and times out. The driver sees the error and stops submitting commands but keeps waiting for something to happen.

The workaround is trivial... don't use a SATA CD-ROM with Windows XP guests. There is no real benefit over an IDE CD-ROM.

comment:9 Changed 19 months ago by michaln

Found the problem -- when a command failed, the guest driver got confused about which command that was. It didn't handle the error condition at all and kept waiting for the failed command to complete. Easy to fix once the problem was found...

comment:10 follow-up: ↓ 12 Changed 19 months ago by frank

And here is a test build containing the fix. Could you verify that the bug is fixed?

comment:11 Changed 18 months ago by frank

  • Summary changed from CD Device attached to SATA blocks XP from booting to CD Device attached to SATA blocks XP from booting => Fixed in SVN

comment:12 in reply to: ↑ 10 Changed 18 months ago by toasterking

I had all the same symptoms as @billsc26 with Windows XP SP3 as the guest but running on Mac OS X 10.6.8 as the host. Obviously, I could not use the test build for Windows on my host system, but I can confirm that the problem is present in 4.3.6 and is absent in 4.3.8_RC1 r92386. Thanks, @michaln and @frank!

For the first time, I am now able to run DVDFab for Windows in a Windows XP guest with VirtualBox! (It doesn't work properly with IDE passthrough but does with SATA passthrough.)

comment:13 Changed 17 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fix is part of VBox 4.3.8.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use