VirtualBox

Ticket #12399 (closed defect: duplicate)

Opened 9 years ago

Last modified 6 years ago

VBOX_E_OBJECT_NOT_FOUND error attaching a vhdx on a new VM

Reported by: mdapri Owned by:
Component: virtual disk Version: VirtualBox 4.3.2
Keywords: vhdx Cc:
Guest type: Windows Host type: Windows

Description

Hello, I have a disk created using Windows 8 Hyper V, with Windows server 2012 installed as a guest os. To use the disk I have created via the wizard a new VM with type and version Windows 2012 64 bit, gave it 10GB memory, and told to use an existing hard drive. Selecting the VHDX file and giving the OK, the error occurs


Failed to open the hard disk file F:\VM SP2013\SP2013-Baseline\Virtual Hard Disks\SP2013-Baseline.vhdx.

Could not open the medium 'F:\VM SP2013\SP2013-Baseline\Virtual Hard Disks\SP2013-Baseline.vhdx'.

VD: error VERR_NOT_SUPPORTED opening image file 'F:\VM SP2013\SP2013-Baseline\Virtual Hard Disks\SP2013-Baseline.vhdx' (VERR_NOT_SUPPORTED).

Result Code: E_FAIL (0x80004005) Component: Medium Interface: IMedium {05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} Callee: IVirtualBox {fafa4e17-1ee2-4905-a10e-fe7c18bf5554} Callee RC: VBOX_E_OBJECT_NOT_FOUND (0x80BB0001)


a similar problem seemed to be fixed with version of VBox 4.2.14.

below the VBoxSVC.log file content


VirtualBox COM Server 4.3.2 r90405 win.amd64 (Nov 1 2013 15:06:10) release log 00:00:00.000000 main Log opened 2013-11-27T15:49:00.247703100Z 00:00:00.000000 main Build Type: release 00:00:00.000000 main OS Product: Windows 8 00:00:00.000000 main OS Release: 6.2.9200 00:00:00.000000 main OS Service Pack: 00:00:00.015624 main DMI Product Name: Latitude E6430 00:00:00.015624 main DMI Product Version: 01 00:00:00.015624 main Host RAM: 16286MB total, 13891MB available 00:00:00.015624 main Executable: C:\Program Files\Oracle\VirtualBox\VBoxSVC.exe 00:00:00.015624 main Process ID: 824 00:00:00.015624 main Package type: WINDOWS_64BITS_GENERIC 00:00:00.015624 Loading settings file "C:\Users\mm.ddd/.VirtualBox\VirtualBox.xml" with version "1.12-windows" 00:00:00.031250 usbLibDevStrDrEntryGet: DeviceIoControl 1 fail winEr (31) 00:00:00.031250 usbLibDevStrDrEntryGet: DeviceIoControl 1 fail winEr (31) 00:00:00.291372 VDInit finished 00:02:17.064869 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Could not open the medium 'F:\VM SP2013\SP2013-Baseline\Virtual Hard Disks\SP2013-Baseline.vhdx'. 00:02:17.064869 VD: error VERR_NOT_SUPPORTED opening image file 'F:\VM SP2013\SP2013-Baseline\Virtual Hard Disks\SP2013-Baseline.vhdx' (VERR_NOT_SUPPORTED)}, preserve=false


Regards, Maurizio

Attachments

VBoxSVC.log Download (1.4 KB) - added by mdapri 9 years ago.
the VMware log

Change History

Changed 9 years ago by mdapri

the VMware log

comment:1 Changed 7 years ago by costinel

I have the same issue using latest released version 4.3.26 on windows 8.1 64bit.

steps to reproduce:

  1. download server 2012 r2 eval version from  http://www.microsoft.com/en-us/evalcenter/evaluate-windows-server-2012-r2
  1. create a vm and try to add existing vhdx file - it won't attach the vhdx.

it only works in hyper-v

VirtualBox COM Server 4.3.26 r98988 win.amd64 (Mar 16 2015 17:35:35) release log 00:00:00.006000 main Log opened 2015-04-20T18:55:25.290762400Z 00:00:00.006000 main Build Type: release 00:00:00.006000 main OS Product: Windows 8.1 00:00:00.006000 main OS Release: 6.3.9600 00:00:00.006000 main OS Service Pack: 00:00:00.029007 main DMI Product Name: X38-DQ6 00:00:00.038007 main DMI Product Version: 00:00:00.038007 main Host RAM: 4094MB total, 1059MB available 00:00:00.038007 main Executable: D:\Programs\virtualbox\VBoxSVC.exe 00:00:00.038007 main Process ID: 7780 00:00:00.038007 main Package type: WINDOWS_64BITS_GENERIC 00:00:01.153411 HostDnsMonitorProxy::notify 00:00:01.153411 HostDnsMonitorProxy: Host's DNS information updated: 00:00:01.153411 server 1: 192.168.13.1 00:00:01.153411 no search string entries 00:00:01.153411 domain: example.com 00:00:01.218414 VDInit finished 00:00:03.171525 USBPROXY usbLibDevStrDrEntryGet: DeviceIoControl 1 fail winEr (31) 00:01:03.022308 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Could not open the medium 'D:\IMAGES\10041.vhdx'. 00:01:03.023308 VD: error VERR_NOT_SUPPORTED opening image file 'D:\IMAGES\10041.vhdx' (VERR_NOT_SUPPORTED)}, preserve=false 00:01:41.770504 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={480cf695-2d8d-4256-9c7c-cce4184fa048} aComponent={Machine} aText={This machine does not have any snapshots}, preserve=false 00:02:32.216361 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Could not open the medium 'D:\IMAGES\10041.vhdx'. 00:02:32.216361 VD: error VERR_NOT_SUPPORTED opening image file 'D:\IMAGES\10041.vhdx' (VERR_NOT_SUPPORTED)}, preserve=false 00:02:42.405939 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Could not open the medium 'D:\IMAGES\2012r2_eval.vhdx'. 00:02:42.405939 VD: error VERR_NOT_SUPPORTED opening image file 'D:\IMAGES\2012r2_eval.vhdx' (VERR_NOT_SUPPORTED)}, preserve=false 00:08:18.733993 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={05f2bbb6-a3a6-4fb9-9b49-6d0dda7142ac} aComponent={Medium} aText={Could not open the medium 'D:\IMAGES\10041.vhdx'. 00:08:18.733993 VD: error VERR_NOT_SUPPORTED opening image file 'D:\IMAGES\10041.vhdx' (VERR_NOT_SUPPORTED)}, preserve=false

comment:2 Changed 7 years ago by costinel

I also get the same error using 4.3.x revision 99378

comment:3 Changed 7 years ago by aeichner

VHDX is supported readonly only so far. You need to convert it to a format which VirtualBox supports writing to like VDI, VHD or VMDK in order to attach it to a VM. This can be done using VBoxManage:

VBoxManage clonemedium disk <input VHDX> <output image>

comment:4 Changed 7 years ago by costinel

I need to directly open it for read/write access, not convert. Is there any hope for this to happen in the near future, at least for the simplest form of VHDX (not expandable, no snapshots, just a plain dump fixed size image stored in the vhdx format)?

Last edited 7 years ago by costinel (previous) (diff)

comment:5 Changed 6 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to duplicate

Closing as duplicate of #12616.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use