VirtualBox

Ticket #12359 (closed defect: fixed)

Opened 20 months ago

Last modified 5 months ago

Can't switch workspace on Linux host when guest in fullscreen

Reported by: isecore Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.2 Keywords:
Cc: Guest type: Windows
Host type: Linux

Description

Whenever the guest (in this case Windows 7) is running fullscreen (in my case with 2 monitors, one of each guest is replicated in fullscreen on my two physical monitors) I cannot hit right-ctrl and change workspace. Often times the guest menu (at the top) gets locked and/or I am completely "locked into" the guest without possibility to move out into the host except for shutting down the guest from within the VM.

This worked without a problem in 4.2.x. Also, whenever I run anything else on the host in fullscreen (youtube video, whatever) the guest VM decides for unknown reasons that I have unplugged all monitors and resizes guest-resolution seemingly randomly. Very annoying!

Change History

comment:1 follow-up: ↓ 9 Changed 20 months ago by michael

Regarding the first issue, I am surprised this worked before, as redirecting all keyboard input to the virtual machine is actually the intended behaviour. Pressing the host key combination to release the keyboard should help. By "the guest menu", do you mean the VirtualBox application window menu? What does "stuck" mean here?

Regarding guest monitor hot-plug there have been a number of fixes since 4.3.2 - you might want to try a test build to see if it improves things for you.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.3.3-90619-Linux_x86.run  http://www.virtualbox.org/download/testcase/VirtualBox-4.3.3-90619-Linux_amd64.run

comment:2 Changed 20 months ago by esogs

I'm seeing what I believe to be the same issue on Virtualbox 4.3.2 r90405

[home@desktop[ 8:47AM]] cat /etc/*-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=15
DISTRIB_CODENAME=olivia
DISTRIB_DESCRIPTION="Linux Mint 15 Olivia"
NAME="Ubuntu"
VERSION="13.04, Raring Ringtail"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 13.04"
VERSION_ID="13.04"
CINNAMON_VERSION=1.8.8
  1. Two monitors
  2. Linux Mint, 4 workspaces, CTRL-ALT-RIGHT-ARROW, CTRL-ALT-LEFT-ARROW moves between workspaces, or other key combinations jump me from workspace 1-4.
  3. Start Virtualbox on workspace 3, I have that on my guest monitor
  4. Start a VM, it starts up on workspace 3 on my main monitor
  5. As long as the windows isn't in full screen mode, and as long as my mouse focus is not in the VM, I can use key combinations to switch workspaces.
  6. Enabling full screen mode, and moving my mouse to a focus that isn't on the vm, and using key combinations to switch workspaces, no longer allows me to switch workspaces. It looks like it attempts to, but virtualbox workspace 3 continually stays as the primary workspace.
    • Note, the windowing options for the VM window are "Only on this workspace", which usually prevents a window from moving to the new workspace when you switch to it.

This worked for other versions of VirtualBox.

Last edited 20 months ago by esogs (previous) (diff)

comment:3 Changed 20 months ago by michael

Are you sure that you pressed the host key or key combination before trying to switch work-spaces to release the virtual machine's keyboard capture?

comment:4 Changed 20 months ago by frank

  • Priority changed from critical to major

comment:5 Changed 20 months ago by jmagder

I've had the same problem using a single monitor. The host OS is Linux Mint 15 running cinnamon. I am running Virtual Box 4.3.2. When I have a full screen guest (Windows/Linux), I press the 'right ctrl' key. I can then press alt tab in an attempt to switch between programs. I will see my host OS task switcher appear as it should. However, if I then select another task from the task switcher, it will only appear briefly (less than a second), and then recede to the background.

The same thing happens if I attempt to switch desktops with the 'Ctrl Alt Left/Right Arrow' key combination after hitting the right CTRL button. The non-virtual machine workspace will appear briefly, but the full screen virtual machine again steals focus.

My only workaround is to "right CTRL F" to leave full screen, and then proceed as normal.

Last edited 20 months ago by jmagder (previous) (diff)

comment:6 Changed 20 months ago by jmagder

I tried this on another install running Mint 14, and the issue no longer happens. So this may be Mint 15 specific.

comment:7 Changed 19 months ago by esogs

With regard to the question by Michael about pressing the host key, yes, I've tried that too, but that isn't the issue. It is something that was introduced on 4.3.2 r90405 (or somewhere in that range) I think, as again, it worked fine for a couple of years on prior versions of virtualbox and linux mint. I haven't upgraded mint in a while.

I have the same symptoms as jmagder though, with the non-virtual machine workspace appearing briefly, but the full screen virtual machine stealing the focus back and keeping me on the desktop where virtualbox was started.

It is only when we do "full screen" mode on virtualbox. I can report it also is still an issue on: 4.3.4.r91027

comment:8 Changed 19 months ago by pookey

I'm also seeing this in Mint with the 4.3.4-91027~Ubuntu~raring

comment:9 in reply to: ↑ 1 Changed 19 months ago by isecore

Yes, of course I am aware of that and that's how it always been. Keyboard and mouse input is automatically grabbed when the guest window is active. However, previously I was able to press the host key (right ctrl) to release it even in fullscreen, and then be able to switch to another workspace. This is no longer possible.

I believe I mean the application window menu that drops drop from the top. Another (related?) bug is that when I switch the guest VM to fullscreen, Virtualbox ends up "fighting" for who's on top with my Cinnamon taskbar. Very annoying, and it also causes the guest VM to crawl to a slow pace, so slow the application window menu cannot drop down and I cannot shut down the guest from inside it either, forcing me to ctrl-alt-f1 to a TTY and killing it from there.

The monitor hotplug-bug inside the guest VM is still there. Running 4.3.4 r91027 with the latest guest additions inside my Windows guest-VM.

Replying to michael:

Regarding the first issue, I am surprised this worked before, as redirecting all keyboard input to the virtual machine is actually the intended behaviour. Pressing the host key combination to release the keyboard should help. By "the guest menu", do you mean the VirtualBox application window menu? What does "stuck" mean here?

Regarding guest monitor hot-plug there have been a number of fixes since 4.3.2 - you might want to try a test build to see if it improves things for you.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.3.3-90619-Linux_x86.run  http://www.virtualbox.org/download/testcase/VirtualBox-4.3.3-90619-Linux_amd64.run

comment:10 Changed 19 months ago by taidoka

I'm having similar issues with any version later than 4.2.18: https://www.virtualbox.org/ticket/12407

Last edited 19 months ago by taidoka (previous) (diff)

comment:11 Changed 19 months ago by shek

I think I raised the same issue when the beta testing for 4.3 was going on. Unfortunately, we couldnt root cause it then. Maybe the devs can take another stab at it. The problem seems to be cinnamon centric I think.

BTW, a workaround does exist... when trying to change the workspace with host key shortcuts, long press the combination. I have mentioned that in the beta thread below.

 https://forums.virtualbox.org/viewtopic.php?f=15&t=57786&sid=94b07c85a1c0a44c0498a4f2665d1299

comment:12 Changed 18 months ago by Nikorasu

I'm running cinnamon 2.0.14-2 (the latest from the Arch repos) and I have the same issues as isecore: I also find trouble changing workspaces in fullscreen; VirtualBox "fights" for the top of the screen with not just the cinnamon panel but other windows, too; and I often need to use another TTY or reboot if I get "stuck" in the VM when the host key doesn't respond.

At least for me, the changing workspace issue may be a symptom of a similar issue which is that, at times, the host key doesn't seem to respond at all. I can hit HOST+F to try and exit fullscreen or HOST+HOME to try and bring up the VirtualBox menu but nothing happens.

Additionally, I notice that my left windows key does not get captured by VirtualBox. That is, when I hit my left windows key, the Cinnamon menu pops up, even when my input is supposed to be captured. I mention this because it may be related.

comment:13 Changed 18 months ago by esogs

Note that upgrading Mint didn't change anything.

The behavior only exhibits when VirtualBox is in full screen mode, and it didn't happen on earlier versions of VirtualBox with Linux Mint.

home@desktop # cat /etc/*-release
DISTRIB_ID=LinuxMint
DISTRIB_RELEASE=16
DISTRIB_CODENAME=petra
DISTRIB_DESCRIPTION="Linux Mint 16 Petra"
NAME="Ubuntu"
VERSION="13.10, Saucy Salamander"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 13.10"
VERSION_ID="13.10"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

Last edited 18 months ago by esogs (previous) (diff)

comment:14 follow-up: ↓ 15 Changed 17 months ago by Bo

Add me to the list.

  • Host: Linux Mint 16
  • Guest: Windows 7 (doesn't matter)
  • Guest Additions Version: 4.3.6r91406

If I place the Guest in Workspace2 while in Fullscreen Mode, attempting to switch to Workspace1 fails. Pressing CTRL+ALT+UParrow key displays the Workspaces as normal. However, when I attempt to select Workspace1, it is momentarily selected and immediately reverts back to Workspace2.

This feature worked not too long ago and hope it can be restored. Great job with VirtualBox. Thanks for it and keep up the great work.

Last edited 17 months ago by Bo (previous) (diff)

comment:15 in reply to: ↑ 14 Changed 17 months ago by Rodney-Tx

Replying to Bo:

This is definitely new behavior with VBox 4.3. The only way I can get it to switch workspaces is to hit the host key (right-CTRL) and then press and hold CTRL-ALT-LEFTARROW until the workspace switches (it jumps back an forth but will finally stick - very annoying.

Add me to the list.

  • Host: Linux Mint 16
  • Guest: Windows 7 (doesn't matter)
  • Guest Additions Version: 4.3.6r91406

If I place the Guest in Workspace2 while in Fullscreen Mode, attempting to switch to Workspace1 fails. Pressing CTRL+ALT+UParrow key displays the Workspaces as normal. However, when I attempt to select Workspace1, it is momentarily selected and immediately reverts back to Workspace2.

This feature worked not too long ago and hope it can be restored. Great job with VirtualBox. Thanks for it and keep up the great work.

comment:16 Changed 17 months ago by shek

Reporting this fixed in 4.3.8

comment:17 Changed 17 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the report!

comment:18 Changed 5 months ago by Bo

This issue appears to have been fixed. I am running the latest VirtualBox Version 4.3.22 r98236.

Issuing a CTRL+ALT+Left/RightArrow keyboard command from within the VirtualBox Guest (Windows7 in my case) does NOTHING unless the Host Key is first pressed. It seems VB would better serve by just inherently allowing the CTRL+ALT+Arrow keys to work regardless of what capture mode is selected.

Regardless, VB keeps getting better. Thanks!

Last edited 5 months ago by Bo (previous) (diff)

comment:19 Changed 5 months ago by michael

I'm afraid that this will probably not change, since the whole point of capturing is to allow the guest to handle all special combinations of that sort itself. The usual solution if you want the guest to get most key strokes but not special ones like that is to disable keyboard capturing globally.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use