VirtualBox

Ticket #12270 (closed enhancement: duplicate)

Opened 6 months ago

Last modified 6 months ago

Option to show host-side mouse cursor during mouse integration

Reported by: m00k0w Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.0 Keywords: UI user interface
Cc: Guest type: Linux
Host type: Windows

Description

The user is loading multiple instances of Android x86 at once. With mouse integration on, there is no visible cursor as Android does not show one in this case, and Virtualbox hides the Windows cursor. The clicks register but the cursor is invisible.

With mouse integration disabled, Android x86 shows a visible mouse cursor - the issue is it mouse acceleration or otherwise non-linear input, which leads to the non-visible host cursor, and guest cursor, not synchronizing in position. They are initially aligned when the mouse is moved very slowly, but if the mouse is moved at a normal pace, they will offset, and the host mouse will stop controlling the virtual mouse, leaving the frame before the virtual mouse reaches the edge of the frame. It is then not easy at all to align the mice again. This happens very easily and makes it entirely unusable with mouse integration off. Other guest OS's could possibly behave this way.

As well, even if the cursors were synchronized, quickly clicking across several different windows means an extra click is required to transfer focus to each instance.

Therefore, the best method of use is with mouse integration enabled, and with an option to have the host cursor visible. There is no reason to force it to be hidden; Is there a known quick workaround to make a windows mouse cursor unhidable?

Change History

comment:1 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Please do NOT open duplicates!

comment:2 Changed 6 months ago by m00k0w

It's a duplicate because the issue was not explained thoroughly in the other thread, nor was there a resolution. The problem is on Oracle's side, and has nothing to do with android. The bug is the assumption that every case of mouse integration use should involve hiding the host-side cursor. It shouldn't.

comment:3 Changed 6 months ago by michael

Have you tried contacting the Android developers to find out why they hide the guest cursor when they detect an absolute mouse device? I see no reason to do this unless a touch screen (and no mouse) is detected.

With mouse integration disabled host and guest mouse position are not expected to be the same. The host cursor should be hidden and the guest one visible, and the host cursor should never "break out" of the guest window - it should be possible to move the guest cursor to any position within the guest window providing that the guest implements things in a reasonable way. Are you seeing something different?

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use