VirtualBox

Ticket #1226 (closed defect: fixed)

Opened 6 years ago

Last modified 8 months ago

x64 Vista host BSD when connecting USB Wi-Fi adapter to WinXP SP2 guest

Reported by: L38Crow Owned by:
Priority: critical Component: USB
Version: VirtualBox 1.5.6 Keywords: BSD USB Wi-FI Vista x64 Windows XP Crash
Cc: Guest type: other
Host type: Windows

Description (last modified by frank) (diff)

I have Windows Vista Business (Aero enabled) x64 installed as HOST (With updates til Feb 08), Intel Core 2 Quad 6400, 4GB RAM. VirtualBox 1.5.6 x64 installed. Guest OS: Windows XP Service Pack 2 + Updates

When connecting my USB Wi-Fi adapter (D-Link DWL-G122 HW:C1) while guest OS is active gives Blue Screen of Death (formely BSD) on the host (Vista) OS.

I'm able to reproduce a problem 2 times. It's happends after I connect my USB adapter while Guest OS is in focus.

Attachments

Mini022208-01.dmp Download (264.0 KB) - added by L38Crow 6 years ago.
Mini022208-02.dmp Download (264.0 KB) - added by L38Crow 6 years ago.
VBox.log Download (42.4 KB) - added by mludwig 6 years ago.

Change History

Changed 6 years ago by L38Crow

Changed 6 years ago by L38Crow

comment:1 Changed 6 years ago by sandervl73

See tickets 1111 and 1245 as well.

Changed 6 years ago by mludwig

comment:2 Changed 6 years ago by mludwig

I also experienced the same BSD on Vista64 host, XP32 guest. If hardware virtualization is enabled, the guest dies with BSD, if disabled, the host does. The host BSDs had the code 0x3B, and 0xA.

comment:3 Changed 6 years ago by mludwig

I just want to add, that the BSD only happened when a USB device was connected.

comment:4 Changed 6 years ago by sandervl73

  • Host type changed from other to Windows

comment:5 Changed 6 years ago by frank

  • Component changed from other to USB

comment:6 Changed 5 years ago by sandervl73

See also #993.

comment:7 Changed 5 years ago by icstrasher

I had the same problem.

I think the problem is because the drivers for the usb are not for Vista x64 or can anyone say me where I can find the USB drivers (Windows ask you if you want to install the drivers I pressed Automatic but he cant find it and i thought it must be in

"C:\Program Files\Sun\Virtualbox\drivers\USB\"

but Windows cant find the drivers

comment:8 Changed 5 years ago by sandervl73

l38crow: the crash happens because afd.sys triggers a breakpoint. Is that the driver for your USB wifi device?

comment:9 Changed 5 years ago by icstrasher

Maybe I installed WinXP 32bit now and it works!

But when I add a USB while virtualbox is on. (example: USB-Stick) First virtualbox installing a driver , successful. But it doesent appaers. I must close Virtualbox because the error crash my Computer. But not so fatal than in Vista x64 because in Vista 64x it crash and you must shutdown your computer ACPI.

In XP it crash the proccess.

comment:10 Changed 8 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

Please reopen if still relevant with VBox 4.2.16.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use