VirtualBox

Ticket #12254 (closed defect: fixed)

Opened 18 months ago

Last modified 5 months ago

Guru Meditation (VERR_TRPM_DONT_PANIC) VBox 4.3 fails to load the VM

Reported by: spyrus Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.0 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description


Attachments

VBox.zip Download (54.0 KB) - added by spyrus 18 months ago.
VBox.png Download (29.8 KB) - added by spyrus 18 months ago.

Change History

Changed 18 months ago by spyrus

Changed 18 months ago by spyrus

comment:1 Changed 18 months ago by frank

Did you disable VT-x for this VM or is VT-x just disabled in the BIOS?

comment:2 Changed 18 months ago by spyrus

Hardware Virtualization in VirtualBox is disabled but that setting was there from the beginning when i have created the machine (back in 4.0.x release or earlier) Last update to 4.3 has the problem on the same machine with untouched settings

comment:3 Changed 18 months ago by frank

Did you disable VT-x for your VM by intention? Please try to enable it.

comment:4 Changed 18 months ago by frank

Sorry for the stupid question, I missed your last comment before. That is indeed a bug but enabling VT-x is still preferred.

comment:5 Changed 18 months ago by spyrus

Ok it worked by enabling VT-X and paging (i have Core i7). The machine though cannot be shutdown still, but that is an old bug. If interested check that link  https://forums.virtualbox.org/viewtopic.php?f=6&t=31658

comment:6 Changed 18 months ago by frank

  • Summary changed from VBox 4.3 fails to load the VM to Guru Meditation (VERR_TRPM_DONT_PANIC) VBox 4.3 fails to load the VM

comment:7 Changed 6 months ago by mpack

I've seen this reported a few times recently. Here is a recent example involving 4.3.18. Same error and same scenario in that VT-x is enabled in the VM (probably for legacy reasons) but disabled in the BIOS.

 https://forums.virtualbox.org/viewtopic.php?f=6&t=64211

comment:8 Changed 6 months ago by mpack

Here's another one from today. Almost the same scenario, except this user's 64bit Intel CPU doesn't support VT-x at all. He also suggests that preventing his guests drive from sleeping bypasses the issue.  https://forums.virtualbox.org/viewtopic.php?f=6&t=64220

Last edited 6 months ago by mpack (previous) (diff)

comment:9 Changed 6 months ago by frank

Hi mpack, all VBox.log files which involve 'acpiPMTmrRead' are a duplicate of #13521. This problem is a 4.3.18 regression and happens only with VT-x/AMD-V disabled/not available.

Other tickets (like this one, see the original VBox.log file) have PDMQueueInsert in the lines right below the Guru meditation description. These reports don't describe a regression but actually a problem with the LsiLogic emulation. Also does only happen if VT-x/AMD-V is not available.

comment:10 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in VBox 4.3.20.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use