VirtualBox

Ticket #12222 (closed defect: duplicate)

Opened 6 months ago

Last modified 4 months ago

Failed to load unit 'PATM' (VERR_SSM_FIELD_NOT_CONSECUTIVE) => Fixed in SVN

Reported by: franciscocedeno3 Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.4 Keywords:
Cc: Guest type: other
Host type: other

Description

Fallo al abrir una sesión para la máquina virtual Windows XP SAP11.

Failed to load unit 'PATM' (VERR_SSM_FIELD_NOT_CONSECUTIVE).

Código Resultado: NS_ERROR_FAILURE (0x80004005) Componente: Console Interfaz: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

Attachments

VBox.log Download (79.6 KB) - added by manfredsch 6 months ago.
Log of a crashed boot attempt
VBox_GVC.log Download (77.7 KB) - added by geertvc 6 months ago.
VirtualBox log file created when failed to (re)load saved session.
2013-11-02 13_37_03-VirtualBox - Error.jpg Download (23.9 KB) - added by geertvc 6 months ago.
VBox.2.log Download (48.1 KB) - added by Gurvender.Bahia 6 months ago.
XP guest, unable to restore Saved State

Change History

comment:1 Changed 6 months ago by franciscocedeno3

Reestablece la imagen guardada pero cuando llega a 100% manda la notificacion de error y no entra a windows.

Saludos

comment:2 Changed 6 months ago by michael

  • Summary changed from Fallo Virtual Box 4.3 to Failed to load unit 'PATM' (VERR_SSM_FIELD_NOT_CONSECUTIVE)

Translation of comment 1: restoring a saved state caused the error in the description on reaching 100% and Windows failed to start.

Please, a bit more information - in particular how to reproduce this error - and a log file would be helpful. It would also be helpful to write in English as I don't think the people likely to be able to help with this speak Spanish.

comment:3 Changed 6 months ago by izico

The same on my PC.

Host: Kubuntu Linux 13.10 and 13.04 Guest: Windows 7 Professional and Ultimate

4.2.18 works well, but the new 4.3.0 has this problem; and worse, after uninstall 4.3.0 and reinstall 4.2.18, the Windows 7 guests tend to crash either in normal shutdown or hibernate.

The problem is the same on either Kubuntu 13.10 or 13.04 host, and either Windows 7 professional or Ultimate guest.

comment:4 Changed 6 months ago by EuLeEr

The same on my PC. Host Windows 8.1 - guest UBUNTU 12.04

comment:5 Changed 6 months ago by ackwell

I've had this issue with Host: Windows 7 SP1, Guest: CrunchBang Linux (Debian derivative), testing branch. I posted this issue here:  http://superuser.com/questions/663088/virtualbox-savestate-resume-error-verr-ssm-field-not-consecutive

comment:6 Changed 6 months ago by ackwell

I seem to have fixed it in the above scenario. It would seem to be linked to the host's virtualisation capabilities. Enabling Intel Virtualisation Technology in BIOS settings seems to have cleared up the issue.

Changed 6 months ago by manfredsch

Log of a crashed boot attempt

comment:7 Changed 6 months ago by manfredsch

Same here after upgrading from 4.2.18 to 4.3. Host is x86_64 (core2), guest is Windows2000.

Crash does only happen when restoring a snapshot, doing a clean boot is OK.

I have attached a log file, for completeness.

comment:8 Changed 6 months ago by Petr Vones

Same issue. Windows Server 2008 x86 host (Intel Pentium E2160  http://ark.intel.com/products/29739/Intel-Pentium-Processor-E2160-1M-Cache-1_80-ghz-800-mhz-fsb, no VT-x support), Windows XP x86 guest.

Last edited 6 months ago by Petr Vones (previous) (diff)

comment:9 Changed 6 months ago by ramshankar

  • Summary changed from Failed to load unit 'PATM' (VERR_SSM_FIELD_NOT_CONSECUTIVE) to Failed to load unit 'PATM' (VERR_SSM_FIELD_NOT_CONSECUTIVE) => Fixed in SVN

comment:10 follow-up: ↓ 11 Changed 6 months ago by ramshankar

This issue has been fixed in SVN, fix will be available in the next VirtualBox 4.3.x maintenance release.

comment:11 in reply to: ↑ 10 Changed 6 months ago by sergiomb

Replying to ramshankar:

This issue has been fixed in SVN, fix will be available in the next VirtualBox 4.3.x maintenance release.

Hi, I see this general , huf ! , Could you point me what commits fixes this and/or when where we have a new release ?

Thanks,

Last edited 6 months ago by sergiomb (previous) (diff)

comment:12 Changed 6 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.2. The relevant changeset is r49247.

Changed 6 months ago by geertvc

VirtualBox log file created when failed to (re)load saved session.

Changed 6 months ago by geertvc

comment:13 Changed 6 months ago by geertvc

Problem is NOT solved yet, unfortunately...

Just installed VirtualBox 4.3.2 (including an update of the VirtualBox Guest Additions). According to the release notes, the bug 12222 (VMM: fixed PATM saved state incompatibility for software virtualized VMs (bug #12222)) should be solved.

I've tried out the new version and the problem remains, be it with another error message this time. See attached image:

2013-11-02 13_37_03-VirtualBox - Error.jpg

2013-11-02 13_37_03-VirtualBox - Error.jpg (23.91 KiB) Viewed 92 times

Where the error message previously was "VERR_SSM_FIELD_NOT_CONSECUTIVE", this time it's "VERR_SSM_LOADED_TOO_MUCH" that I see when I want to restart a saved session.

I've also attached the corresponding Vbox_GVC.log file (renamed file since a log file with same name already exists), in which I see another error message, prior to the one given above:

"00:00:05.201750 AIOMgr: Preparing flush failed with VERR_NOT_SUPPORTED, disabling async flushes".

Don't know if there's a relation between the two, though...

The above is similar to the reply I posted on my own message thread (see  https://forums.virtualbox.org/viewtopic.php?p=270622#p270622).

comment:14 Changed 6 months ago by Gurvender.Bahia

  • Status changed from closed to reopened
  • Resolution fixed deleted

Installed 4.3.2

Still unable to restore SAVED STATE

Host: Ubuntu 12.04 Guest: XP sp3 (used to work fine in 4.2.18)

error: Failed to open a session for the virtual machine XP_001.

No error info.

Result Code: NS_ERROR_CALL_FAILED (0x800706BE) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

Changed 6 months ago by Gurvender.Bahia

XP guest, unable to restore Saved State

comment:15 Changed 6 months ago by pipk

I have the identical error and log as the above. 4.3.0 restores failed and after upgrade to 4.3.2:

Result Code: NS_ERROR_CALL_FAILED (0x800706BE) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

on attempted restore. Host is Solaris x86 (openindiana) and guests WinXP and Linux.

comment:16 Changed 6 months ago by manfredsch

Same here: VERR_SSM_LOADED_TOO_MUCH

I did a proper shutdown of the VM, upgraded to 4.3.2, started VM (everything OK), went to savestate, when resuming => bang, hitting an assert.

The relevant snipplet of the log:

00:00:03.615271 TM: cTSCTicksPerSecond=0x65cd7700 (1 707 964 160) fTSCVirtualized=true  fTSCUseRealTSC=false (state load)
00:00:03.652239 AssertLogRel /home/vbox/vbox-4.3.2/src/VBox/VMM/VMMR3/SSM.cpp(6212) int ssmR3DataReadBufferedV2(SSMHANDLE*, void*, size_t): !pSSM->u.Read.fEndOfData
00:00:03.652268 cbBuf=8SSM: LoadExec failed for 'PATM' instance #0 (version 55, pass 0xffffffff): VERR_SSM_LOADED_TOO_MUCH
00:00:03.652312 VMSetError: /home/vbox/vbox-4.3.2/src/VBox/VMM/VMMR3/SSM.cpp(8275) int ssmR3LoadExecV2(VM*, SSMHANDLE*); rc=VERR_SSM_LOADED_TOO_MUCH
00:00:03.652316 VMSetError: Failed to load unit 'PATM'

comment:17 follow-up: ↓ 19 Changed 6 months ago by sergiomb

With 4.3.2 Failed to load unit 'PATM'

Failed to open a session for the virtual machine ie8.

No error info.

Result Code: NS_ERROR_CALL_FAILED (0x800706BE) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

the biggest difference that I see from 4.3.0 to 4.3.2 , is in 4.3.2 can't try 2 times resume the vm , because on first attempt vm goes to state abort.

comment:18 Changed 6 months ago by Jacob Klein

I reported the VERR_SSM_LOADED_TOO_MUCH error as a new error, in Ticket #12291.

comment:19 in reply to: ↑ 17 Changed 5 months ago by sergiomb

Replying to sergiomb:

the biggest difference that I see from 4.3.0 to 4.3.2 , is in 4.3.2 can't try 2 times resume the vm , because on first attempt vm goes to state abort.

I have to corrected this sentence , on WindowsXP as guest vm aborts , but on windows 7 as guest don't , so it is possible that I don't have any difference between 4.3.0 and 4.3.2 .

take this opportunity to ask, if some fixes be made on svn to this issue , please let me know the changesets to test it individually with 4.3.2

Thanks,

comment:20 Changed 5 months ago by Panos Kavalagios

Same issue in Fedora 19 with 4.3.2. The restore of the VM reports the following error:


Failed to open a session for the virtual machine MS Windows XP.

No error info.

Result Code: NS_ERROR_CALL_FAILED (0x800706BE) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}


Panos

comment:21 Changed 5 months ago by jakeochs

same problem - Windows 7 host, Xubuntu 14.04 client

Failed to open a session for the virtual machine saucy.

Failed to load unit 'PATM' (VERR_SSM_LOADED_TOO_MUCH).

Result Code: E_FAIL (0x80004005) Component: Console Interface: IConsole {8ab7c520-2442-4b66-8d74-4ff1e195d2b6}

comment:22 Changed 5 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in 4.3.4. If you experience other SSM issues, please open a separate ticket.

comment:23 Changed 5 months ago by Panos Kavalagios

The issue has not been resolved in 4.3.4. Please to reopen.

comment:24 Changed 5 months ago by frank

  • Status changed from closed to reopened
  • Version changed from VirtualBox 4.3.0 to VirtualBox 4.3.4
  • Resolution fixed deleted

comment:25 Changed 5 months ago by sergiomb

Yeah , not solved in 4.3.4 , also got other regression , hopefully have workaround .

 https://forums.virtualbox.org/viewtopic.php?f=6&t=58820&sid=0e732cf6c057dbed1b2ef4033d5019ad

seems related with CPUs without visualization flag .

comment:26 Changed 4 months ago by frank

  • Status changed from reopened to closed
  • Resolution set to duplicate

Should be fixed in VBox 4.3.6. Please continue the discussion in #12414.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use