VirtualBox

Ticket #12205 (closed defect: fixed)

Opened 6 months ago

Last modified 3 months ago

Cannot Delete "Inaccessible" virtual machines from Virtualbox GUI

Reported by: b3orion Owned by:
Priority: major Component: other
Version: VirtualBox 4.3.0 Keywords: inaccessible, delete
Cc: Guest type: all
Host type: Windows

Description

Inaccessible virtual machines cannot be deleted in 4.3. I have to downgrade to 4.2.18, delete the VM, and then re-upgrade to 4.3 every time I need to remove an inaccessible VM. Tested on Four PCs running Windows 7, 8, and 8.1. Intel and AMD CPUs tested as well with the same results.

Change History

comment:1 Changed 6 months ago by quickbooks

same problem here

comment:2 Changed 6 months ago by JFreakDK

I have the same issue on Linux Mint 13

comment:3 Changed 6 months ago by mscottford

I found a work around for this issue, that does not require downgrading to 4.2.x.

You can use the command line VBoxManage tool to remove inaccessible VMs. To get a list of VMs run:

VBoxManage list vms

The inaccessible ones will show up similar to:

"<inaccessible>" {52a91e62-096d-4f8b-96f4-5fa76db3cd76}

Now you use the GUID in the unregister command:

VBoxManage unregistervm {52a91e62-096d-4f8b-96f4-5fa76db3cd76}
Last edited 6 months ago by mscottford (previous) (diff)

comment:4 Changed 6 months ago by gggeek

Same problem here (win7 64bit host). Tested on version 4.3.2

comment:5 Changed 5 months ago by joris.roovers

Same problem (windows 7, 64 bit) - Virtualbox 4.3.4

comment:6 Changed 5 months ago by Rapid e-Suite

Same problem (windows 7, 64 bit) - Virtualbox 4.3.4 as well

comment:7 Changed 5 months ago by frank

Why is your VM inaccessible at all? Did you change the XML file with an editor?

comment:8 Changed 4 months ago by JDBurnZ

@frank, your question is a bit irrelevant. It doesn't matter to an end user *why* an error is being encountered, the fact is there is an error being thrown resulting in undesired / unexpected behavior.

"<inaccessible>" errors are generally encountered when the VM's configuration itself is no longer found due to data loss, renaming of a parent directory, or the file itself being deleted.

Until this is resolved in a future update of the VirtualBox application, here is a workaround:

Locate and edit your VirtualBox.xml file. Depending on your set up and operating system, this could be in a number of places.

  • If running windows, try looking in C:\Documents and Settings\[your-username]\.VirtualBox\ or C:\Users\[your-username]\.VirtualBox\
  • If running on a MAC, try looking in: [your-hardrive]/Users/[your-username]/Library/VirtualBox

Once you've located the file, edit it in your favorite text editor and find the line under <MachineRegistry> matching the name of the <inaccessible> VM you wish to remove. Delete the line and save.

You may need to make sure VirtualBox is closed before editing and saving the file.

Last edited 4 months ago by JDBurnZ (previous) (diff)

comment:9 Changed 4 months ago by frank

My question is not irrelevant as I want to know what users do to trigger this problem.

comment:10 Changed 4 months ago by klaus

Exactly, frank's question is very relevant, it's about what to test first, so that you get a quick fix for your actual problem and not one which happens to be nearby.

comment:11 Changed 4 months ago by Rapid e-Suite

"VBoxManage unregistervm" command also helped me get rid of inaccessible VM.

But unfortunately, I can't provide full log now as I have tried modify vbox file to get the VM working again, however, I have noticed the HardDisks section in vbox file seems corrupted and vbox.prev file have the same content hence I can't restore from vbox.prev file but now I'm trying to generate this section manually.

<MediaRegistry>

<HardDisks/> <DVDImages>

comment:12 Changed 4 months ago by frank

Hopefully fixed in 4.3.6. Please confirm.

comment:13 Changed 4 months ago by DaveOverton

4.3.6 running under Win7, and its not working still, used the command line tool

Version 0, edited 4 months ago by DaveOverton (next)

comment:14 Changed 4 months ago by klaus

If it's still not fixed then you have a different problem, and as long as no one tells us what the problem actually is this will hardly change. I'm not after a log file, the only thing which should matter is the content of the VM config file (please attach a complete one!), and why it's inaccessible (the full message shown by the GUI). The GUI might unintentionally handle certain cases differently.

I'm destroying the content of foo.vbox to make it inaccessible, and the GUI in 4.3.6 handled them exactly as expected, offering only unregistration (VBoxManage can't do anything else in this situation).

comment:15 Changed 3 months ago by b3orion

4.3.6 fixed it. Great! I've not used the bug tracker on here before, so do I have to mark it as solved now, somehow? If I have to change it, please help!

comment:16 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks b3orion, marking this ticket as fixed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use