VirtualBox

Ticket #12182 (closed defect: fixed)

Opened 23 months ago

Last modified 3 weeks ago

Failed to create the host network interface => Fixed in SVN

Reported by: wwirthtorres Owned by:
Priority: major Component: network
Version: VirtualBox 4.3.0 Keywords: host only adapter
Cc: Guest type: Windows
Host type: Windows

Description

I have two VMs that worked properly on v4.2.6. I upgraded vbox to 4.3 today and now can only start-up the VMs if I have a Bridged Adapter. The Host-Only adapter has defaults of IP: 0.0.0.0, Subnet 0.0.0.0 and will not save any changes (I tried updating to 192.168.56.1 and 255.255.255.0). When that didn't work I tried deleting and recreating the Host-Only adapter and received this error:

Failed to create the host network interface.

Assertion failed: [!aGuid.isValid()] at 'D:\tinderbox\win-4.3\src\VBox\Main\src-server\HostNetworkInterfaceImpl.cpp' (74) in long __cdecl HostNetworkInterface::init(class com::Bstr,class com::Bstr,class com::Guid,enum __MIDL___MIDL_itf_VirtualBox_0000_0000_0034).

Please contact the product vendor!.

Result Code: E_FAIL (0x80004005)
Component: HostNetworkInterface
Interface: IHostNetworkInterface {f6e556f9-d598-409b-898c-8ba99d9b05ae}

Although the adapter deleted here, as soon as I restarted Vbox, the default Host-only adapter was back. These VMs are a lab build that must be separated completely from both the internal network and the internet.

Attachments

VBoxInstallLog.txt.tar.bz2 Download (35.2 KB) - added by ldawson 9 months ago.
Installation log for windows 8.1 host with virtual box 4.3.20 - same problem

Change History

comment:1 Changed 23 months ago by wwirthtorres

Resolved by uninstalling VBox, rebooting, reinstalling VBox, rebooting.

When I upgraded to 4.3, I did not uninstall 4.2 first. Additionally, the 4.3 install did not require a restart after upgrading; however, I rebooted the system as part of troubleshooting with no results. The only fix that worked was to start from scratch.

comment:2 Changed 23 months ago by Jailout2000

I was also having this issue when I upgraded from 4.2.18 to 4.3. Host operating system is Windows 7 Home Premium x64. I will try the steps mentioned in comment 1.

comment:3 Changed 23 months ago by akshah123

I have the same problem. However, uninstalling Vbox, rebooting, reinstalling Vbox and rebooting doesn't work.

comment:4 Changed 23 months ago by dlech

Same error here. Was able to fix by uninstalling, rebooting, and reinstalling. Did not have to reboot again after the reinstall. The issue appears to be with the installation of the host-only network interface in Windows. When I first installed 4.3, I noticed that I no longer had the "VirtualBox Host-Only Ethernet Adapter" in "Control Panel\Network and Internet\Network Connections".

comment:5 Changed 23 months ago by pauloelr

An issue on the Vagrant repository om GitHub seens to be related with this one too:  https://github.com/mitchellh/vagrant/issues/2392#issuecomment-26885297

comment:6 Changed 22 months ago by dopry

This seems to still be an issue with virtual box. running into tonight on windows 8.1 w/ virtual box 4.3.2.

comment:7 Changed 22 months ago by AlexSell

Problem persists since v.4.3.0 and is a BIG issue on Windows. It has been reported on Win7 up to Win8.1 (all 64bit) versions.

Symptoms: after clean-install (with uninstall, reboot, install, reboot) of any VBox version >= 4.3.0, the host-only network interface can only be deleted, but when created, the application throws the error mentioned in the ticket. It doesn't matter if the interface is created via GUI or directly via VBoxManage (thus making it even more annoying for Vagrant users).

Despite the error, VBox seems to create the network interface correctly (a restart of the GUI shows the new interface in place.

Re-installing didn't help on my system. Also it seems like the installation works as expected, all default network interfaces are there after.

Relevant system information below (all device drivers are recent):

System Information report written at: 11/06/13 08:23:45
System Name: -
[System Summary]

Item	Value	
OS Name	Microsoft Windows 8.1 Pro	
Version	6.3.9600 Build 9600	
Other OS Description 	Not Available	
OS Manufacturer	Microsoft Corporation	
System Name	-	
System Manufacturer	SAMSUNG ELECTRONICS CO., LTD.	
System Model	900X3C/900X3D/900X3E/900X4C/900X4D	
System Type	x64-based PC	
System SKU	System SKUNumber	
Processor	Intel(R) Core(TM) i5-3317U CPU @ 1.70GHz, 1701 Mhz, 2 Core(s), 4 Logical Processor(s)	
BIOS Version/Date	Phoenix Technologies Ltd. P09ABK, 07.10.2013	
SMBIOS Version	2.7	
Embedded Controller Version	255.255	
BIOS Mode	UEFI	
BaseBoard Manufacturer	SAMSUNG ELECTRONICS CO., LTD.	
BaseBoard Model	Not Available	
BaseBoard Name	Base Board	
Platform Role	Mobile	
Secure Boot State	On	
PCR7 Configuration	Binding Not Possible	
Windows Directory	C:\WINDOWS	
System Directory	C:\WINDOWS\system32	
Boot Device	\Device\HarddiskVolume1	
Locale	Germany	
Hardware Abstraction Layer	Version = "6.3.9600.16408"	
User Name	-\-	
Time Zone	W. Europe Standard Time	
Installed Physical Memory (RAM)	4,00 GB	
Total Physical Memory	3,63 GB	
Available Physical Memory	1,80 GB	
Total Virtual Memory	4,07 GB	
Available Virtual Memory	1,91 GB	
Page File Space	448 MB	
Page File	C:\pagefile.sys	
Hyper-V - VM Monitor Mode Extensions	Yes	
Hyper-V - Second Level Address Translation Extensions	Yes	
Hyper-V - Virtualization Enabled in Firmware	Yes	
Hyper-V - Data Execution Protection	Yes	

[Hardware Resources]



[Conflicts/Sharing]

Resource	Device	
Memory Address 0xF0600000-0xF0601FFF	Intel(R) Centrino(R) Advanced-N 6235	
Memory Address 0xF0600000-0xF0601FFF	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 1 - 1E10	
		
I/O Port 0x00000000-0x0000001F	Direct memory access controller	
I/O Port 0x00000000-0x0000001F	PCI Express Root Complex	
		
I/O Port 0x00002000-0x000020FF	Realtek PCIe GBE Family Controller	
I/O Port 0x00002000-0x000020FF	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 4 - 1E16	
		
I/O Port 0x00000070-0x00000070	Motherboard resources	
I/O Port 0x00000070-0x00000070	System CMOS/real time clock	
		
Memory Address 0xF0400000-0xF0403FFF	Realtek PCIe GBE Family Controller	
Memory Address 0xF0400000-0xF0403FFF	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 4 - 1E16	
		
Memory Address 0xFF000000-0xFFFFFFFF	Motherboard resources	
Memory Address 0xFF000000-0xFFFFFFFF	Intel(R) 82802 Firmware Hub Device	
		
IRQ 16	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 1 - 1E10	
IRQ 16	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 5 - 1E18	
		
I/O Port 0x00005000-0x00005003	Motherboard resources	
I/O Port 0x00005000-0x00005003	Motherboard resources	
		

[DMA]

Resource	Device	Status	
Channel 4	Direct memory access controller	OK	

[Forced Hardware]

Device	PNP Device ID	

[I/O]

Resource	Device	Status	
0x0000002E-0x0000002F	Motherboard resources	OK	
0x0000004E-0x0000004F	Motherboard resources	OK	
0x00000061-0x00000061	Motherboard resources	OK	
0x00000063-0x00000063	Motherboard resources	OK	
0x00000065-0x00000065	Motherboard resources	OK	
0x00000067-0x00000067	Motherboard resources	OK	
0x00000070-0x00000070	Motherboard resources	OK	
0x00000070-0x00000070	System CMOS/real time clock	OK	
0x00000080-0x00000080	Motherboard resources	OK	
0x00000092-0x00000092	Motherboard resources	OK	
0x000000B2-0x000000B3	Motherboard resources	OK	
0x00000680-0x0000069F	Motherboard resources	OK	
0x00001000-0x0000100F	Motherboard resources	OK	
0x00005000-0x00005003	Motherboard resources	OK	
0x00005000-0x00005003	Motherboard resources	OK	
0x0000FFFF-0x0000FFFF	Motherboard resources	OK	
0x00000400-0x00000453	Motherboard resources	OK	
0x00000458-0x0000047F	Motherboard resources	OK	
0x00000500-0x0000057F	Motherboard resources	OK	
0x00000A00-0x00000A0F	Motherboard resources	OK	
0x0000164E-0x0000164F	Motherboard resources	OK	
0x00000062-0x00000062	Microsoft ACPI-Compliant Embedded Controller	OK	
0x00000066-0x00000066	Microsoft ACPI-Compliant Embedded Controller	OK	
0x00000020-0x00000021	Programmable interrupt controller	OK	
0x00000024-0x00000025	Programmable interrupt controller	OK	
0x00000028-0x00000029	Programmable interrupt controller	OK	
0x0000002C-0x0000002D	Programmable interrupt controller	OK	
0x00000030-0x00000031	Programmable interrupt controller	OK	
0x00000034-0x00000035	Programmable interrupt controller	OK	
0x00000038-0x00000039	Programmable interrupt controller	OK	
0x0000003C-0x0000003D	Programmable interrupt controller	OK	
0x000000A0-0x000000A1	Programmable interrupt controller	OK	
0x000000A4-0x000000A5	Programmable interrupt controller	OK	
0x000000A8-0x000000A9	Programmable interrupt controller	OK	
0x000000AC-0x000000AD	Programmable interrupt controller	OK	
0x000000B0-0x000000B1	Programmable interrupt controller	OK	
0x000000B4-0x000000B5	Programmable interrupt controller	OK	
0x000000B8-0x000000B9	Programmable interrupt controller	OK	
0x000000BC-0x000000BD	Programmable interrupt controller	OK	
0x000004D0-0x000004D1	Programmable interrupt controller	OK	
0x00000454-0x00000457	Motherboard resources	OK	
0x00000000-0x0000001F	Direct memory access controller	OK	
0x00000000-0x0000001F	PCI Express Root Complex	OK	
0x00000081-0x00000091	Direct memory access controller	OK	
0x00000093-0x0000009F	Direct memory access controller	OK	
0x000000C0-0x000000DF	Direct memory access controller	OK	
0x00000060-0x00000060	Standard PS/2 Keyboard	OK	
0x00000064-0x00000064	Standard PS/2 Keyboard	OK	
0x000000F0-0x000000F0	Numeric data processor	OK	
0x00002000-0x000020FF	Realtek PCIe GBE Family Controller	OK	
0x00002000-0x000020FF	Intel(R) 7 Series/C216 Chipset Family PCI Express Root Port 4 - 1E16	OK	
0x00000D00-0x0000FFFF	PCI Express Root Complex	OK	
0x00000040-0x00000043	System timer	OK	
0x00000050-0x00000053	System timer	OK	
0x00003000-0x0000303F	Intel(R) HD Graphics 4000	OK	
0x00003088-0x0000308F	Intel(R) 7 Series Chipset Family SATA AHCI Controller	OK	
0x00003094-0x00003097	Intel(R) 7 Series Chipset Family SATA AHCI Controller	OK	
0x00003080-0x00003087	Intel(R) 7 Series Chipset Family SATA AHCI Controller	OK	
0x00003090-0x00003093	Intel(R) 7 Series Chipset Family SATA AHCI Controller	OK	
0x00003060-0x0000307F	Intel(R) 7 Series Chipset Family SATA AHCI Controller	OK	
0x0000EFA0-0x0000EFBF	SAMSUNG SMBus Driver	OK	

comment:8 Changed 22 months ago by frank

We think we found and fixed the issue. Please could you check if  this test build fixes the problem with creating the host-only network interfaces? Thank you!

comment:9 Changed 22 months ago by AlexSell

I can confirm following things working now in VBox version 4.3.3 build 90468 on Win8.1 64bit:

  • Adding and deleting host-only interfaces in VBox GUI (user and elevated mode): no errors
  • Adding and deleting host-only interfaces via VBoxManage (user and elevated mode): no errors

Nice one, thank you for you quick response! :-)

Version 0, edited 22 months ago by AlexSell (next)

comment:10 Changed 22 months ago by frank

  • Summary changed from Failed to create the host network interface to Failed to create the host network interface => Fixed in SVN

Thank you for the feedback! Of course this fix will be included in the next maintenance release. No release date yet but it will not take months.

comment:11 Changed 22 months ago by shallal

didn't work for me on windows 7 64bit

comment:12 Changed 22 months ago by frank

shallal, in that case I guess you have a different problem. Please describe what you experience and attach log files. You cannot experience the problem as described in the subject because this was definitely fixed in the test build (see comment 8).

comment:13 follow-up: ↓ 15 Changed 22 months ago by shallal

D:\Oracle\Vbox>VBoxManage.exe hostonlyif create bla --ip 192.168.1.1 --netmask 2 55.255.255.0 0%... Progress state: E_FAIL VBoxManage.exe: error: Failed to create the host-only adapter VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended in fo not available) VBoxManage.exe: error: Context: "int cdecl handleCreate(struct HandlerArg *,in t,int *)" at line 66 of file VBoxManageHostonly.cpp

comment:14 Changed 21 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in 4.3.4.

comment:15 in reply to: ↑ 13 Changed 21 months ago by FirewallEngineer

Replying to shallal:

D:\Oracle\Vbox>VBoxManage.exe hostonlyif create bla --ip 192.168.1.1 --netmask 2 55.255.255.0 0%... Progress state: E_FAIL VBoxManage.exe: error: Failed to create the host-only adapter VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended in fo not available) VBoxManage.exe: error: Context: "int cdecl handleCreate(struct HandlerArg *,in t,int *)" at line 66 of file VBoxManageHostonly.cpp

I’m experiencing the same issue even though I’ve downloaded and installed the latest one.  http://download.virtualbox.org/virtualbox/4.3.6/VirtualBox-4.3.6-91406-Win.exe

 http://firewallengineer.wordpress.com/2013/12/26/problem-virtualbox-failed-to-create-the-host-network-interface/

comment:16 follow-up: ↓ 20 Changed 18 months ago by David.Requena

  • Status changed from closed to reopened
  • Resolution fixed deleted

Sorry to bother but this is not fixed as of 4.3.8.r92456 on Windows 7 Pro x64

VBoxManage hostonlyif create "vbho" --ip 10.0.200.1
0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available)
VBoxManage.exe: error: Context: "int __cdecl handleCreate(struct HandlerArg *,int,int *)" at line 66 of file VBoxManageHostonly.cpp

comment:17 Changed 18 months ago by frank

  • Priority changed from blocker to major

This must be a different problem. Are you sure that you installed the host-only driver when you installed VirtualBox?

comment:18 Changed 18 months ago by David.Requena

I definitely did install it. In fact going back to 4.2.24 and creating some h/o adapter allows its use after upgrading to any 4.3.x release. Said adapter can be removed in 4.3.x but not modified. Under no circunstance can it be re-created.

Please let me know if I should open a new issue. It's definitely the same one reported by @FirewallEngineer above however.

comment:19 Changed 17 months ago by chriscupas

Resolved it by going to virtualbox manager and

File -> Preferences -> Network -> Host-only Networks -> Add host-only network (icon)

comment:20 in reply to: ↑ 16 Changed 17 months ago by Markl8

Replying to David.Requena:

Sorry to bother but this is not fixed as of 4.3.8.r92456 on Windows 7 Pro x64

VBoxManage hostonlyif create "vbho" --ip 10.0.200.1
0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available)
VBoxManage.exe: error: Context: "int __cdecl handleCreate(struct HandlerArg *,int,int *)" at line 66 of file VBoxManageHostonly.cpp

Exactly the same problem and message with windows 8.1 pro 64-bits and virtual box 4.3.10 R39012.

Did you found any solution?

comment:21 Changed 17 months ago by mrlindsey

Same problem in Windows 7 64-bit on 4.3.10 R39012. Thanks.

comment:22 Changed 17 months ago by Duck Asteroid

VBox 4.3.10r93012 On Windows 8.1 64 bit:

VBoxManage hostonlyif create -vbho- --ip 10.0.200
.10%...
Progress state- E_FAIL
VBoxManage.exe- error- Failed to create the host-only adapter
VBoxManage.exe- error- Code E_FAIL (0x80004005) - Unspecified error (extended info not available)
VBoxManage.exe- error- Context- -int __cdecl handleCreate(struct HandlerArg -,int,int -)- at line 66 of file VBoxManageHostonly.cpp
Last edited 17 months ago by Duck Asteroid (previous) (diff)

comment:23 Changed 16 months ago by Milan Jaroš

Same issue. Windows 7 32-bit using VirtualBox-4.3.10-93012.

c:\Program Files\Oracle\VirtualBox>VBoxManage.exe hostonlyif create -vbho- --ip 10.0.0.200
0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available)
VBoxManage.exe: error: Context: "int __cdecl handleCreate(struct HandlerArg *,int,int *)" at line 68 of file VBoxManageHostonly.cpp

Note, there different line number.

comment:24 Changed 16 months ago by MAS

Same issue, VirutalBox ver. 4.3.10 r93012 (Windows 7 64-bit).

00:00:08.745527 IntNet#0: szNetwork={HostInterfaceNetworking-Intel(R) Centrino(R) Ultimate-N 6300 AGN} enmTrunkType=3 szTrunk={\DEVICE\{CE672E5A-1A31-4EFB-8D0C-B39822D8CDBD}} fFlags=0x14001 cbRecv=325632 cbSend=196608 fIgnoreConnectFailure=false
00:00:08.745666 VMSetError: D:\tinderbox\win-4.3\src\VBox\Devices\Network\DrvIntNet.cpp(1752) int __cdecl drvR3IntNetConstruct(struct PDMDRVINS *,struct CFGMNODE *,unsigned int); rc=VERR_INTNET_FLT_IF_NOT_FOUND
00:00:08.745699 VMSetError: Failed to open/create the internal network 'HostInterfaceNetworking-Intel(R) Centrino(R) Ultimate-N 6300 AGN'
00:00:08.745786 VMSetError: D:\tinderbox\win-4.3\src\VBox\Devices\Network\DevE1000.cpp(7693) int __cdecl e1kR3Construct(struct PDMDEVINS *,int,struct CFGMNODE *); rc=VERR_INTNET_FLT_IF_NOT_FOUND
00:00:08.745793 VMSetError: Failed to attach the network LUN
00:00:08.745830 PDM: Failed to construct 'e1000'/0! VERR_INTNET_FLT_IF_NOT_FOUND (-3600) - The networking interface to filter was not found.
00:00:08.758644 AIOMgr: Preparing flush failed with VERR_NOT_SUPPORTED, disabling async flushes
00:00:08.872909 ERROR [COM]: aRC=E_FAIL (0x80004005) aIID={8ab7c520-2442-4b66-8d74-4ff1e195d2b6} aComponent={Console} aText={Failed to open/create the internal network 'HostInterfaceNetworking-Intel(R) Centrino(R) Ultimate-N 6300 AGN' (VERR_INTNET_FLT_IF_NOT_FOUND).
00:00:08.872968 Failed to attach the network LUN (VERR_INTNET_FLT_IF_NOT_FOUND)}, preserve=false
00:00:08.902467 Power up failed (vrc=VERR_INTNET_FLT_IF_NOT_FOUND, rc=E_FAIL (0X80004005))

Note: the problem appeared right after upgrading from 4.3.6-91406 to 4.3.10-93012, I didn't have this on the older version and downgrading to what it was didn't help.

comment:25 Changed 16 months ago by mrlindsey

I'm disappointed that this was not addressed in 4.3.12. Or was it? It is holding up some work for us.

comment:26 Changed 16 months ago by michael

Very sorry this is causing problems for you. Once a fix is available we will make a test build available here. Unfortunately we have limited resources available, and have to prioritise those towards issues which affect paying customers which is why we were not able to get this fixed for 4.3.12. Other than paying for support users can of course also speed up the resolution of this sort of issue by investigating themselves using the source code.

comment:27 Changed 16 months ago by frank

The error messages in the recent comments normally indicate that the host-only network driver was not properly installed. Uninstalling VirtualBox + reboot the host + re-installing VirtualBox is worth a try in such case.

comment:28 Changed 16 months ago by Milan Jaroš

Frank, I've tried countless-times to turn-off and on again. ;)

Last edited 16 months ago by Milan Jaroš (previous) (diff)

comment:29 Changed 16 months ago by MAS

Finally, I've got it fixed!

When I first upgraded from (4.3.6-91406) to (4.3.10-93012) I didn't Power off all the VMs, instead I've "saved machine state" for some of my VMs and closed VBox and installed the newer version then this problem appeared.

I've fixed this by "Powering off" all the VMs before upgrading to latest (4.3.12-93733) and it worked!

Hope this solution helps the others too. Peace,

comment:30 Changed 15 months ago by yvesware

I have tried different version from 4.2.0 to the latest and I always get the error is there a fix yet. I am running windows 7/sp1 with 2 sockets/32GB memory. Following is the error I get if I do it manually

c:\Program Files\Oracle\VirtualBox>VBoxManage.exe hostonlyif create 0%... Progress state: E_FAIL VBoxManage.exe: error: Failed to create the host-only adapter VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not ava ilable) VBoxManage.exe: error: Context: "int cdecl handleCreate(struct HandlerArg *,int,int *)" at line 66 of file VBoxManageHostonly.cpp

Yvesware~

comment:31 Changed 14 months ago by lh84

I have the same problem. Can't use my VM's anymore. I tried also to reinstall Virtualbox and some others. What I recognized additionally: Everytime Virtualbox tries to create a host-only adapter, there will be a new unknown device in windows device manager. After I recognized it, there were more than 30 unknown devices. The problem is, that I can't uninstall the devices in normal boot mode. Everytime I want to uninstall the devices, I have to boot in Windows saved mode to uninstall them. Everyone else noticed this behavior?

I assume that something is wrong with permissions in windows. Maybe the installation brokes some permission rights in the OS.

I've got the exact same error like yvesware. I'm running Win 7 Enterprise / SP1 (64Bit), Intel Core i7, 8GB Ram.

Is there a fix or a version of Virtualbox in which it works? Because I can't work without the virtual machines.

Last edited 14 months ago by lh84 (previous) (diff)

comment:32 Changed 13 months ago by Marco_Postpischl

I have the same issue. Please fix it

comment:33 Changed 13 months ago by GreenTea

Same problem in win 8.1 and VirtualBox 4.3.15 r95599

comment:34 Changed 13 months ago by VVP

Checked on Win 7 enterprise 64bit, VBox 4.3.53 r95358. Command "VBoxManage.exe hostonlyif create" works. It is created a network adapter with name "VirtualBox Host-Only Ethernet Adapter #{number}". I had two host-only adapters before, so afterwards the adapter "VirtualBox Host-Only Ethernet Adapter #3" was created.

p.s. Possibly, the problem is still here. And may be it is related to installer. Anyway, keep the log after each installation. and upload it here if it is possible.

To allow logging: run installer from command line with additional parameter "--logging".

log file place: Win7 - C:\Users\{user name}\AppData\Local\Temp\VirtualBox

Last edited 13 months ago by VVP (previous) (diff)

Changed 9 months ago by ldawson

Installation log for windows 8.1 host with virtual box 4.3.20 - same problem

comment:35 Changed 9 months ago by ldawson

The install log was rejected as too large for upload, uploaded compressed .tar.bz2 version. I have the same problem, the host is a Windows 8.1 laptop. I've tried the uninstall-reboot-install cycle more than once, it doesn't help. Also tried deleting the devices and the device driver using windows control panel before reinstalling.

From the command line I get:

C:\Program Files\Oracle\VirtualBox>VBoxManage.exe hostonlyif create 0%... Progress state: E_FAIL VBoxManage.exe: error: Failed to create the host-only adapter VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended in fo not available) VBoxManage.exe: error: Context: "int cdecl handleCreate(struct HandlerArg *,in t,int *)" at line 66 of file VBoxManageHostonly.cpp

Last edited 9 months ago by ldawson (previous) (diff)

comment:36 Changed 7 months ago by DennisSanders

I'm running VirtualBox 4.3.20r96997 and encountering this same problem on a work Windows 7 x64 Enterprise Edition laptop. The laptop is a Dell Latitude E6510 running an I7 processor with 8GB RAM.

The problem isn't that VB Failed to create the host network interface, the actual underlying Windows driver "VirtualBox Host-Only Ethernet Adapter" will not run on the laptop. When I go in and try to manually update the driver, it finds the correct driver in the Windows driver directory, but when installing it, it reports:

Windows found driver software for your device but encountered an error while attempting to install it.

VirtualBox Host-Only Ethernet Adapter

Insufficient system resources exist to complete the requested service.

This also happens with the VirtualBox Bridged Networking Service driver. Other drivers I've installed have not had this issue, and I've updated the register entry HKLM\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters to 0x14 (20 decimal) as discussed in a number of threads I found on line to no avail.

Without these two drivers loading properly in Windows, Host-Only and Bridged networking is not possible with VirtualBox. This problem didn't exist in older versions of the VB software running on Windows 7 x64 Ultimate at home, but when upgrading the home laptop, this also fails for the same reasons.

comment:37 Changed 5 months ago by hwinter

I have the same issue with 4.3.26.r98988, running on a Windows 8.1 (i7, 8G RAM) - HP Envey 700-339. After installing VBOX (tried several times running as administrator) I see on Windows Device Manager that VirtualBox Host-Only Ethernet Adapter is not working: "windows cannot load the drivers required for this device. (code 31)

When I choose Bridge Mode and start the VM, I get the message "Failed to open/create the internal network 'hostInterfaceNetworking-Realtek PCIe GBE Family Controller' (VERR_SUPDRV_COMPONENT_NOT_FOUND)".

Only NAT option works. Interesting enough, I have the same version of VBOX running on a Windows 8.1 (i5 16G RAM), where I have no problem. However, that version has been upgraded from previous versions, not a fresh 4.3 install as the one in question. I assume there is something wrong with the driver or installer. I also tried installing the Host Only Network Adapter directly from Windows Device Manager, pointing to the file on C:\Program Files\Oracle\VirtualBox\drivers\network\netadp\VBoxNetAdp.inf However, that return an error too "the system cannot find the file specified".

I tried installing VBOX version 4.2.28, same exact issue. Basically I cannot use this machine with VBOX.

comment:38 Changed 5 months ago by hwinter

OK, after trying EVERYTHING possible, I did a refresh on windows 8.1, losing everything I had installed (not much really) and re-installed Vbox. I had no issues afterwards.

comment:39 Changed 4 months ago by MEMark

I have the same problem, running VirtualBox-4.3.26-98988 on Windows 8.1 Enterprise 6.3.9600 x64.

I tried using the --logging option for the installer, but I was unable to find the resulting log file... The path mentioned above for Windows 7 is empty. Where is it supposed to be?

Has there been any progress on this issue?

comment:40 Changed 4 months ago by gmc

Having this issue on Win8.1 64 bit and Win 10 Build 10074 (Although on W10 it might be because its a tech preview)

comment:41 Changed 4 months ago by papadi

Same thing here with Windows 10. VirtualBox was working but after the latest release (build 10074) it doesn't. I cannot run Genymotion. Here is part of the log file:

May 3 18:29:28 [Genymotion] [Debug] VBoxManage ("list", "hostonlyifs") returns 0
May 3 18:29:28 [Genymotion] [Debug] VBoxManage ("list", "dhcpservers") returns 0
May 3 18:29:30 [Genymotion] [Error] VBoxManage ("hostonlyif", "create") returns 1
May 3 18:29:30 [Genymotion] [Error] Output command: "0%...
Progress state: E_FAIL
VBoxManage.exe: error: Failed to create the host-only adapter
VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available)
VBoxManage.exe: error: Context: "int cdecl handleCreate(struct HandlerArg *,int,int *)" at line 66 of file VBoxManageHostonly.cpp"
May 3 18:29:30 [Genymotion] [Error] failed to create host only interface

When I try to create the Host-only Network using VBox UI I get the following:
Failed to create the host network interface
Result Code: E_FAIL (0x80004005)

comment:42 Changed 3 months ago by gmc

Getting the same issue on Windows 10 Preview 10130.

Also tried VB 5.0.0 RC1 - same issue.

Will this issue only be fixed after the Win10 final release?

comment:43 Changed 2 months ago by Ant1

Same issue here, W10 build 10130. Does the exact same thing even with a fresh install of latest version of VBox (4.3.28 r100309). Of course, Highly Annoying since no VM will work.

comment:44 Changed 2 months ago by ravensorb

Any hope of a fix for this?

I can confirm the issue still exists with W10 b10162

Last edited 2 months ago by ravensorb (previous) (diff)

comment:45 Changed 2 months ago by bobmajdakjr

speaking up for the two W10 guys above. i am also having this problem, with the latest 4.3 and 5.0.0 beta1 both. but here is the thing - it actually is creating the adapter. i see them in the network connections, and windows says they are up. but vboxmanage dies with the same e_fail. i currently have about 27 of them because i've been messing with it all afternoon.

Last edited 2 months ago by bobmajdakjr (previous) (diff)

comment:46 Changed 2 months ago by helgatheviking

This is still an issue with version 4.3.28 r100309 on Win7x64.

The workaround suggested here helped me get it working with Vagrant, but I'm not sure if it has an effect for anyone, but wanted to share in case it could help:  https://github.com/mitchellh/vagrant/issues/2392#issuecomment-26936014

Uninstall VirtualBox and Vagrant    
Remove VirtualBox and Vagrant entire installation directory    
Remove direcories ~/.vagrant.d and ~/.VirtalBox (if you have important things here make a backup)    
Restart PC    
Install VirtualBox and Vagrant Again     
Restart again     
Open VirtuaBox     
Go to File->Preferences->Network->Host-only Networks
Create Manually a new adapater like as follow:
IPv4: 192.168.2.1 (in my example my vm ip is 192.168.2.2 you must use the 3 first parts equal as your ip address and replace the last one by 1)
Mask: 255.255.255.0
Restart again
Open Prompt as Admin
do a vagrant up

Other things that I did that may or may not have helped: run sfc /scannow on my C: drive. I had patched certain files to run custom themes. delete any improperly installed network adapters in device manager.

Last edited 2 months ago by helgatheviking (previous) (diff)

comment:47 Changed 8 weeks ago by Eldair

Same problem with Win 10 Build 10166 and VirtualBox 5.0

comment:48 Changed 7 weeks ago by Guillaume Roche

This issue is still occurring with W10 build 10240 and VirtualBox 4.3 or 5.0.

comment:49 Changed 7 weeks ago by stijlfigurant

Also experiencing these problems with W10 build 10240 and VirtualBox 5.0.

comment:50 Changed 5 weeks ago by xwjabc

These problems still appeared with Win 10 build 10240 (Currently as RTM) and VirtualBox 5.0/4.3/4.2

comment:51 Changed 5 weeks ago by MEMark

Clearly Oracle lives up to it's reputation on this one, completely ignoring it and doing nothing...

How do I unsubscribe to the notifications from this ticket?

comment:52 Changed 5 weeks ago by METEMEDO

I've just upgraded to Windows 10 in four computers (had to, while it's free and we're in the planning phase of a new project) and now VirtualBox failed on us, rendering us without our Vagrant machines (they don't start because of this problem). Now, seeing this ticket and the frustration of the people here, made us think. If this is not solved really soon (and I mean until monday or tuesday), then we will just move to the more reliable virtualization software (you know which one). I wouldn't like to look at VirtualBox as a not-reliable-for-enterprise piece of software, but currently that's how it stands. It may be reliable enough for home projects and very small companies, but anything above that, it might not be worth the risk.

Last edited 5 weeks ago by METEMEDO (previous) (diff)

comment:53 Changed 5 weeks ago by TDslacker

I had VirtualBox 5.0.0 running Win 7 (64 bit), no problems. I upgraded from Win 7 to Windows 10 Pro and now VirtualBox can no longer access the network. After the OS upgrade, the VirtualBox Host-Only Network adapter was still present and configured to 192.168.56.1/24 and a new VirtualBox Host-Only Ethernet Adapter named Ethernet was present and was set to dynamically assigned IP address. The VirtualBox Manager GUI did not have an interface listed in the Host-Only Networks box in network settings. Attempted to add adapter with GUI and vboxmanage cmd and get the same "Ethernet(x)" VirtualBox Host-Only Ethernet Adapter added to the system - x varies with the number of times tried to add adapter - with same error message:

D:\Program Files\Oracle\VirtualBox>vboxmanage hostonlyif create 0%... Progress state: E_FAIL VBoxManage.exe: error: Failed to create the host-only adapter VBoxManage.exe: error: Code E_FAIL (0x80004005) - Unspecified error (extended info not available) VBoxManage.exe: error: Context: "enum RTEXITCODE cdecl handleCreate(struct HandlerArg *)" at line 70 of file VBoxManageHostonly.cpp

D:\Program Files\Oracle\VirtualBox>

Is there some way to configure Vbox to recognize the VirtualBox Host-Only adapter already created? Already completely removed VirtualBox, rebooted, and re-installed. Nothing works - I have several VM's that use vdi files stored on my NAS drive in my network. They can't be seen by VirtualBox either and can't bring up those VM's.

comment:54 Changed 5 weeks ago by ebsk

Hi, have the same issue with Vagrant on Win 10 Pro, VirtualBox 5. I noticed that some window blinks for a milliseconds when there is an attempt to add a host only network via a GUI/or vboxmanage hostonlyif create command (this is used by vagrant) and then the error happen, used camrecorder to recognize that window and it's the following - not sure if it mean anything though.https://dl.dropboxusercontent.com/u/5410561/Nowy%20folder/Screen_20150802_001346.png Like it tries to copy it over and over again to system32/drivers and something then goes wrong (however, the network seems to be added, but the error probably prevents the client application (like vagrant) to go on further with other stuff).

comment:55 Changed 4 weeks ago by ravensorb

Are there any options on this?

comment:56 Changed 4 weeks ago by vushakov

Windows 10 problem is #14040 (there's a test build provided there) and is most likely unrelated to the original problem.

comment:57 Changed 4 weeks ago by ravensorb

I tried that and it did not help. I ran the exe, then ran VB and tried to open the Network Operations Manager. The screen would not load while the "fix" was running.

comment:58 Changed 4 weeks ago by vushakov

Did you run the test build?

comment:59 Changed 3 weeks ago by frank

  • Status changed from reopened to closed
  • Resolution set to fixed

Windows 10 problems should be fixed with VBox 5.0.2. If there are still problems with Windows != 10 when using VirtualBox 5.0.2, please open a separate ticket.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use