VirtualBox

Ticket #12161 (closed defect: fixed)

Opened 4 years ago

Last modified 10 months ago

EFI boot very slow with Serial Port enabled => fixed in SVN/next maintenance

Reported by: AxelFontaine Owned by:
Priority: major Component: EFI
Version: VirtualBox 4.2.18 Keywords:
Cc: Guest type: Linux
Host type: Windows

Description

When booting a VM using EFI with a serial port mapped to a file, the VM spends more than 10 seconds in EFI before booting the kernel. During this time a lot of output is written to the serial port file.

With the serial port disabled, the same VM boots the kernel after less than 1 second.

Attachments

efi-boot-without-serialport-vbox.log Download (64.1 KB) - added by AxelFontaine 4 years ago.
efi-boot-with-serialport-com1.log Download (22.8 KB) - added by AxelFontaine 4 years ago.
efi-boot-with-serialport-vbox.log Download (84.0 KB) - added by AxelFontaine 4 years ago.

Change History

Changed 4 years ago by AxelFontaine

Changed 4 years ago by AxelFontaine

Changed 4 years ago by AxelFontaine

comment:1 Changed 3 years ago by AxelFontaine

More testing with 4.3.6 completed.

This problem is Windows-only. It works fine on Mac & Linux.

It also has gotten worse with recent releases. The boot now takes even longer.

Last edited 3 years ago by AxelFontaine (previous) (diff)

comment:2 Changed 10 months ago by aeichner

  • Summary changed from EFI boot very slow with Serial Port enabled to EFI boot very slow with Serial Port enabled => fixed in SVN/next maintenance

Sorry for the very late response but I just stumbled over your ticket. The issue is still true with the current VirtualBox release but will be fixed in the next maintenance release. Thanks for the report!

comment:3 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 5.1.4.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use