VirtualBox

Ticket #12064 (new defect)

Opened 7 years ago

Last modified 5 years ago

Suddenly no VM's will start - all give a RPC_S_SERVER_UNAVAILABLE error at 0%

Reported by: Bryan Bentz Owned by:
Component: other Version: VirtualBox 4.2.16
Keywords: RPC_S_SERVER_UNAVAILABLE 0% "won't start" Cc:
Guest type: all Host type: Windows

Description

I was in the process of creating a new machine, and it wouldn't start (more in a bit) - I then tried to start up a few old, reliable machines, and got the same behavior. The only change was that on startup a new version was mentioned; I installed it and saw this behavior. After some web research I went back to version 4.2.12, and still see the same problem - but this may have to do with having installed the 4.2.16 version and then, perhaps, and incomplete removal. I suppose technically this applies to both versions, as the problem shows up in both.

When I try to start any machine, I see a small popup, "Starting virtual machine..." and "0%" - that never changes. My host OS is Windows 7 Ultimate; I have to kill the process for that machine manually. When I do, I get a popup from Virtualbox; the detailed error message is: Result Code:

RPC_S_SERVER_UNAVAILABLE 0x800706BA (0x800706BA) Component: ProgressProxy Interface: IProgress {c20238e4-3221-4d3f-8891-81ce92d9f913}

Web searching shows this, or something like it, was a problem years ago, but apparently fixed. I found current ticket #10747 that looks similar.

The VM I was trying to start as the main test case is a Windows 98 machine, fairly vanilla. I certainly haven't changed any of its attributes (e.g., hardware acceleration options) since it last ran.

I have 17 VM's, all of some level of importance; it would not be a minor effort to recreate them, even if that helped. I tried to create a new Windows 2000 machine from scratch and had the same problem, that is the exact same hang and detailed error message.

I'm willing to invest some time to help fix it, if any testing I can do on this end might help.

Attachments

VBox.log Download (27.7 KB) - added by Bryan Bentz 7 years ago.
Win2K startup log - my most recently tried test of what used to run

Change History

Changed 7 years ago by Bryan Bentz

Win2K startup log - my most recently tried test of what used to run

comment:1 Changed 7 years ago by danshick

Same problem for a Linux guest with the exact same error message (down to the address). Very similar log. I was actually on version 4.2.18. It started happening right after I upgraded.

Tried downgrading to 4.2.12, which I believe was the version I was on previously. That did not fix the issue. I also tried recreating the guest, using the same VDI and the same preferences. That also did not work. Tried deleting all VirtualBox preferences, which also failed.

Anyway, last thing mentioned in both of our logs was an audio driver. I went into the settings for the guest and unchecked the "Enable Audio" box in the audio settings. VM booted right up.

This is definitely not an ideal workaround (I do use the audio for this VM), but at least you can get back into your VM and backup any information sitting in that VDI. Let me know if this solves your problem.

comment:2 Changed 6 years ago by joeervin

I just encountered this exact issue. Disabling the audio on the guests seems to have fixed it. Odd, since I had avoided upgrading from 4.2.12 due to past experience and it just started happening. Thanks for the suggestion!

comment:3 Changed 5 years ago by talby

Just to confirm for others, that I too encountered this problem (in 4.3.28, no experience with older versions) and could solve it almost the same way as others mentioned it before. In my case I have had to disable the "3D Acceleration" option.

I noticed, that when trying to activate other options (like the "2D Acceleration"), that VirtualBox informed me about for my system unavailable settings. However, it missed to detect that "3D Acceleration" won´t work.

For the developers: my host system is: WinXP 32-bit on HP Compaq nx6235 Laptop with an AMD Turion X2 64bit Mobile processor

Last edited 5 years ago by talby (previous) (diff)
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use