VirtualBox

Opened 11 years ago

Closed 10 years ago

#11979 closed defect (fixed)

64bit guest on 32bit host make host random reboots

Reported by: feverwind Owned by:
Component: host support Version: VirtualBox 4.2.14
Keywords: 64bit guest on 32bit host make host random reboots Cc:
Guest type: Linux Host type: Windows

Description

Guest: ubuntu 64bit 13.04 Host: windows 32bit Professional Virtualbox: 4.2.12 i also try 4.2.14 CPU: Core i7

I start two ubuntu 64 guest host, they both connect to Hostonly ethernet adapter. My topo is like this: ubuntu-64 ----- ubuntu-64-2 Then I ping ubuntu-64-2 from ubuntu-64, after about 10 minutes,the host reboot with no minidump.

Attachments (17)

ubuntu-64-VBox.log (51.6 KB ) - added by feverwind 11 years ago.
ubuntu-64-vbox.log
ubuntu-64-2-VBox.log (51.0 KB ) - added by feverwind 11 years ago.
ubuntu-64-2-vbox.log
ubuntu-64.vbox (14.4 KB ) - added by feverwind 11 years ago.
ubuntu-64 configure file
ubuntu-64-2.vbox (13.7 KB ) - added by feverwind 11 years ago.
ubuntu-64-2 configure file
ubuntu-64-VBox.2.log (50.7 KB ) - added by feverwind 11 years ago.
official edition ubuntu-64 log
ubuntu-64-2-VBox.2.log (50.6 KB ) - added by feverwind 11 years ago.
official edition ubuntu-64-2 log
ubuntu-64.2.vbox (7.0 KB ) - added by feverwind 11 years ago.
official edition ubuntu-64 configure
ubuntu-64-2.2.vbox (7.0 KB ) - added by feverwind 11 years ago.
official edition ubuntu-64-2 configure
Ubuntu Precise 64.vbox (8.1 KB ) - added by rewen 11 years ago.
poweroff.log (83.5 KB ) - added by feverwind 11 years ago.
properly powerr off
poweroff-2.log (83.6 KB ) - added by feverwind 11 years ago.
till now, the new package works fine, so I only get the poweroff log.
ubuntu-64.log (52.4 KB ) - added by feverwind 11 years ago.
ubuntu-64-2.log (52.1 KB ) - added by feverwind 11 years ago.
VirtualBox-4.2.51-87788-Win.exe-VBox.log (95.4 KB ) - added by artvolk 11 years ago.
VIRTSUSE-2013-08-20-18-54-04.log (53.0 KB ) - added by chris@… 11 years ago.
VIRTSUSE-2013-08-22-10-56-40.log (53.0 KB ) - added by chris@… 11 years ago.
VIRTSUSE-2013-08-28-14-07-59.log (44.9 KB ) - added by chris@… 10 years ago.

Download all attachments as: .zip

Change History (52)

by feverwind, 11 years ago

Attachment: ubuntu-64-VBox.log added

ubuntu-64-vbox.log

by feverwind, 11 years ago

Attachment: ubuntu-64-2-VBox.log added

ubuntu-64-2-vbox.log

by feverwind, 11 years ago

Attachment: ubuntu-64.vbox added

ubuntu-64 configure file

by feverwind, 11 years ago

Attachment: ubuntu-64-2.vbox added

ubuntu-64-2 configure file

comment:1 by Klaus Espenlaub, 11 years ago

Does this also happen with the VirtualBox packages from virtualbox.org? So far we didn't get any such reports, this might be a miscompiled 3rd party package.

in reply to:  1 comment:2 by feverwind, 11 years ago

Replying to klaus: The problem is found by official edition at first, so I build the OSE because i want to fix it by myself. I will reproduce it by official edition.

by feverwind, 11 years ago

Attachment: ubuntu-64-VBox.2.log added

official edition ubuntu-64 log

by feverwind, 11 years ago

Attachment: ubuntu-64-2-VBox.2.log added

official edition ubuntu-64-2 log

by feverwind, 11 years ago

Attachment: ubuntu-64.2.vbox added

official edition ubuntu-64 configure

by feverwind, 11 years ago

Attachment: ubuntu-64-2.2.vbox added

official edition ubuntu-64-2 configure

comment:3 by feverwind, 11 years ago

I reproduce the problem by official edition. This time, I ping ubuntu-64 from ubuntu-64-2 by large packet(8100 byte). The ping command is ping -s 8100 -c 100000 33.0.0.2. I think you can reproduce it local.

comment:4 by Mihai Hanor, 11 years ago

What happens if you don't ping from within the guest? What if you just let the guests idle for 10-15 minutes?

What if you choose some other type of network (NAT or internal network, instead of host-only)?

What if you disable the "Turn display off when inactive" option inside the guests? (System Settings->Brightness&Lock)? The default setting is 10min.

Do you have Windows XP Mode installed?

Version 1, edited 11 years ago by Mihai Hanor (previous) (next) (diff)

comment:5 by feverwind, 11 years ago

Its no relate to ping. And also no relate to network or "Turn display off when inactive" option, because the host reboot just at I start two guests.

I don't have a win xp host, so I haven't try this on win xp, I will try it later.

Last edited 11 years ago by feverwind (previous) (diff)

comment:6 by Mihai Hanor, 11 years ago

I wasn't talking about Windows XP as host, I was saying about Windows XP Mode, which runs inside your Windows 7 Pro, if you do have it installed.

Also, you've said that it takes 10 minutes for the host to reboot. The guest might do something at the 10 minutes mark and trigger the reboot. Ubuntu (as guest), by default, turns off the (guest) display after 10 minutes of inactivity.

So, you're saying that the host can reboot spontaneously, right after starting the guests? Can you trigger the reboot with only one guest?

comment:7 by feverwind, 11 years ago

Win xp is ok, I do same operation on win xp PC. It seems only win7 have this problem. one guest on win7 also have this problem.

by rewen, 11 years ago

Attachment: Ubuntu Precise 64.vbox added

comment:8 by rewen, 11 years ago

Happens to me as well in 4.2.16 on Win7 32bit Host, 3.24GB (4GB physically), Core i5.

Sometimes when I run python applications, sometimes on reboot, sometimes when turning on the VM.

I do have Windows XP mode installed - but the posts above do not explain the relevance of that.

Did not seem to start happening until I installed the guest extensions, but I could be wrong. I am using shared folders with just one folder. It's mounted using /etc/rc.local

Last edited 11 years ago by rewen (previous) (diff)

comment:9 by Frank Mehnert, 11 years ago

But all of you have a 32-bit Windows host, right?

comment:10 by Frank Mehnert, 11 years ago

We have a suspicion but we need to test it. Could you install this package (here is the corresponding extpack)? This is a build from current trunk (so not for production usage). Install this package, run your 64-bit VM on your 32-bit host for some time but make sure to power off your VM before your host crashes. Then, please attach the resulting VBox.log file to this ticket. Again, make sure that the VM is properly powered off. The log file will contain numbers which either approve our suspicion or disprove it. Thank you! Well, there is still the improbable case that with this trunk package the host reboot does not happen. In that case we would appreciate feedback as well.

by feverwind, 11 years ago

Attachment: poweroff.log added

properly powerr off

comment:11 by feverwind, 11 years ago

I use the new package, There is the log, wish it useful.

comment:12 by feverwind, 11 years ago

The host reboot problem doesn't happen on the new package, I run two ubuntu VM for more than 2 hours, and nothing happened. With the 4.2.12, the problem will happened in 20 minites.

Last edited 11 years ago by feverwind (previous) (diff)

comment:13 by artvolk, 11 years ago

I've the same problem: Windows 7 Home Basic SP1 32 bit, VirtualBox 4.2.16 with Ubuntu Server 64 bit.

I got random reboots, but only on newer machines with Core i3-3220. I've isolated issue on one machine with fresh Windows install and only VirtualBox running.

But, on older machines with DualCore E5500 everything works, no reboots.

Please let me know if I can help in anyway, I can test VirtualBox builds and provide any additional information.

comment:15 by artvolk, 11 years ago

Ok, I'll try it and let you know.

comment:16 by Frank Mehnert, 11 years ago

feverwind, could you also try this build? The VT-x code was rewritten a lot and this build has the new code disabled. So in case your host crashes with this build we know at least where to start searching. Unfortunately our suspicion (NMI interrupts) was not confirmed by your last experiment. Thank you!

comment:17 by feverwind, 11 years ago

please forget my last reply, the host reboot again with the new package. OK, I will try the latest package.

comment:19 by Frank Mehnert, 11 years ago

artvolk, please do also attach a VBox.log file of a VM session when running with one of these packages when you terminated the VM normally.

by feverwind, 11 years ago

Attachment: poweroff-2.log added

till now, the new package works fine, so I only get the poweroff log.

by feverwind, 11 years ago

Attachment: ubuntu-64.log added

by feverwind, 11 years ago

Attachment: ubuntu-64-2.log added

comment:20 by feverwind, 11 years ago

The host reboot last night, and ubuntu-64.log ubuntu-64-2.log is the crash log.

comment:21 by artvolk, 11 years ago

I've got reboot with this build:

http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-87788-Win.exe

What kind of log do you need?

Thanks!

comment:22 by Frank Mehnert, 11 years ago

artfolk, thanks for testing! Can you start a VM again with this test build but make sure that it wouldn't reboot? I mean, just run it for a few minutes, then shut down the guest properly. Then attach the VBox.log file this this ticket. There is some statistics counter enabled which would confirm or refute an assumption about the problem. Thank you!

comment:23 by artvolk, 11 years ago

Here is log. Machine was booted from power off state and than halted using halt -p. Please let me know if I can help in any other way.

comment:24 by chris@…, 11 years ago

Hi all.

I also face the same pb with:

  • Guest: Opensuse 11.2 64 bits
  • Host: Win7 Prof SP1 32 bits running on a Dell laptop E6510 with 2 Core i7

Things used to run fine until an upgrade to VBox 4.2.10, and the pb seems to get worse after each new update (currently using VBox 4.2.16).

I tried to reduce the nb of processors, to remove support of unused peripherals, to increase/decrease the memory but not way.

A few things I have observed:

  • I use other VMs that run OK, but they are all 32 bits old OSes (WinXP or RedHat)
  • With the 64bits OpenSuse VM, the reboots are more frequent if the host is heavily used (for example: running a parallel build on the host while the guest VM is launched will almost always reboot the system).
  • It also seems to me that they are more reboots when the host machine is hot, and I wonder if the pb has something to do with some thermal detection hardware.

I attach the VBox log of the last unwanted reboot. Any help welcome.

Last edited 11 years ago by chris@… (previous) (diff)

by chris@…, 11 years ago

comment:25 by feverwind, 11 years ago

to chris:

Is 4.2.8 runs fine ?

comment:26 by chris@…, 11 years ago

Before upgrading to 4.2.10, I was using a 4.1.X (but I can't remember exactly what version it was).

I've just downloaded and installed the 4.2.8 but no luck, I had a reboot after a few minutes of use of the OpenSuse VM.

I attach the latest VBox log file but there is nothing in it that seems weird to me.

by chris@…, 11 years ago

comment:27 by feverwind, 11 years ago

to chris:

please check which version works fine, it is helpful

comment:28 by rousseauhk, 11 years ago

I have the same problem - here's the forum post I raised: https://forums.virtualbox.org/viewtopic.php?f=3&t=55574

  • VBox: 4.2.10
  • Guest: Ubuntu Server LTS 64-bit
  • Host: Windows 7 Home Premium 32-bit (running under bootcamp)
  • Machine: MacBook Pro i7 2720QM

VBox causes the host to reboot during Ubuntu installation, round about the time that it changes screen resolution.

in reply to:  27 comment:29 by chris@…, 11 years ago

Replying to feverwind:

to chris:

please check which version works fine, it is helpful

I have installed an ancient VBox 4.1.16 and, even if it appeared to be more stable under light CPU usage, it made the PC reboot after 1 hour of heavy load.

I will give a try to some more older distributions (may be also a 4.0).

in reply to:  27 comment:30 by chris@…, 11 years ago

My last try is VirtualBox V4.0.18 and a full day of test has not revealed the reboot pb with this older release.

The tests where mainly based on workload:

  • doing light work in the host (word processing) while performing parallel builds on the guest
  • performing parallel builds on the host while the guest runs only a desktop and a few shells with light cyclic processes (like "top", "ping", etc)
  • performing concurrent parallel builds on the host and the guest

The concurrent parallel build tests were done with allowing 4 on 8 CPUs to the guest, while the host was already using all of the 8 CPUs (just to be sure that there will be enough hardware shaking between the VM and the host).

For now, I will keep using this V4.0.18 and report any further pb if any.

Hope this helps.

Last edited 11 years ago by chris@… (previous) (diff)

comment:31 by chris@…, 10 years ago

Bad news: after few hours today, the V4.0.18 has also rebooted the host PC without notice.

At the time of the reboot, the 64 bits VM was minimized and was not doing anything (just the KDE desktop running).

I attach the last VirtualBox log just in case.

by chris@…, 10 years ago

comment:32 by Frank Mehnert, 10 years ago

Hi, first of all, thank you all for your tests. I think we finally found and fixed the problem. I have a new test build available. Could you test if this build fixes your problem? Thank you!

comment:33 by feverwind, 10 years ago

Good news! I already test this version for 4hours, it works fine. I will go on test it.

comment:34 by AngelArias, 10 years ago

I was in the same situation and with frank's solution now works ok. Thansk!

comment:35 by Frank Mehnert, 10 years ago

Resolution: fixed
Status: newclosed

VBox 4.2.18 contains the fix. Please reopen this defect if you still experience problems with 4.2.18.

Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use