Opened 10 years ago

Closed 6 years ago

#11948 closed defect (obsolete)

Network Interface Issues - After upgrade with Windows 8.1 and VB 4.2.16

Reported by: deedr Owned by:
Component: network Version: VirtualBox 4.2.16
Keywords: Cc:
Guest type: Linux Host type: Windows



I upgraded recently from Win 8 (as the main OS) and VB was working great! Then i upgrade to Win 8.1 and VB stopped working great :(. Yes i realize this points to a Win 8.1 issue, but think there's something goin on with the VB interface drivers, see below

After the upgrade to 8.1, my existing 4.2.14 version stopped working. Wouldn't boot and wouldn't give me the option to bridge the network interface adapted (there was never any interface listed in the bridged drop down). NAT, etc also didn't work for some odd/unexplained reason.

Luckily enough 4.2.16 was release and waddayaknow, it fixed something and i was able to select my NIC for a bridged interface. But then things really fall off the rails, after the upgrade/install of 4.2.16 (i've tried both, upgrade and "clean" install of VB 4.2.16) my internet connection stops working. If i have a ssh/tcp/http connection established, they stay up. but no new connections work. Also on reboot i'm not able to get out to anything and interface says "limitted connectivity" with no IP address.

Change History (45)

comment:1 by Joel, 10 years ago


i just did the same thing with exactly the same result. I upgraded to Windows 8.1 and once i've had installed 4.2.16, my internet connection dropped.

comment:2 by Frank Mehnert, 10 years ago

Could you remove VBox 4.2.16 again and install it, this time without support for "Host Networking"? Does that solve your problems?

comment:3 by Joel, 10 years ago

Hi Frank and thanks for your fast reply. I just tried to deinstall Virtualbox and reinstall it without the "Host-Only Networking" part. Unfortunately this has resulted in the same state where Windows lost its internet connectivity.

comment:4 by Joel, 10 years ago

If i install it completely without the networking part it obviously works. For the moment i use NAT instead of the bridge, which does also work for me.

comment:5 by deedr, 10 years ago

hey guys, so only installing to use NAT is do-able but def not ideal as was doing some simple home app "stuff". any ideas why the bridging portion craps out? or how to figure that out?

in reply to:  1 comment:6 by DWade, 10 years ago

Replying to Joel:


i just did the same thing with exactly the same result. I upgraded to Windows 8.1 and once i've had installed 4.2.16, my internet connection dropped.

It's the same in Windows 7, Ubuntu 12.04 and Ubuntu 13.04. If you try to go backwards to 4.2.14, the drivers are still gone. Only NAT will work. In Ubuntu, the WLan0 is available but does not work correctly. Only NAT works. I haven't checked it on Mac yet, I don't have it available to use.

I uninstalled and went back to version 4.2.6 in windows and virtual box drivers will not load or work. Only Nat available. Where are the drivers located so the files can be removed?

comment:7 by misha, 10 years ago

We were unable to reproduce the host networking issues using a clean Win 8.1 install and VBox 4.2.16.
Do you have any custom networking-related software installed on your win8.1 host? i.e. antivirus/firewall/VPN slient/other hypervisors/etc. ? What network card does your host have?

comment:8 by JCMartin, 10 years ago

Same issue here. Upgraded to Win 8.1 and either VirtualBox 4.2.14 and 4.2.16 will make the network unusable.

comment:9 by Frank Mehnert, 10 years ago

All users which have this problem: Could you answer mishas question to help debugging? Currently we are not able to reproduce the problem.

comment:10 by misha, 10 years ago

Besides that, please specify whether you updated from Win8 or just had a clean Win8.1 install.

comment:11 by Atmis, 10 years ago

I confirm the same issue after upgrading from Windows 8 to 8.1

When I have free time, I'll do some testing to see if I can give more details.

comment:12 by Glenn Choi, 10 years ago

We did a clean install of Windows 8.1pro and installed/used VirtualBox 4.2.14/16 with a virtual Windows 7 environment which worked for awhile, then the network connectivity would be lost in Windows 8.1.

Most of the time, it is a matter of bridging/unbridging the network adapter and VirtualBox host-only network a couple of times to regain network connectivity in Windows 8.1 where it seems the computer forgot the assigned network adapter information when getting the dhcp lease from the router.

When assigning a static IP/mask/gateway in Windows 8.1, the gateway address sometimes disappears and it is a matter of re-entering the gateway address.

The common trend seems to be the loss of Windows 8.1 gateway information in both scenarios.

Edit: To supply additional info Do you have any custom networking-related software installed on your win8.1 host? i.e. antivirus/firewall/VPN slient/other hypervisors/etc. ? None, except the preinstalled Windows Defender.

What network card does your host have? Onboard Lan through Asus p5n-d motherboard (NVIDIA nForce® 750i SLI built-in Gigabit MAC with external PHY)

Version 1, edited 10 years ago by Glenn Choi (previous) (next) (diff)

comment:13 by NoName, 10 years ago

I also met this problem today. First (fresh, not reinstall) installation of VirtualBox 4.2.16 on Windows 8.1 kill your internet connection.

Furthermore, the uninstall will NOT remove Virtualbox ethernet adapter, and you can't able to remove it manually (but at least the internet connection come back).

EDIT: On reinstall Virtualbox install one more Ethernet adapter, it not use the old one, and still can't delete the adapters.

Last edited 10 years ago by NoName (previous) (diff)

comment:14 by Atmis, 10 years ago

Here is more information :

  • I had Windows 8 and VirtualBox 4.2.16 setup : no problem. On this machine, I used to have Cisco VPN Client and Juniper Client, but they are now uninstalled for few weeks.
  • I upgraded to Windows 8.1 and VirtualBox was not able to list the network interfaces for bridging in my VM properties.
  • I tried to repair VirtualBox : No difference.
  • I uninstalled VirtualBox and reinstalled it : The network interfaces for bridging where back in my VM properties, BUT Windows Network is broken : if you open any connection status detail in Windows, the window is blank (no IP, no Gateway, nothing at all).
  • I uninstalled VirtualBox, and network is back to normal, even without restarting.
  • I reinstalled VirtualBox, with the Bridged networking support only (NOT the Host-only) : Network is broken again.
  • I uninstalled and reinstalled again, with the Host-only networking support only (NOT the bridged), and it works (except bridging of course).

The problem really seems to be related to the bridge networking support, so I temporarily switched my VM to NAT.

I hope this helps.

comment:15 by Atmis, 10 years ago

Ok, I was able to fix my problem, here is what I did.

I noticed that I had many network cards labeled "VirtualBox Bridged Networking Driver Miniport" with a yellow exclamation mark, remaining in Windows Device Manager, but impossible to delete them. I also noticed that Virtualbox setup was slow to complete.

I uninstalled Virtualbox, and went into Window Registry to manually delete those network cards (Registry key : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\ROOT\SUN_VBOXNETFLTMP). But it was impossible to delete that key. I changed the permissions on that key (Local admin group with total access, I switched the owner to local admin group, and activated inheritance). Inheritance could not be properly activated, and I was still unable to delete the key...

Then I reinstalled Virtualbox without bridged network, and I noticed the registry key was deleted (probably by Virtualbox setup), and the "VirtualBox Bridged Networking Driver Miniport" disappeared from device manager. Good point !

I uninstalled VB and reinstalled it again, with Bridged support, and voilà, everything is back to normal. Bridging is working, VB Setup is fast to complete, and Windows network is not broken anymore.

I think Windows 8.1 upgrade is somehow corrupting Windows registry, leading to this error.

PS : I also ran sfc.exe /scannnow to detect any possible error in Windows, but it didn't found anything, and I don't think it helped to solve the issue.

comment:16 by Frank Mehnert, 10 years ago

Hi Atmis, thank you very much for this information! So reading from your experiences I understand that the problem appears because during the Windows 8 => Windows 8.1 upgrade, Windows screws something up and this needs manual intervention, right? Maybe our installer could be extended to handle this case.

comment:17 by Atmis, 10 years ago


So far, this is my observation based on my experience. It would good if something else could confirm. Unfortunately, now that it is fixed (partly, see below), I can't reproduce the issue, but I tried to be as precise as I could in my resolution decription.

After few hours of use, I can say that the problem is not totally fixed : Windows network is broken (same symptom as before) after waking up the computer from sleep mode. That's the only problem I encountered for the moment.


comment:18 by Atmis, 10 years ago

Here is my latest feedback :)

Windows network is also broken after a system start/stop, but apparently, this is not always. As you probably now, start/stop in Windows 8 is different from a standard restart, it is more like a deep sleep.

I removed bridge functionnality as it is really not stable enough.

comment:19 by Justin Slauson, 10 years ago

I had the same problem for a while(network device error that required registry edits to uninstall), but was waiting for a fix. In the mean time, I installed Comodo firewall and by default it does not work. I looked into the problem there and had to change the registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network\MaxNumFilters. The value defaults to 1 in windows 8.1, but was 7 in previous versions. Everywhere I looked said to put it to 8, but that wasn't high enough to accommodate my setup. I set it at 15, reinstalled Comodo and it worked. Thinking there might be a link, I re-installed VB and everything just worked.

Now I have network bridging and all devices show as working; no issue in my VM's.

  • edit:

After further review, I still have issues on system reboot(likely as in previous posts, sleep or hibernation as well). The connection will not get dhcp until I disabled the "Virtualbox bridged networking driver" in the connection properties. As soon as I do that, I can bring the connection down and back up with out issue and then enable the driver again and all works.

More info: Everything worked fine in Windows 8, but then I did the public preview update and that's when it broke. If there's any other info I can provide, let me know.

Last edited 10 years ago by Justin Slauson (previous) (diff)

comment:20 by misha, 10 years ago

One more question to all having this issue: do you see this issue on 32bit or 64bit version of Win8.1?

comment:21 by Atmis, 10 years ago

In my case, this is the x64 version of Windows 8.1.

comment:22 by Justin Slauson, 10 years ago


comment:23 by avindra, 10 years ago

Also having this issue, as described by users above. Haven't found a solution yet. Even after using PsExec to manually delete the old (corrupted?) drivers, it still doesn't work.

For the miniport drivers, it shows this message:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

{Operation Failed}
The requested operation was unsuccessful.

comment:24 by NunoRelvao, 10 years ago

I also confirm this is a problem with windows 8.1RTM, as i have upgraded windows 8 to 8.1 RTM keeping all programs and settings, with VirtualBox even the latest 4.2.18, i had problems and computer didnt go to sleep.

After i uninstalled VirtualBox i have found that sleep now works.

comment:25 by Paul Déforge, 10 years ago

Same probleme after upgrade Windows 8 to 8.1... Found a solution : add service 'VirtualBox Bridged Network Driver' on your network card. After this, driver is fine in 'computer manager'

Like post, just start in point 5.1

Regards, Paul.

comment:26 by Paul Déforge, 10 years ago

Another thing, You hace certainly some USB problems, and perhaps a kernel problem whe you are starting VM...

Just reinstall VBoxDrv.inf and VBoxUSBMon.inf like

Another thing, your vm in state 'saved' is not going to work (network error name') => just forget state and everything is going well !!

comment:27 by joelsand, 10 years ago

Just wanted to confirm that I am experiencing this issue as well...

1) Had Windows 8 Pro x64 working with VB bridged networks

2) Performed in-place upgrade of Windows 8 to 8.1. At this point, normal Windows networking worked fine

3) VirtualBox could no longer see an host network adapters, thus bridging wouldn't work

4) Upgraded VB to 4.2.18... but the installer never completed, so I rebooted Windows.

5) Upon reboot, Windows networking did not work. Re-ran VB installer and it finished, but Windows networking still didn't work.

6) Uninstalled VB and re-installed, same condition

7) Now, I can get Windows networking to work if I uncheck the "VirtualBox Bridged Networking Driver" service in the adapter settings. In VB, I'm now forced to use NAT though - which is not ideal in my use-case.

Any other tips on getting bridged networks working on Windows 8.1?

comment:28 by Stirfry Rose, 10 years ago

Got this working with the final released version of Windows 8.1. I unticked the host only option and all was fine. Took some reboots / retries. This is using 4.3 as well, so not sure if this will help.

comment:29 by Schwedenbitter, 10 years ago

Since my upgrade to Windows 8.1 Professional 64bit (the very final) VirtualBox 4.2.18 r88780 doesn't show a network interface in it's common place. Non of my virtual Machines (Windows XP and openSUSE) won't start. Now I'm thinking to install the never version 4.3 by myself, which isn't quite curious shown via the menu "help" and "look for updates" (hope that's right because my VB is German). This message box keeps telling me I would have the latest version already.

But now I'm afraid of doing this. The last thing I could need is a not working network on my Windows 8.1 host. And unfortunately I don't exactly understand the pretty small howtos in comment 27 and 28.

Can anybody please give me some advice how to make VB work again without compromising my perfect running system?

comment:30 by eltazar, 10 years ago

Installing VB version 4.3 on my Windows 8.1 host (upgraded from Windows 8) solved the issue for me.

comment:31 by syntax53, 10 years ago

For me, after upgrading to 4.3 I still didn't have any network connectivity when the VirtualBox Bridged Networking Driver was ticked on the network card. I went into my network adapter and uninstalled the VirtualBox Bridged Networking Driver. Then reinstalled it from "C:\Program Files\Oracle\VirtualBox\drivers\network\netflt" and I can once again use bridged mode on my VMs.

comment:32 by geppy, 10 years ago

I'm having the same problems described in the post (Host-Only networking no longer works after upgrading to Windows 8.1), using:

  • Windows 8.1 Home (x64)
  • VirtualBox 4.2.18 r88780
  • 1x1 11b/g/n Wireless LAN PCI Express Half Mini Card Adapter

(The NIC came with my ThinkPad (x230), let me know if there's a way to find more detailed information for you on it.)

I'm running no special networking software (aside from VirtualBox).

EDIT: Upgrading VB to 4.2.3 fixed the problem.

Last edited 10 years ago by geppy (previous) (diff)

comment:33 by kenkyee, 10 years ago

Ditto needed an uninstall/reinstall after upgrading to Windows 8.1.

Symptoms were the same...bridged adapter didn't show anything to attach to.

comment:34 by shinji257, 10 years ago

I was able to install 4.3.2 when I tested today. Bridged networking driver is enabled on the wireless and I still have connectivity. Can't test functionality though as my battery got too low to work it out after installation. Just had enough to verify that network came back up on shutdown followed by power on.

OS: Windows 8.1 Pro w/ MCE

comment:35 by amm, 10 years ago

I just ran into the Bridged Network breaking issue after upgrading to windows 8.1 from Windows 8.0, last night. This morning when I turned on VB I noticed that I cannot anymore start with Bridged network as it(VB) indicates Invalid Settings Detected. This problem appears to have been reported as early as 6 months ago and it appears there is still no working solution. Anyone with any workaround ? My version of VB is 4.3.2. My Network Adapter is :Realtek PCIe GBE Family controller. Appreciate any help.

comment:36 by pordon, 10 years ago

Do not install the component «VirtualBox Bridged Networking»!!! Otherwise, in general, will no longer work online! When installing, select all the items in the screenshot:

Windows 8.1 x64 WMC; Realtek PCIe GBE Family controller; VirtualBox-4.3.4-91027

comment:37 by Olivier-Myriad, 10 years ago

I encountered the same problem as you all after updating my Windows 8 to 8.1. At least on my computer, it only seems to be a problem of service installation.

Here is the solution that worked for me (source here : :

I reinstalled VB completely (including Bridged Networking) then edited the properties of my network card, added a service and selected the bridged networking .inf file in the "drivers\network\netflt" subfolder of the VB install folder.

Once the service manually installed, the network card could be selected in the VM's drop-down menu, and all my VM could run in bridged mode again.

comment:38 by Aren Cambre, 10 years ago also worked for me. Unlike @Olivier-Myriad's experience, I didn't need to reinstall anything. I think the deal is simply that this service gets removed from the network adapter upon upgrade to 8.1.

comment:39 by mizzao, 10 years ago

I think there are two different issues mentioned here.

On a preinstalled Windows 8.1 that came with a Surface Pro 2, I am experiencing the problem where the host NIC disappears after the computer resumes from sleep. I have to restart in order to get network connectivity again. This has nothing to do with upgrades

This is also described in the thread

in reply to:  37 comment:40 by Willem, 10 years ago

Replying to Olivier-Myriad: Thanks for the link. Worked for me going from 8.0 to 8.1 with virtualbox 4.3.6 installed.

comment:41 by jokejong, 10 years ago

I am using a Thinkpad T440p, got it with Windows 8.0 pro x64, installed Virtual Box 4.3.6, then run an upgrade to windows 8.1.

I encountered problems with the running of virtual machines on a bridged and NAT environment.

I went to the device manager, found 2 devices that has exclamation marks on them, found out the driver is corrupted due to the upgrade of OS.

I uninstalled the drivers, removed them from my system frm the device manager. Then uninstalled Virtual Box, restarted the PC, and re-installed it with the same version 4.3.6 as it's the latest edition downloadable frm the net at the time of this writing.

Problem was solved after the installation and a reboot.

comment:42 by jokejong, 10 years ago

Hi Everyone, it's me again, and I posted the last update. now that I am trying to upgrade from 4.3.6 to 4.3.12, I faced the same problem.

as such, I had to do the exact same steps to uninstall the drivers, uninstall virtual box, then network adapters came back to life. after which, I had to restart pc, and then re-install latest virtual box.

as such, the solution in future, before running the upgrade to latest virtual box, please remember to uninstall the drivers for network adapter, and then uninstall the current virtual box instead of doing an in-place upgrade.

comment:43 by xorred, 9 years ago

I am unable to uninstall the Virtualbox Bridged Network Driver Miniport. Have at least 4 of them, with a yellow icon on them in device manager. Uninstalling Virtualbox, rebooting multiple times, trying to uninstall them - nothing. The moment I try to re-install Virtualbox and it installs it's driver - I lose Internet connection. Have to go to Network adapter properties and de-select the virtualbox driver from there to get Internet back again.

This happened after an upgrade from Windows 8 to Windows 8.1, keeping all my settings... now it does not matter how many times I uninstall and reinstall VirtualBox, I have the same problem over and over again.

s23.postimg DOT org/ixpsj65bf/Mezer_10_05_13_56_54.jpg

Properties of the device drivers show the following: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31) An object ID was not found in the file.

Wnenever I reinstall Virtualbox, I LOSE my internet connection until I uninstall it back again.

comment:44 by sidamus, 9 years ago

Although the majority of the problems with network bridging and VB on this incident are related to *upgrading* the host from Windows 8 to 8.1, I wanted to let everyone know that this is also a problem with a *clean* installation of Windows 8.1 (not an upgrade from Windows 8).

In my case I installed VB 4.3.20 (including the extension pack) on a clean Windows 8.1 installation. While I did see the network bridge adapter configured in the VB console, any attempts to start the guest resulted in the following error:


After searching online for this error I noticed a lot of people reporting this on Linux hosts but not Windows 8/8.1.

What helped me solve my problem was to re-install the base networking driver for my network adapter. I found this post to be especially helpful:

I'm eternally grateful to MartinŠ for sharing this workaround. I don't know if I'll have to do this again the next time I update to a new version of VirtualBox but for now I'm really relieved that I can continue to use bridged networking with my guests.

Here is the solution copied from the link above:

"Go to Device Manager --> Network adapters --> Uninstall network adapter (on which setting Bridged adapter is not working) --> Click on Scan for harware changes --> Restart PC --> after restart go to Device Manager --> Network adapters --> uninstalled network adapter will be marked with "!", again uninstall this network adapter --> Click on Scan for harware changes - now network adapter will be installed and restart will not be required. It is all, test Bridged adapter in VirtualBox ..."

comment:45 by Aleksey Ilyushin, 6 years ago

Resolution: obsolete
Status: newclosed
Note: See TracTickets for help on using tickets.

© 2023 Oracle
ContactPrivacy policyTerms of Use