VirtualBox

Ticket #11895 (closed defect: fixed)

Opened 10 months ago

Last modified 10 months ago

OVF import fails with NS_ERROR_ABORT after upgrade to 4.2.14 => Fixed in SVN

Reported by: javornikolov Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.14 Keywords:
Cc: Guest type: Linux
Host type: Linux

Description

VBoxManage import box.ovf 
0%...10%...20%...30%...40%...50%...60%...70%...80%...90%...100%
Interpreting /home/myuser/.vagrant.d/boxes/centos/virtualbox/box.ovf...
OK.
Disks:  vmdisk1	10632560640	-1	http://www.vmware.com/interfaces/specifications/vmdk.html#streamOptimized	box-disk1.vmdk	-1	-1	
Virtual system 0:
 0: Suggested OS type: "RedHat_64"
    (change with "--vsys 0 --ostype <type>"; use "list ostypes" to list all possible values)
 1: Suggested VM name "Berkshelf-CentOS-6.3-x86_64-minimal"
    (change with "--vsys 0 --vmname <name>")
 2: Number of CPUs: 2
    (change with "--vsys 0 --cpus <n>")
 3: Guest memory: 1024 MB
    (change with "--vsys 0 --memory <MB>")
 4: Network adapter: orig NAT, config 3, extra slot=0;type=NAT
 5: CD-ROM
    (disable with "--vsys 0 --unit 5 --ignore")
 6: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 6 --ignore")
 7: IDE controller, type PIIX4
    (disable with "--vsys 0 --unit 7 --ignore")
 8: SATA controller, type AHCI
    (disable with "--vsys 0 --unit 8 --ignore")
 9: Hard disk image: source image=box-disk1.vmdk, target path=/u02/virtualbox/Berkshelf-CentOS-6.3-x86_64-minimal/box-disk1.vmdk, controller=8;channel=0
    (change target path with "--vsys 0 --unit 9 --disk path";
    disable with "--vsys 0 --unit 9 --ignore")
Progress object failure: NS_ERROR_ABORT
  • The platform is Ubuntu Linux 13.04 64-bit
  • Same stuff used to work fine with previous versions of VirtualBox

Attachments

box.ovf Download (13.9 KB) - added by javornikolov 10 months ago.
The OVF file being imported
VBoxSVC.log Download (2.4 KB) - added by javornikolov 10 months ago.
vbox log file

Change History

Changed 10 months ago by javornikolov

The OVF file being imported

Changed 10 months ago by javornikolov

vbox log file

comment:1 Changed 10 months ago by javornikolov

Appliance import from GUI fails too.

Other information to reproduce the issue: the offending OVF appliance has been taken from  https://dl.dropbox.com/u/31081437/Berkshelf-CentOS-6.3-x86_64-minimal.box (Installed through through Vagrant  http://www.vagrantup.com/ utility)

Seems others are complaining by same issue:  http://www.marshut.com/pzisi/progress-object-failure-ns-error-call-failed-when-running-vagrant-up-in-getting-started-guide.html

Last edited 10 months ago by javornikolov (previous) (diff)

comment:2 follow-up: ↓ 7 Changed 10 months ago by frank

Thanks for the report. This is a 4.2.14 regression and happens only for appliances without a manifest. We already fixed the bug in the repository. Could you install  this test build and confirm that the problem is gone? Thank you!

comment:3 Changed 10 months ago by frank

  • Summary changed from OVF appliance import fails with NS_ERROR_ABORT after upgrade to 4.2.14 to OVF import fails with NS_ERROR_ABORT after upgrade to 4.2.14 => Fixed in SVN

comment:4 Changed 10 months ago by jrosengren

I was seeing the same issue with 4.2.14. The test build in comment:2 fixed the issue for me.

comment:5 Changed 10 months ago by gerardo.lisboa

quick workaround: go to the directory where the ovf file is placed and create the missing manifests following the instructions in  http://www.virtuallyghetto.com/2012/01/how-to-create-manifest-file-for-ovf.html

comment:6 Changed 10 months ago by javornikolov

I just tested the provided test build as per comment:2 and it solved the problem. Thanks!

comment:7 in reply to: ↑ 2 Changed 10 months ago by terrywang

Replying to frank: Thanks Frank. The  4.2.15-86695 build does fix the import issue. Vagrant works fine now with the same appliance.

comment:8 Changed 10 months ago by flaccid

When will 4.2.15 be available for download? I use Arch Linux.

comment:9 follow-up: ↓ 10 Changed 10 months ago by michael_hodgins

I'm having the same problem on Mac OSX. Is there a .dmg for 4.2.15-86695?

comment:10 in reply to: ↑ 9 ; follow-up: ↓ 11 Changed 10 months ago by terrywang

Replying to michael_hodgins:

I'm having the same problem on Mac OSX. Is there a .dmg for 4.2.15-86695?

Try manually generating the manifest using openssl and re-import as a workaround. I don't think there is a OS X 4.2.15 build.

Details =>  Vagrant Issue 1850

comment:11 in reply to: ↑ 10 Changed 10 months ago by michael_hodgins

Replying to terrywang:

Details =>  Vagrant Issue 1850

Thanks, Terry, that worked fine.

comment:12 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Finally fixed in 4.2.16 (released today).

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use