VirtualBox

Ticket #11792 (closed defect: fixed)

Opened 11 months ago

Last modified 10 months ago

Shared Clipboard --> Cannot copy and paste from one Guest to another Guest (2nd time) -> fixed in releases after May 29 2013 (4.2.x and later)

Reported by: quickbooks Owned by:
Priority: major Component: clipboard
Version: VirtualBox 4.2.12 Keywords:
Cc: quickbooks.office@… Guest type: all
Host type: all

Description

Shared Clipboard --> Cannot copy and paste from one Guest to another Guest.

It only works the first time. Then it stops working.

Both guests here are Fedora 18.

Host is Fedora 18.

If you want to copy a second time, you need to first paste it to the host, and then copy again from the host, and paste it to the second guest.

Attachments

firstGuest.log Download (3.4 KB) - added by quickbooks 11 months ago.
SecondGuest.log Download (4.5 KB) - added by quickbooks 11 months ago.
firstGuestRun2.log Download (6.5 KB) - added by quickbooks 11 months ago.
secondGuestRun2.log Download (8.4 KB) - added by quickbooks 11 months ago.
FirstGuestHost-2013-05-26-19-48-41.log Download (102.1 KB) - added by quickbooks 11 months ago.
secondGuestHost-2013-05-26-19-48-41.log Download (94.2 KB) - added by quickbooks 11 months ago.
firstClipboardRun3.log Download (7.6 KB) - added by quickbooks 11 months ago.
secondClipboardRun3.log Download (13.9 KB) - added by quickbooks 11 months ago.
firstGuestHostrun3-2013-05-27-13-13-15.log Download (104.4 KB) - added by quickbooks 11 months ago.
secondGuestHostrun3-2013-05-27-13-13-15.log Download (96.8 KB) - added by quickbooks 11 months ago.

Change History

comment:1 Changed 11 months ago by michael

It would be great if you could try to debug this a bit. We have guidelines on a wiki page<1>. Feel free to point out any possible improvements to the debugging guidelines!

<1> https://www.virtualbox.org/wiki/X11Clipboard

comment:2 Changed 11 months ago by quickbooks

[user9@localhost ~]$ ps -Af | grep VBoxClient
user9     2267  2215  0 00:35 pts/0    00:00:00 grep --color=auto VBoxClient

The "--clipboard" is not there?

VBoxClient is at the end of the line? Shouldn't it be before "--color=auto"?

[user9@localhost ~]$ VBOX_RELEASE_LOG_DEST=file=/tmp/clipboard.log VBOX_RELEASE_LOG=+all.e.l.f VBoxClient -d --clipboard
bash: VBoxClient: command not found...
[user9@localhost ~]$ 

Then it says command not found?

comment:3 follow-up: ↓ 4 Changed 11 months ago by michael

That looks to me as though you are executing those commands on the host, or on a guest without Additions installed.

comment:4 in reply to: ↑ 3 Changed 11 months ago by quickbooks

Replying to michael:

That looks to me as though you are executing those commands on the host, or on a guest without Additions installed.

yes I executed those commands on the host.

I will try again on the guests in a couple of days.

sorry about that.

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

comment:5 Changed 11 months ago by quickbooks

  1. Copy "testcopy1" from first guest.
  2. Pastes "testcopy1" to second guest. (Correct)
  1. Copy "testcopy2" from first guest.
  2. Pastes "testcopy1" to second guest. (Wrong. It should paste "testcopy2" not "testcopy1")

Note this is same for Windows guests also (not just linux guests).

comment:6 Changed 11 months ago by quickbooks

I messed up.

I put

[user@localhost ~]$ VBOX_RELEASE_LOG=+shared_clipboard.e.l.f

instead of

[user@localhost ~]$ VBOX_RELEASE_LOG=+shared_clipboard.e.l.f VirtualBox

Attaching new log files (Run2).

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

comment:7 Changed 11 months ago by quickbooks

  1. Copy "testCopy1Run2" from First Guest.
  2. Pastes "testCopy1Run2" to Second Guest. (Correct)

  1. Copy "testCopy2Run2" from First Guest.
  2. Pastes "testCopy1Run2" to Second Guest. (Wrong. It should paste "testCopy2Run2")
  3. Pastes "testCopy2Run2" to Host. (Correct)

comment:8 follow-up: ↓ 9 Changed 11 months ago by michael

How nice. When we announce new clipboard data, the X toolkit checkes whether we already own the clipboard and suppresses the announcement if we do. Would you care to give this build a try? It is trunk (4.2.51) as I saw from the log that you were already running that.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-86034-Linux_amd64.run

comment:9 in reply to: ↑ 8 Changed 11 months ago by quickbooks

Replying to michael:

How nice. When we announce new clipboard data, the X toolkit checkes whether we already own the clipboard and suppresses the announcement if we do. Would you care to give this build a try? It is trunk (4.2.51) as I saw from the log that you were already running that.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-86034-Linux_amd64.run

Thank you for the updated build.

Your fix works. You probably have to press copy twice the first time, but after that copy and paste works fine. So thank you.

comment:10 follow-up: ↓ 11 Changed 11 months ago by michael

Since I have debugged this this far, would you be interested to elaborate about that "press copy twice the first time"? And thanks for confirming that the fix works otherwise.

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

Changed 11 months ago by quickbooks

comment:11 in reply to: ↑ 10 Changed 11 months ago by quickbooks

Replying to michael:

Since I have debugged this this far, would you be interested to elaborate about that "press copy twice the first time"? And thanks for confirming that the fix works otherwise.


  1. Press copy "testCopy1Run3" in First Guest.
  2. Nothing pastes to Second Guest. (Wrong) (clipboard is empty for Second Guest?)
  3. Pastes "testCopy1Run3" to Host. (Correct)

  1. Press copy again on "testCopy1Run3" in First Guest.
  2. Pastes "testCopy1Run3" to Second Guest. (Correct)

  1. Press copy on "testCopy2Run3" in First Guest.
  2. Pastes "testCopy2Run3" to Second Guest. (Correct)

  1. Press copy on "testCopy3Run3" in First Guest.
  2. Pastes "testCopy3Run3" to Second Guest. (Correct)

comment:12 follow-up: ↓ 13 Changed 11 months ago by michael

Interesting. Would you be able to get log files for that? Thank you.

comment:13 in reply to: ↑ 12 Changed 11 months ago by quickbooks

Replying to michael:

Interesting. Would you be able to get log files for that? Thank you.

I posted the log files before the last comment :)

PS. I stopped logging after step 7 (but I can confirm step 8 and 9 works fine):


Inside guest 1:

https://www.virtualbox.org/attachment/ticket/11792/firstClipboardRun3.log


Guest 1 log from host:

https://www.virtualbox.org/attachment/ticket/11792/firstGuestHostrun3-2013-05-27-13-13-15.log


Inside guest 2:

https://www.virtualbox.org/attachment/ticket/11792/secondClipboardRun3.log


Guest 2 log from host:

https://www.virtualbox.org/attachment/ticket/11792/secondGuestHostrun3-2013-05-27-13-13-15.log


comment:14 Changed 11 months ago by michael

Excuse me, I did not see them. Thank you, I will take a look!

comment:15 follow-up: ↓ 16 Changed 11 months ago by michael

Please give this build a try. It seems that the Xt toolkit does not cope well with several operations on the clipboard in parallel, and now the other virtual machine is sending out two "new data" announcements on those occasions when the toolkit doesn't suppress the announcement. I could prevent that of course, but I preferred to keep the code simple. Which revealed this problem.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-86055-Linux_amd64.run

comment:16 in reply to: ↑ 15 Changed 11 months ago by quickbooks

Replying to michael:

Please give this build a try. It seems that the Xt toolkit does not cope well with several operations on the clipboard in parallel, and now the other virtual machine is sending out two "new data" announcements on those occasions when the toolkit doesn't suppress the announcement. I could prevent that of course, but I preferred to keep the code simple. Which revealed this problem.

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-86055-Linux_amd64.run

It works perfectly with the latest test build (4.2.51-86055). Thank you. Much appreciated.

Last edited 11 months ago by quickbooks (previous) (diff)

comment:17 Changed 11 months ago by michael

  • Summary changed from Shared Clipboard --> Cannot copy and paste from one Guest to another Guest (2nd time) to Shared Clipboard --> Cannot copy and paste from one Guest to another Guest (2nd time) -> fixed in releases after May 29 2003 (4.2.x and later)

Thanks for the confirmation.

comment:18 Changed 11 months ago by michael

  • Summary changed from Shared Clipboard --> Cannot copy and paste from one Guest to another Guest (2nd time) -> fixed in releases after May 29 2003 (4.2.x and later) to Shared Clipboard --> Cannot copy and paste from one Guest to another Guest (2nd time) -> fixed in releases after May 29 2013 (4.2.x and later)

comment:19 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use