VirtualBox

Ticket #1177 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

v1.5.4: Incorrect text cursor colour in guest display when using Crimson editor

Reported by: bifferos Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 2.1.2 Keywords:
Cc: Guest type: Windows
Host type: other

Description

Guest: Windows XP sp2
Host: Slackware linux 12.0
Application: Crimson Editor v3.70 (freeware)  http://www.crimsoneditor.com/

Steps to reproduce:

*Install Crimson editor
*Run Crimson
*From the menu select View -> Set Colors
*From the "Load color scheme" drop-down select 'reversed color scheme'
*Click "Load"
*Close the dialog
*Type some text in the editor window 

Notice that when the mouse cursor is over the text, it is black instead of white, as it would be when running Windows natively. I have run Crimson on a few other machines (always reversed colour scheme and never had this problem. My display depth inside the guest is 32-bit, xorg is running at 24-bit.

Unfortunately not being able to locate the cursor inside the editor window of Crimson makes this color scheme almost unusable. I never realised I relied on the mouse so much.

Change History

comment:1 Changed 5 years ago by dpo

Similar problem with PuTTY / VirtualBox 2.1.2:

Guest: Windows XP SP3 Host: Fedora 10 Application: PuTTY Tray 0.60 (r3)  http://www.xs4all.nl/~whaa/putty/

The background of PuTTY is black, the cursor is black as well. The cursor is invisible.

comment:2 Changed 5 years ago by sandervl73

  • Version changed from VirtualBox 1.5.4 to VirtualBox 2.1.2
  • Component changed from other to guest additions
  • Guest type changed from other to Windows

comment:3 Changed 5 years ago by dpo

Could be a duplicate of ticket #750.

comment:4 Changed 5 years ago by dpo

Definitely a duplicate of ticket #750: I can reproduce the problem with Crimson Editor 3.72 with mouse integration enabled. You can work around it by disabling mouse pointer integration.

Problem is still there in VirtualBox 2.2.4.

comment:5 Changed 5 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use