VirtualBox

Ticket #11737 (closed defect: duplicate)

Opened 12 months ago

Last modified 12 months ago

Linux guest mouse buttons remapping when switching to host and back -> duplicate of #6171

Reported by: mrmikee Owned by:
Priority: major Component: guest additions
Version: VirtualBox 4.2.12 Keywords: linux mouse guest button mapping
Cc: Guest type: Linux
Host type: Windows

Description

Host: Windows 7 32 bit Virtualbox 4.2.12 Guest: Linux Mint 14 Nadia(Mate) with Guest Additions Mouse: Logitech M705 10 button w/scroll wheel USB Unity

Mouse works in Windows Host with latest Logitech drivers installed and in guest when first booted.

The mouse wheel scrolling fails after switching from the Linux guest to Win7 host and back to Linux.

Running "xev|grep button" before this all buttons are mapped correctly. After switching to the host and back the buttons for the mouse wheel (buttons 4 5) become (buttons 6 7) and scrolling no longer works in linux guest, but is still working properly in the windows host.

Attempted patches: edit /usr/share/X11/xorg.conf.d/50-vmmouse.conf +++ Option "Buttons" "10" +++ Option "ButtonMapping" "1 2 3 4 5 4 5 8 9" +++ Option "ZAxisMapping" "4 5"

Attachments

VM-2013-04-19-11-32-10.log Download (84.1 KB) - added by mrmikee 12 months ago.

Change History

Changed 12 months ago by mrmikee

comment:1 Changed 12 months ago by mrmikee

Clarification: The Attempted patches did not fix or patch the issue.

comment:2 Changed 12 months ago by michael

I wonder whether this is the same thing as ticket #11665.

comment:3 Changed 12 months ago by mrmikee

Ok, update, once returned to the Linux guest, if I press the "HOST" button (<right CTRL>) then the <left Alt> and the "HOST" button again, the mouse buttons remap back to "4 5" for the scroll wheel per "xev|grep button" output.

Version 1, edited 12 months ago by mrmikee (previous) (next) (diff)

comment:4 Changed 12 months ago by michael

If you want to see (a lot!) more information in the log file about how mouse information is being sent to the guest you could start the virtual machine with the following environment variable set (unfortunately it provides less output if you are using USB mouse emulation, which it looks from the log file that you are):

VBOX_RELEASE_LOG="+main.e.l3+dev_kbd.e.l3"

comment:5 Changed 12 months ago by mrmikee

Seems this issue has been around for about three years. I missed this one in my "web search".... https://www.virtualbox.org/ticket/6171

Again for me at least the patch is:

<Host Key><left ALT><Host Key> in the linux guest to resume normal mouse wheel scrolling.

It's extremely annoying that this happens. I switch between host and guest at least 50-100 times per work day.

Last edited 12 months ago by mrmikee (previous) (diff)

comment:6 Changed 12 months ago by michael

  • Status changed from new to closed
  • Resolution set to duplicate
  • Summary changed from Linux guest mouse buttons remapping when switching to host and back to Linux guest mouse buttons remapping when switching to host and back -> duplicate of #6171

I will mark this ticket a duplicate and will post an update on #6171 shortly.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use