VirtualBox

Ticket #11718 (closed defect: fixed)

Opened 12 months ago

Last modified 10 months ago

cannot resume saved state with 4.2.12 => Fixed in SVN

Reported by: mike-spainhower Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.12 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

Possible regression of https://www.virtualbox.org/ticket/10126

I suspended my VM with 4.2.10, then upgraded to 4.2.12. Resuming the machine now fails with the following error:

Failed to open a session for the virtual machine Spain Ubuntu 64.

Failed to load unit 'HGCM' (VERR_SSM_LOADED_TOO_MUCH).

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: Console
Interface: IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

Host: Mac OS X 10.8.3; Guest: Ubuntu 12.10

Attachments

VBox.log Download (96.8 KB) - added by mike-spainhower 12 months ago.
Log for failing restore
VBox.2.log Download (95.0 KB) - added by prfernando 12 months ago.

Change History

Changed 12 months ago by mike-spainhower

Log for failing restore

comment:1 Changed 12 months ago by prfernando

I have the same problem - My host: Mac OS X 10.6.8; My guest: 64-bit Ubuntu 12.10. I too upgraded from VBox 4.2.10 to 4.2.12 and got the following error message:

''''''Failed to load unit 'HGCM' (VERR_SSM_LOADED_TOO_MUCH).''''''

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}


Changed 12 months ago by prfernando

comment:2 Changed 12 months ago by prfernando

FYI: Strangely, I was able to resume a 64 bit Windows 7 Enterprise guest using the updated VirtualBox 4.2.12!!!

comment:3 Changed 12 months ago by misha

We are aware of this problem, and should have a fix for it soon.

comment:4 follow-up: ↓ 5 Changed 12 months ago by misha

Thanks for the report, we have found and fixed this issue now.
Here is a test build containing the fix. Please give it a try and let me know whether the issue is solved with it:

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.13-85147-OSX.dmg

Let me know if you need a build for any non-osx host.

comment:5 in reply to: ↑ 4 Changed 12 months ago by prfernando

The build you have provided has solved the issue. Both my windows7 64-bit guest and my ubuntu 64-bit guest are now functioning properly. Thanks for your quick fix.

Replying to misha:

Thanks for the report, we have found and fixed this issue now.
Here is a test build containing the fix. Please give it a try and let me know whether the issue is solved with it:

 http://www.virtualbox.org/download/testcase/VirtualBox-4.2.13-85147-OSX.dmg

Let me know if you need a build for any non-osx host.

comment:6 Changed 11 months ago by frank

  • Summary changed from cannot resume saved state with 4.2.12 to cannot resume saved state with 4.2.12 => Fixed in SVN

Thanks for the feedback!

comment:7 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Fix is part of VBox 4.2.14.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use