VirtualBox

Ticket #11709 (closed defect: fixed)

Opened 12 months ago

Last modified 8 months ago

VirtualBox Guest Additions 4.2.12 breaks Ubuntu 12.04 guest => Fixed in SVN

Reported by: David Anderson Owned by:
Priority: critical Component: guest additions
Version: VirtualBox 4.2.12 Keywords: 4.2.12 breaks Ubuntu 12.04 guest
Cc: Guest type: Linux
Host type: Windows

Description

I upgraded to VirtualBox version 4.2.12 on my Windows 7 host and the guest additions version 4.2.12 onto my Ubuntu 12.04 guest. Having installed the guest additions, the guest system became unusable with an error about the graphics configuration. It offered to go into low graphics mode but this didn't work either. All I could get was a command prompt. I rolled back to verion 4.2.10 with the following steps and now the system is fine again. Before the roll-back, I tried reinstalling the guest additions but it didn't help.

Rollback procedure (for the benefit of others with the same problem)

  1. Uninstalled the guest additions in the Ubuntu guest from the command prompt

cd /opt/VBoxGuestAdditions-4.2.12

sudo ./uninstall.sh

  1. Shutdown guest (actually I think it wouldn't shut down and I had to power it off)
  1. Uninstalled VirtualBox in Windows (Control Panel, Uninstall a program, Oracle VM VirtualBox 4.2.12).
  1. Reinstalled VirtualBox 4.2.10 in Windows 7 host (downloaded from VirtualBox web downloads section, previous versions link).
  1. Reinstalled guest additions version 4.2.10 in Ubuntu 12.04 guest.

Attachments

Xorg.0.log Download (32.3 KB) - added by fzoc 12 months ago.
Xorg.0.log
f456__ubuntu_32-2013-04-27-10-01-02.log Download (96.8 KB) - added by f456 12 months ago.
patch worked for a day, then the problem reoccured.
Xorg.0.2.log Download (34.6 KB) - added by randomwhitetrash 10 months ago.
Ubuntu 12.04 not booting with 4.14 GA
vboxadd-install.log.gz Download (38.3 KB) - added by randomwhitetrash 10 months ago.
Ubuntu 12.04 not booting with 4.2.14 GA
Xorg.0.log.png Download (24.2 KB) - added by Wanchy 9 months ago.

Change History

comment:1 Changed 12 months ago by frank

Unable to reproduce. Please could you add a VBox.log file of VBox 4.2.12 with 4.2.12 Additions installed together with the /var/log/Xorg.0.log file form the guest?

Changed 12 months ago by fzoc

Xorg.0.log

comment:2 Changed 12 months ago by fzoc

Almost the same problem for me, except that I was able to boot using 2D desktop. 3D acceleration does not work anymore, despite trying to uninstall and reinstall the 4.2.12 guest additions.

I attached my Xorg.0.log file to the ticket.

comment:3 Changed 12 months ago by vensasa

I too have had this problem as well. it is reproducable. When I installed the 4.2.12 guest addition, and rebooted, I got error messages about the graphics not being configured and could not log in with full resolution. In other words, 4.2.12 breaks Ubuntu 12.04 VMs making the graphics unuseable.

I had to go back to 4.2.10, and install the 4.2.10 guest additions, removing all of 4.2.12, to get things working again. It was a big mess

comment:4 Changed 12 months ago by ivarho

Confirmed here as well, a rollback to 4.2.10 fixes the problem.

comment:5 Changed 12 months ago by michael

Could you please try installing the 4.2.12 Additions on a fresh Ubuntu 12.04 virtual machine (or 12.04.2, depending on what you are using now) and see if that works? I can't seem to reproduce the issue here, so I hope that may provide more information.

comment:6 Changed 12 months ago by debian-root

Confirmed as well for Windows 7 host and Ubuntu 12.04 guest after upgrading to VB 4.2.12 and installing the according VBoxGuestAdditions afterwards.

To resolve this, I downloaded the VBoxGuestAdditions_4.2.10.iso, mounted it via

mount -o loop /root/VBoxGuestAdditions_4.2.10.iso /mnt/

and started the VBoxGuestAdditions installation script from within /mnt.

That uninstalled the 4.2.12 additions and installed the 4.2.10 additions again. Afterwards, the VM started normally.

The problem can be reproduced by installig the 4.2.12 additions again, so starting from VB 4.2.10 and upgrading should work to reproduce the issue.

comment:7 Changed 12 months ago by Iancdn

I have the same problem, same symptoms as original poster. Fortunately I had a backup, so restored the vm. Continuing to use Vbox 4.2.12, but without updating the additions to the latest version. Anxiously awaiting a fix.

Windows 7 host (latest updates), Ubuntu 12.04 guest.

comment:8 Changed 12 months ago by dvisser

Many have described this issue in the forums:  https://forums.virtualbox.org/viewtopic.php?f=1&t=55091#p253699

comment:9 Changed 12 months ago by mnowotka

I have the same problem in my mac! Please fix it ASAP!

comment:10 Changed 12 months ago by mnowotka

Last edited 12 months ago by mnowotka (previous) (diff)

comment:11 Changed 12 months ago by frank

It seems that only Ubuntu 12.04 systems are affected. For the time being, please install the 4.2.10 Additions in such guests.

comment:12 follow-ups: ↓ 13 ↓ 14 ↓ 19 ↓ 23 Changed 12 months ago by frank

Fix in r45603. Either apply this fix manually to /usr/src/vboxguest-4.2.12/vboxvideo/vboxvideo_drm.c or install  this .iso image containing the same fix.

comment:13 in reply to: ↑ 12 Changed 12 months ago by debian-root

Replying to frank:

Fix in r45603. Either apply this fix manually to /usr/src/vboxguest-4.2.12/vboxvideo/vboxvideo_drm.c or install  this .iso image containing the same fix.

I had VB 4.2.12 installed, together with GA 4.2.10, crossed my fingers, downloaded the .iso image and run the installation script for GA.

Everything went on fine and I could reboot the VM without any problems.

Well done! Thank you!

comment:14 in reply to: ↑ 12 Changed 12 months ago by MXWest

Replying to frank:

Fix in r45603. Either apply this fix manually to /usr/src/vboxguest-4.2.12/vboxvideo/vboxvideo_drm.c or install  this .iso image containing the same fix.

Thank you. Fix works here, installed via .iso image. Running OS X 10.8.3 (12D78).

comment:15 Changed 12 months ago by jpgeek

Fix worked for me too. Running Ubuntu 12.04 as both Host and guest,

3.2.0-40-generic 64-Ubuntu SMP

Thanks!

comment:16 follow-up: ↓ 17 Changed 12 months ago by Iancdn

Fix also worked for me, win 7 host, ubuntu 12.04 32 bit guest.

Thanks

comment:17 in reply to: ↑ 16 Changed 12 months ago by dvisser

Replying to Iancdn:

Fix also worked for me, win 7 host, ubuntu 12.04 32 bit guest.

Ditto for me, same config.

comment:18 Changed 12 months ago by fermulator

At first I attempted modifying the source on the guest OS in /usr/src/... pointing the Linux.run file to the vboxvideo SRC to the patched vboxvideo_drm.c, however the MD5 checksum failed and tried to bypass that but then there was some other error...

I gave up on that, and just used the .iso file linked above, worked fine.

comment:19 in reply to: ↑ 12 Changed 12 months ago by wtanaka

Replying to frank:

Fix in r45603. install  this .iso image

This worked for me.

comment:20 Changed 12 months ago by chrone

yay thanks for the 4.2.13 ga iso link! it works!

comment:21 Changed 12 months ago by f456

The patch appeared to work for a few hours with my ubuntu 12.10. The next day, however, the same problem re-occured - now the screen turns black or white when i resize it.

Log attached.

Changed 12 months ago by f456

patch worked for a day, then the problem reoccured.

comment:22 Changed 12 months ago by michael

f456: this change is only expected to be relevant for Ubuntu 12.04 guests (original release, not .1 or .2). Please see if you can find a ticket which better fits what you are seeing or open a new one. You will probably want to be looking at your guest system's system log file (var/log/syslog) or dmesg output and /var/log/Xorg*log* for information to help you decide if your problem matches an existing ticket. And attaching a machine log file as you did here (thank you!) is always a good idea.

comment:23 in reply to: ↑ 12 Changed 11 months ago by sworwasbreathing

Replying to frank:

Fix in r45603. Either apply this fix manually to /usr/src/vboxguest-4.2.12/vboxvideo/vboxvideo_drm.c or install  this .iso image containing the same fix.

Looks like the link to the iso is down. Any chance we could see it returned? I'm facing the same issue and would like to install the updated guest additions.

comment:24 follow-up: ↓ 26 Changed 11 months ago by frank

 Here is another test build.

comment:25 Changed 11 months ago by frank

  • Summary changed from VirtualBox Guest Additions 4.2.12 breaks Ubuntu 12.04 guest to VirtualBox Guest Additions 4.2.12 breaks Ubuntu 12.04 guest => Fixed in SVN

comment:26 in reply to: ↑ 24 Changed 11 months ago by Csq

Replying to frank:

 Here is another test build.

The ISO is down again :(

It would be great to have 4.2.14 to finally solve this issue...

Meanwhile I've found the  new ISO, seems to work.

Last edited 11 months ago by Csq (previous) (diff)

comment:27 Changed 11 months ago by frank

 Here is another test build. These links are only valid for 21 days. I hope we can release the next maintenance release before this link expires (no guarantee though).

comment:28 Changed 10 months ago by super_ed_9000

Test build in comment 27 worked for me

Win 7 64 host, Ubuntu 12.04.2 LTS 32bit

Thanks!

comment:29 Changed 10 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Now finally fixed in 4.2.14.

comment:30 Changed 10 months ago by randomwhitetrash

Hm... Not sure how its fixed, unless you call black screen during boot up a fix.

Once upgraded to Additions .14 I can not boot up. It just hangs with black screen. I can still Ctrl-F1 to another console and uninstall guest additions and then it works. If I download GA .12 and install those everything works.

I am running Ubuntu as a guest on Win 8 host.

comment:31 Changed 10 months ago by frank

randomwhitetrash, I need more information here. At least the /var/log/vboxadd-install.log file from the guest when you installed the 4.2.14 Additions as well as /var/log/Xorg.0.log. Ubuntu 12.04 guests run fine here with 4.2.14 Additions.

Changed 10 months ago by randomwhitetrash

Ubuntu 12.04 not booting with 4.14 GA

Changed 10 months ago by randomwhitetrash

Ubuntu 12.04 not booting with 4.2.14 GA

comment:32 Changed 10 months ago by randomwhitetrash

As requested I attached the logs, kind sir.

comment:33 Changed 10 months ago by frank

Looks normal. I wonder if the 4.2.12 Additions do really work for your guest (including mouse integration and automatic change of the guest screen resolution by resizing the VM window).

Does it make any difference if you toggle 3D support for that VM in the VM settings?

Changed 9 months ago by Wanchy

comment:34 Changed 9 months ago by Wanchy

Hi,

I'm experiencing the same problem with VBoxGuestAdditions 4.2.16 on my Ubuntu 12.04 x86_64 guest (running on a Windows 7 x86_64 host).

Installing GA 4.2.16 results with the following error: "Installing graphics libraries and desktop services components ...fail!" After restarting the Ubuntu guest machine, I just get a black screen.

Ctrl-F1 still works, so I was able to make a screenshot of the Xorg.0.log file (or at least the last part of it).

When I remove the Additions, my Ubuntu guest boots normally.

Last edited 9 months ago by Wanchy (previous) (diff)

comment:35 Changed 8 months ago by mrhipp

This problem is still present in 4.2.16 on Win7x64 host with Ubuntu 12.04.2 x32 guest. Black screen upon boot after fresh install with a message about "low graphics".

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use