VirtualBox

Ticket #11642 (closed defect: duplicate)

Opened 13 months ago

Last modified 13 months ago

vboxsf does not support hard or soft file symlinks

Reported by: RoelV Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.2.10 Keywords: vboxsf ln symlink
Cc: Guest type: Linux
Host type: Windows

Description

[roel@localhost ssd]$ mount | grep "vboxsf" /ssd on /ssd type vboxsf (rw) ssd on /media/sf_ssd type vboxsf (gid=501,rw) [roel@localhost ssd]$ echo "test" > test1 [roel@localhost ssd]$ ln test1 test2 ln: creating hard link test2' => test1': Operation not permitted [roel@localhost ssd]$ ln -s test1 test2 ln: creating symbolic link `test2': Read-only file system [roel@localhost ssd]$ cd ~ [roel@localhost ~]$ echo "test" > test1 [roel@localhost ~]$ ln test1 test2 [roel@localhost ~]$ ln -s test1 test2 ln: creating symbolic link `test2': File exists [roel@localhost ~]$ rm test2 [roel@localhost ~]$ ln -s test1 test2 [roel@localhost ssd]$ tar -xf Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64.tar.gz tar: Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64/lib/libmysqlclient_r.a: Cannot create symlink to `libmysqlclient.a': Read-only file system tar: Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64/lib/libmysqlclient.so: Cannot create symlink to `libmysqlclient.so.18': Read-only file system

Btw, the file system is definitely not read-only (and as a sidenote privileges are set to 777), as can be seen from the successful creation of test1 initially as per the above. It can also be seen by the fact that the tar is successful in extracting files, except for symlinks.

Change History

comment:1 Changed 13 months ago by RoelV

Hrm. Ticketing system removed newslines from paste. Trying again:

[roel@localhost ssd]$ mount | grep "vboxsf"
/ssd on /ssd type vboxsf (rw)
ssd on /media/sf_ssd type vboxsf (gid=501,rw)
[roel@localhost ssd]$ echo "test" > test1
[roel@localhost ssd]$ ln test1 test2
ln: creating hard link test2' => test1': Operation not permitted
[roel@localhost ssd]$ ln -s test1 test2
ln: creating symbolic link `test2': Read-only file system
[roel@localhost ssd]$ cd ~
[roel@localhost ~]$ echo "test" > test1
[roel@localhost ~]$ ln test1 test2
[roel@localhost ~]$ ln -s test1 test2
ln: creating symbolic link `test2': File exists
[roel@localhost ~]$ rm test2
[roel@localhost ~]$ ln -s test1 test2
[roel@localhost ~]$

[roel@localhost ssd]$ tar -xf Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64.tar.gz tar: Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64/lib/libmysqlclient_r.a: Cannot create symlink to `libmysqlclient.a': Read-only file system tar: Percona-Server-5.6.8-alpha60.2-313.Linux.x86_64/lib/libmysqlclient.so: Cannot create symlink to `libmysqlclient.so.18': Read-only file system

comment:2 Changed 13 months ago by RoelV

I can imagine that this is related to Windows support for symlinks. However, Windows does have linking support:  http://technet.microsoft.com/en-us/library/cc753194%28WS.10%29.aspx so it would be possible to implement.

comment:3 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #10085.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use