VirtualBox

Ticket #11641 (closed defect: wontfix)

Opened 13 months ago

Last modified 13 months ago

vboxsf does not seem to support BLKGETSIZE & BLKFLSBUF

Reported by: RoelV Owned by:
Priority: major Component: shared folders
Version: VirtualBox 4.2.10 Keywords: vboxsf
Cc: Guest type: Linux
Host type: Windows

Description (last modified by frank) (diff)

[roel@localhost ~]$ mount | egrep "sda|vboxsf"
/dev/sda1 on /boot type ext4 (rw)
/ssd on /ssd type vboxsf (rw)
ssd on /media/sf_ssd type vboxsf (gid=501,rw)
[roel@localhost ~]$ sudo hdparm -t /dev/sda1

/dev/sda1:
 Timing buffered disk reads:  492 MB in  3.01 seconds = 163.28 MB/sec
[roel@localhost ~]$ sudo hdparm -t /media/sf_ssd

/media/sf_ssd:
 BLKGETSIZE failed: Inappropriate ioctl for device

BLKFLSBUF failed: Inappropriate ioctl for device
[roel@localhost ~]$
[roel@localhost ~]$ sudo hdparm -t /ssd

/ssd:
 BLKGETSIZE failed: Inappropriate ioctl for device
BLKFLSBUF failed: Inappropriate ioctl for device

Change History

comment:1 Changed 13 months ago by frank

  • Description modified (diff)

comment:2 Changed 13 months ago by frank

  • Status changed from new to closed
  • Resolution set to wontfix

This is not a bug. Other remote filesystems like 'nfs' do also not support there system calls.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use