VirtualBox

Ticket #11613 (closed defect: fixed)

Opened 13 months ago

Last modified 6 months ago

Guest Fedora vanished unexpectedly!

Reported by: nim Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.10 Keywords:
Cc: Guest type: Linux
Host type: Mac OS X

Description

I had several cases of this bizarre situation. Though it cannot be reproduced reliably, but the crashes have something in common:

  1. Usually this is a fresh restart of guest Fedora.
  2. At the login screen, I type in password and click the Session dropdown list.
  3. Click on GNOME.
  4. The whole guest Window vanishes.

Attachments

VBox.log.2 Download (86.0 KB) - added by nim 13 months ago.
VBox.log Download (68.3 KB) - added by nim 13 months ago.
It happened again, unexpectedly
VBox.2.log Download (73.7 KB) - added by nim 13 months ago.
Again…

Change History

Changed 13 months ago by nim

Changed 13 months ago by nim

It happened again, unexpectedly

comment:1 Changed 13 months ago by nim

It seems after clicking on GNOME or XFC, I have to move mouse pointer a bit to cause the crash.

comment:2 Changed 13 months ago by frank

  • Priority changed from blocker to major
  • Component changed from other to 3D support

Looks to me like 3D-related. I assume that your VM will not crash if you disable 3D support.

Changed 13 months ago by nim

Again...

comment:3 Changed 12 months ago by nim

Ah, yes. It's caused by 3D acceleration. After disabling it, I have no crashes til now.

comment:4 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

There were lots of improvements done for 3D support on OSX host, and your issue is very likely to be fixed.
Please give a try to VBox 4.3 and 4.3 additions, and re-open if needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use