VirtualBox

Ticket #11608 (closed defect: duplicate)

Opened 13 months ago

Last modified 3 months ago

Sleep issue on Windows 7

Reported by: x64 Owned by:
Priority: critical Component: network
Version: VirtualBox 4.2.10 Keywords: VBoxNetAdp DRIVER_POWER_STATE_FAILURE
Cc: Guest type: all
Host type: Windows

Description

VBox version: 4.2.10.
Host OS: Windows 7 x64 SP1.

Sometimes but not always when I send my host system to sleep mode it crashes with DRIVER_POWER_STATE_FAILURE "A device object has been blocking an Irp for too long a time". According to memory dump analysis it's seems there is a bug in your virtual network adapter driver's code.

This issue I think is similar to #11274.

Attachments

analysis.txt Download (5.1 KB) - added by x64 13 months ago.
Memory dump analysis log

Change History

Changed 13 months ago by x64

Memory dump analysis log

comment:1 Changed 13 months ago by x64

Link to memory dump file:
 http://www.sendspace.com/file/cyal4f

comment:2 Changed 13 months ago by anshul makkar

Similar issue is also reported for win 8 host (https://www.virtualbox.org/ticket/11467). Currently work is in progress to fix it..

Version 0, edited 13 months ago by anshul makkar (next)

comment:3 Changed 13 months ago by anshul makkar

Thanks for sharing the memory dump.

Please can you share the memory dump with checked version of ndis.sys installed. Actually, the crash is not reproducible in our lab, so need detailed dump with checked ndis.sys for analysis.

comment:4 Changed 13 months ago by x64

Sorry, I can't crash my work system again and again as this may lead to data loss. Nevertheless, if you need detailed information about my system such as list of installed software, list of hardware-related drivers or something like that - do not hesitate to ask.

comment:5 Changed 13 months ago by anshul makkar

Oh k, one complete memory dump with debug version of ndis.sys is what we need to fix the issue.

comment:6 Changed 6 months ago by bobs

I have a similar problem: my machine was hibernating fine until VB was installed; since installation it has BSODed every time I've tried to hibernate (6-7 times).

WinDbg appears to suggest it is a problem with an NDIS Unbind request to VBoxNetFlt (the thread with this call in has a wait tick count of exactly 5 minutes before presumably timing out) and both dumps I've examined have been the same. However, my analysis is very amateurish - you shouldn't take my word for it.

I've jumped through the many hoops Microsoft apparently puts in your way to swap in the checked build of ndis.sys; the dump file is stored  here.

Other Notes

  • The host OS is a new build (installed 3-4 weeks before installing VB)
  • No other changes were made at the same time as VB was put on
  • The only guest (Win XP 32-bit) is using NAT, but I note that the VB Bridged Networking Miniport driver has been installed
  • It makes no difference whether the guest or VBox Manager have been run during the session (they weren't during the session I have a dump for)
  • I've tried sleep as well as hibernate (only once): it also caused a BSOD
  • I had a previous Win 7 Pro (32-bit) host on the same hardware which exhibited a similar problem for years (but I never linked it to VB)

Installation Details

MachineMSI P35 NEO2-FR Motherboard, 4GB RAM, Nvidia 8600GT
NICRealtek GBE (latest driver: 8.20.815.2013, which supersedes the Win 8.1. RTM driver)
Host OSWindows 8.1 RTM 64-bit
VB version4.2.18 r88780

comment:7 Changed 6 months ago by bobs

I have now installed the first three Win 8.1 patches (KBs 2884846, 2993200 & 2895219) and, as suggested in some other bug report threads, my very limited testing (one hibernation and one sleep) indicates one of these may have fixed the problem.

I suppose there is a question (assuming the problem really has gone away) over whether the bug is fixed or whether the bug still exists but no longer crashes the machine, but from an end-user point of view, things are looking up!

comment:8 Changed 3 months ago by frank

  • Status changed from new to closed
  • Resolution set to duplicate

I will mark this one as duplicate of #12063.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use