VirtualBox

Ticket #11596 (closed defect: wontfix)

Opened 8 years ago

Last modified 18 months ago

Incorrect OpenGL/GLES drawing z-order in guest os

Reported by: djdron Owned by:
Component: 3D support Version: VirtualBox 4.2.8
Keywords: OpenGL GLES Cc:
Guest type: Linux Host type: Windows

Description

Views inside windows with OpenGL/GLES rendering appears to draw always on the top of all. This is really annoying because you can't see popup menus, etc. Also this OpenGL/GLES views somtimes "freezes" and not update 3D graphics inside it.

How to reproduce: Install Ubuntu x86-64 guest inside Windows 7 host. Install Guest Additions. Install Google Chrome browser. Follow some HTML5 web sites with WebGL (GLESv2) content ( https://chrome.google.com/webstore/category/home?utm_source=chrome-ntp-icon) Try to browse. FAIL.

Also look attached screenshots:

Attachments

gles_fail.jpg Download (197.3 KB) - added by djdron 8 years ago.
gles_fail2.jpg Download (166.9 KB) - added by djdron 8 years ago.
VBox.log Download (227.1 KB) - added by djdron 8 years ago.
gpu_caps_viewer_report.txt Download (46.0 KB) - added by 83.manish@… 8 years ago.
host machine configuration
glxinfo.log Download (19.3 KB) - added by 83.manish@… 8 years ago.
gust machine glxinfo log
glxgears.jpg Download (35.5 KB) - added by 83.manish@… 8 years ago.
Error
Screenshot 2019-01-08 at 09.19.08.png Download (351.0 KB) - added by leopold.talirz 3 years ago.
issue on VirtualBox 6.0

Change History

Changed 8 years ago by djdron

Changed 8 years ago by djdron

Changed 8 years ago by djdron

Changed 8 years ago by 83.manish@…

host machine configuration

Changed 8 years ago by 83.manish@…

gust machine glxinfo log

comment:1 Changed 8 years ago by 83.manish@…

I am also getting the same error.

Below is my configuration:- Host: Windows 7(64bit) Guest: Ubuntu 13.04 Virtual Box : 4.3.6.r91406 Guest Additions : Installed. Glxinfo logs : glxinfo.log (Attached) Host machine configuration : gpu_caps_viewer_report.txt (Attached)

Any idea how to fix this?

Changed 8 years ago by 83.manish@…

Error

comment:2 Changed 8 years ago by frank

  • priority changed from critical to major

comment:3 Changed 5 years ago by aeichner

  • Status changed from new to closed
  • Resolution set to obsolete

Please reopen if still relevant with a recent VirtualBox release.

comment:4 Changed 3 years ago by leopold.talirz

While I cannot reproduce the issue with Chrome (is the site still using OpenGL?), I can definitely confirm that the underlying issue still persists, for example with glxgears as shown in one of the original screenshots

sudo apt-get install mesa-utils
glxgears

but also with many other apps that use OpenGL, for example visualizers for molecules (xcrysden[1], vmd[2]).

This is with VirtualBox 5.2.18, Guest OS Ubuntu 16.04.5 LTS, Host OS MacOS 10.13.6 (I've heard about this also from people with other Host OS's).

Happy to provide additional input on this issue - it currently forces us to disable 3d acceleration in VirtualBox, which obviously comes at a significant hit in graphics performance.

[1]  http://www.xcrysden.org/

[2]  https://www.ks.uiuc.edu/Research/vmd/

comment:5 Changed 3 years ago by leopold.talirz

Same problem on the newer Ubuntu 18.04.1 LTS (guest).

Last edited 3 years ago by leopold.talirz (previous) (diff)

comment:6 Changed 3 years ago by leopold.talirz

  • Status changed from closed to reopened
  • Resolution obsolete deleted

comment:7 Changed 3 years ago by leopold.talirz

Maybe some suspicious lines from /var/log/syslog will help?

Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) Loading sub module "glamoregl"
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) LoadModule: "glamoregl"
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) Loading /usr/lib/xorg/modules/libglamoregl.so
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) Module glamoregl: vendor="X.Org Foundation"
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: #011compiled for 1.19.6, module version = 1.0.0
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: #011ABI class: X.Org ANSI C Emulation, version 0.4
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) glamor: OpenGL accelerated X.org driver based.
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: pci id for fd 12: 80ee:beef, driver (null)
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (II) glamor: EGL version 1.4 (DRI2):
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: EGL_MESA_drm_image required.
Oct  8 05:59:57 qmobile /usr/lib/gdm3/gdm-x-session[1123]: (EE) modeset(0): glamor initialization failed

Also

org.gnome.Shell.desktop[1248]: OpenGL Warning: vboxCall failed with VBox status code VERR_BUFFER_OVERFLOW

The xcrysden program states

OpenGL Warning: No pincher, please call crStateSetCurrentPointers() in your SPU

Changed 3 years ago by leopold.talirz

issue on VirtualBox 6.0

comment:8 Changed 3 years ago by leopold.talirz

The issue persists on VirtualBox 6.0 with Ubuntu 18.04.1 LTS guest (now accompagnied by distortions of the background, see screenshot).

comment:9 Changed 19 months ago by leopold.talirz

For me, the issue has finally been resolved in VirtualBox 6.1. I'm now able to install glxgears, drag the window around + it correctly goes into the background when I select a different window.

VBox configuration: Graphics Controller VBox SVGA, 3d acceleration enabled Guest: Ubuntu 18.04.3 LTS Host: MacOS 10.14.6 (Macbook Pro 15" Mid 2015)

Version 0, edited 19 months ago by leopold.talirz (next)

comment:10 Changed 18 months ago by aeichner

  • Status changed from reopened to closed
  • Resolution set to wontfix

Thanks for the report, the old 3D code was removed and we don't plan any fixes in that area for 6.0, please switch to the VMSVGA based 3D support and report any issues in that area, thanks! Closing as wontfix.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use