VirtualBox

Ticket #11586 (closed defect: fixed)

Opened 13 months ago

Last modified 12 months ago

VBoxGuestAdditions fails to compile vboxvideo_drm.c on CentOS 6.4 => Fixed in SVN

Reported by: h-w Owned by:
Priority: minor Component: guest additions
Version: VirtualBox 4.2.8 Keywords: CentOS vboxvideo
Cc: Guest type: Linux
Host type: Windows

Description

From log:

/tmp/vbox.0/vboxvideo_drm.c:110: error: unknown field ‘reclaim_buffers’ specified in initializer
/tmp/vbox.0/vboxvideo_drm.c:110: warning: initialization from incompatible pointer type
make[2]: *** [/tmp/vbox.0/vboxvideo_drm.o] Error 1
make[1]: *** [_module_/tmp/vbox.0] Error 2
make: *** [vboxvideo] Error 2

Looking at vboxvideo_drm.c:110 shows:

109 #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 6, 0)
110     .reclaim_buffers = drm_core_reclaim_buffers,
111 #endif

Make the following change:

109 #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 6, 0)
110     // .reclaim_buffers = drm_core_reclaim_buffers,
111 #endif

fixes problem. Now vboxvideo kernel module is compiled, loads, and appears to work.

Virtual Box: 4.2.8 r83876
Host: Vista Home 64-bit
Client: CentOS 6.4 (Final)
Kernel: 2.6.32-358.0.1.el6.i686

Best Rgds, -H-

Change History

comment:1 Changed 13 months ago by frank

  • Summary changed from VBoxGuestAdditions fails to compile vboxvideo_drm.c on CentOS 6.4 to VBoxGuestAdditions fails to compile vboxvideo_drm.c on CentOS 6.4 => Fixed in SVN

Thanks for the report. This will be fixed in one of the next maintenance releases.

comment:2 Changed 13 months ago by seba.wagner

I was pointed to this issue when discussing an issue with the vboxvideo module after updating to RHEL 6.4

see:  https://forums.virtualbox.org/viewtopic.php?f=3&t=54838

Will this proposed patch fix the issues with VirtualBox and RHEL 6.4 ?

Is there a planned release for this patch? I am not really keen to use a SVN version of VirtualBox on my VMs.

Thanks, Sebastian

Version 0, edited 13 months ago by seba.wagner (next)

comment:3 Changed 13 months ago by frank

That bug is not critical. Even if the compilation of the Guest Additions kernel fails, you can still work with your guest. If nothing else helps, remove the Guest Additions as described in the User Manual (section 4.2.4).

And it's not really a VirtualBox bug. A kernel of a Linux distribution changed. The Redhat folks backported a feature from a vanilla kernel to their own maintained kernel. VirtualBox 4.2.10 does not ship an adaption to this change but that's a missing feature and not a bug.

Everybody who wants to try out the fix can have a look at r45001.

comment:4 follow-up: ↓ 5 Changed 13 months ago by sherman-zhang

I am also having the same problem and my VirtualBox is also 4.2.8. However, /tmp/vbox.0/vboxvideo_drm.c does not exist. In my Centos6.4, the file vboxvideo_drm.c is located in /opt/VBoxGuestAdditions-4.2.8/src/vboxguest-4.2.8/vboxvideo/. I have modified the line in this file but the problem cannot be fixed. Would you pls inform me how to fix it? Thanks a lot!

comment:5 in reply to: ↑ 4 Changed 13 months ago by frank

Replying to sherman-zhang:

I am also having the same problem and my VirtualBox is also 4.2.8. However, /tmp/vbox.0/vboxvideo_drm.c does not exist. In my Centos6.4, the file vboxvideo_drm.c is located in /opt/VBoxGuestAdditions-4.2.8/src/vboxguest-4.2.8/vboxvideo/. I have modified the line in this file but the problem cannot be fixed. Would you pls inform me how to fix it? Thanks a lot!

Please tell exactly what you did. The provided fix works here so I assume you did something wrong. I assume that you executed /etc/init.d/vboxadd setup after you modified the guest kernel sources, right?

comment:6 Changed 13 months ago by sherman-zhang

I executed the shell script VBoxLinuxAdditions.run in virtual cdrom where VBoxGuestAdditions.iso was mounted.

comment:7 follow-up: ↓ 8 Changed 13 months ago by frank

That will not work. Please modify the sources you already mentioned and execute

/etc/init.d/vboxadd setup

comment:8 in reply to: ↑ 7 Changed 13 months ago by sherman-zhang

Replying to frank:

That will not work. Please modify the sources you already mentioned and execute

/etc/init.d/vboxadd setup

The problem is fixed according to your suggestion. Thanks a lot!

comment:9 Changed 13 months ago by seba.wagner

I have executed the proposed fix. Done also /etc/init.d/vboxadd setup

Everything compiles fine. Restarted the box. But still the log shows: (EE) VBoxVideo(0): Unable to determine whether the virtual machine supports mouse pointer integration - request initialization failed with return code -4

I agree that the bug is not critical to run the guest system. So the bug does not destroy your host system. But practically VirtualBox is of no use if it does not boot.

I understand the pain of having a tool that integrates with a lot of platforms while those platforms do some nasty stuff :)

However you should provide a fix and distribute it, it is unlikely that RedHat will change because of VirtualBox. It is more likely that VirtualBox has to change to fit into RedHat then the other way round.

Meanwhile it would be nice if the issue could be fixed with some patch,

Thanks! Sebastian

comment:10 Changed 13 months ago by seba.wagner

I would like to add some more details:

The effect of the proposed patch is:

  • After you've run "/etc/init.d/vboxadd setup", the mouse pointer integration basically works. But when you stop the VM and restart it again, it will not work and you will find an error message in the console like I commented in my last post ((EE) VBoxVideo(0): Unable to determine whether the virtual machine supports mouse pointer integration - request initialization failed with return code -4 )
  • The patch does not fix any of the other issues like: VM of guest system does not adjust screen resolution, Seamless mode is no more available, copy and paste between host and guest does no more work, drag n drop does not work. Some other features of VirtualBox I did not test yet.

So from what I can say is:

  • The patch does have an effect but it does not fix the problem.
  • There are a number of other issues that make VirtualBox practically useless. I mean you can't really work with that. If just drag n drop would not work ok, but basically not even screen does adjust anymore. How is that supposed to be a minor issue?

Thanks,
Sebastian

comment:11 Changed 13 months ago by frank

Please don't mix the facts.

I do not expect a change from Red Hat. As said above, this problem will be fixed in the upcoming maintenance release. And for users who need a fix now, they can just apply the fix which I mentioned in comment 3.

Regarding your last comment: That patch does fix the problem as the original problem described in this ticket was that vboxvideo_drm.c does not compile on CentOS/RHEL/OL 6.4. This problem is definitely fixed.

Your other problem (the (EE) VBoxVideo(0)) line is a different problem and needs investigation.

comment:12 Changed 13 months ago by frank

No problems here with the above fix. You might want to try  this image. If you still get the VBoxVideo problem, please attach the /var/log/Xorg.0.log file to this ticket.

comment:13 Changed 12 months ago by seba.wagner

Thanks, the image you provided seem to fix all issues.

comment:14 Changed 12 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Thanks for the feedback! The fix is part of the 4.2.12 release.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use