VirtualBox

Ticket #11568 (closed defect: fixed)

Opened 14 months ago

Last modified 6 months ago

crash Ubuntu guest VM in GLEngine ShCrOpenGL

Reported by: fpn Owned by:
Priority: major Component: 3D support
Version: VirtualBox 4.2.8 Keywords: crash, Ubuntu, opengl
Cc: Guest type: Linux
Host type: Mac OS X

Description

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000

Thread 17 Crashed:: ShCrOpenGL
0   GLEngine                      	0x0000000109ede23c gleRunVertexSubmitImmediate + 5372
1   GLEngine                      	0x0000000109ed0405 gleDrawArraysOrElements_ExecCore + 1079
2   GLEngine                      	0x0000000109eca051 glDrawArrays_ACC_Exec + 636
3   VBoxSharedCrOpenGL.dylib      	0x0000000112d9ba77 crUnpack + 8535
4   VBoxSharedCrOpenGL.dylib      	0x0000000112d1d7de crServerServiceClients + 302
5   VBoxSharedCrOpenGL.dylib      	0x0000000112d14e98 crVBoxServerSetScreenCount + 344
6   VBoxSharedCrOpenGL.dylib      	0x0000000112d134d2 VBoxHGCMSvcLoad + 2690
7   VBoxC.dylib                   	0x000000010a70a202 NSGetModule + 30882
8   VBoxC.dylib                   	0x000000010a707502 NSGetModule + 19362
9   VBoxRT.dylib                  	0x00000001002409df RTThreadCreateF + 271
10  VBoxRT.dylib                  	0x00000001002930fc RTThreadPoke + 540
11  libsystem_c.dylib             	0x00007fff948fb742 _pthread_start + 327
12  libsystem_c.dylib             	0x00007fff948e8181 thread_start + 13

Attachments

VBox.log Download (65.0 KB) - added by fpn 14 months ago.
VirtualBoxVM_2013-03-06-111835_fpn-2.crash Download (66.2 KB) - added by fpn 14 months ago.
VirtualBoxVM_2013-03-08-092956_fpn-2.crash Download (69.9 KB) - added by fpn 14 months ago.
2nd crash
VBox.2.log Download (63.9 KB) - added by fpn 14 months ago.
2nd crash

Change History

Changed 14 months ago by fpn

Changed 14 months ago by fpn

comment:1 follow-up: ↓ 2 Changed 14 months ago by misha

What Ubuntu version do you run as a Guest?
Also please specify detailed steps to reproduce the issue, i.e. what 3D applications do you have running in your guest, how do you make them crash the VM, etc..

comment:2 in reply to: ↑ 1 Changed 14 months ago by fpn

Replying to misha:

Hi Misha, I run Ubuntu 12.10. I think it is related to that I closed / saved the VM and then resumed it the next day. I was able to work a few minutes with it and then it crashed. The first crash was in a context menu in the guest. Today it crashed again and I was just closing a window. Running Unity and Google Chrome - dev channel, other than that just many terminal windows.

Thank you and best regards, Florian

Changed 14 months ago by fpn

2nd crash

Changed 14 months ago by fpn

2nd crash

comment:3 Changed 14 months ago by misha

Thanks for the info. Your crash should be fixed on VBox trunk already. The fix will be available in the next major release.
I can give you a trunk test build though, that you could use to test whether the issue is solved for you.

Note that the trunk is under heavy development now, and thus this build can be used for testing purposes only, and can NOT be used in production environment.

Here are the links:
OSX host distro:  http://www.virtualbox.org/download/testcase/VirtualBox-4.2.51-84184-OSX.dmg
Extension pack:  http://www.virtualbox.org/download/testcase/Oracle_VM_VirtualBox_Extension_Pack-4.2.51-84184.vbox-extpack

Please let me know how it goes.

comment:4 Changed 6 months ago by misha

  • Status changed from new to closed
  • Resolution set to fixed

4.3 is released now, and this should be fixed with it. Please give it a try and re-open this ticket if needed.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use