VirtualBox

Ticket #11490 (closed defect: fixed)

Opened 14 months ago

Last modified 5 months ago

VirtualBox 4.2.6 Mac OS X 10.8.2 host fails to start Mac OS X 10.6.8 guest

Reported by: macsforme Owned by:
Priority: major Component: other
Version: VirtualBox 4.2.6 Keywords:
Cc: Guest type: OSX Server
Host type: Mac OS X

Description

Note: this issue may be related to #10998, #11401, #11288, and #11052, but I have additional information.

Host machine is an Apple Macmini5,1 (Mid 2011 base model). The host machine dual boots Mac OS X 10.8.2 and Mac OS X 10.6.8 on separate partitions. I created the guest VDI image by cloning this same 10.6.8 partition that the machine itself boots from successfully, using VBoxManage.

Booting the machine into 10.6.8 and running VirtualBox 4.1.12 allows me to successfully start the 10.6.8 guest using the VDI image. However, when booting into 10.8.2 and running VirtualBox 4.2.6 (or any other version compatible with Mountain Lion that I have tried), the virtual machine fails to complete the boot up process when this same VDI image is attached. Console output shows a last line of "AppleIntelCPUPowerManagementClient: ready" and then no further output is seen.

EFI was enabled in both tests, and all settings seem as equal as possible considering the differences between these versions.

In a response to the related bug report threads it was suggested to downgrade to VirtualBox 4.1.*. However, it is impossible to downgrade to VirtualBox 4.1.12 in Mac OS X 10.8.2 because that version of VirtualBox refuses to run (and when forced to do so from the command line, it crashes when starting a VM). My attempts to compile it from source were not successful. From release notes and other bug reports, it appears that Mountain Lion specific bugs were fixed in a version subsequent to 4.1.12, so it appears I will not be able to run this version on Mac OS X 10.8.2. I also tested other later versions of 4.1.* that do run on Mac OS X 10.8.2, and they all exhibited this same issue.

I have attached logs for the successful boot under the Mac OS X 10.6.8 / VirtualBox 4.1.12 host, and of the unsuccessful boot under the Mac OS X 10.8.2 / VirtualBox 4.2.6 host. I have also attached screenshots of the console output until the bootup stops on 10.8.2, and one of the console output on 10.6.8 going past that point.

Attachments

MLBootLog.txt Download (109.5 KB) - added by macsforme 14 months ago.
10.6.8 Host VM Log
MLBootLog.2.txt Download (109.5 KB) - added by macsforme 14 months ago.
10.8.2 Host VM Log
SLBootScreenshot.png Download (49.9 KB) - added by macsforme 14 months ago.
10.6.8 Host VM Screenshot
MLBootScreenshot.png Download (80.6 KB) - added by macsforme 14 months ago.
10.8.2 Host VM Screenshot
SLBootLog.txt Download (88.3 KB) - added by macsforme 14 months ago.
10.6.8 Host VM Log

Change History

Changed 14 months ago by macsforme

10.6.8 Host VM Log

Changed 14 months ago by macsforme

10.8.2 Host VM Log

Changed 14 months ago by macsforme

10.6.8 Host VM Screenshot

Changed 14 months ago by macsforme

10.8.2 Host VM Screenshot

Changed 14 months ago by macsforme

10.6.8 Host VM Log

comment:1 Changed 14 months ago by TGOS

I would say that this is an exact duplicate of #11401

comment:2 Changed 5 months ago by frank

  • Status changed from new to closed
  • Resolution set to fixed

Please reopen if still relevant with VBox 4.3.2.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use