VirtualBox

Ticket #1147 (closed defect: invalid)

Opened 6 years ago

Last modified 6 years ago

Not possible to get a reliable RDP connection (ubuntu amd64 7.10)

Reported by: cpolleke Owned by:
Priority: major Component: other
Version: VirtualBox 1.5.4 Keywords: AMD64 RDP
Cc: Guest type: other
Host type: other

Description

My serup is the following:

Server: AMD Athlon 64 X2, 4800+ (RAID1), an ubuntu AMD64 7.10 host to a Windows XP Home SP2 OS. Workstation: AMD64 Turion 64, ubuntu 7.10 AMD64 desktop using a wireless g connection (and believe me: this wireless is stable :-)).

I use VNC connections to the server a lot and this always works without a glitch.

After installing virtualbox 1.5.4 (non-OSE version) with a Windows XP VM I am having trouble getting a reliable RDP connection to the windows VM (yes, it is enabled from the gui).

I have used the following clients: Gnome RDP, rdesktop from the commandline and kdrc and all of them show the same result: either closing the connection right away, only showing the first screen without updating it (after reconnection the updated screen is shown) or working correctly for 1 minute (showing garbled areas in the screen).

The fact that sometimes I do get a screen is telling me I have setup the ports and stuff right. What can be the issue here? Is RDP not that stable or is some common part of all the clients I use unstable?

Change History

comment:1 Changed 6 years ago by cpolleke

BTW: Starting a fresh VM with the windows setup initially works, but after disconnecting things get ugly... Also, kdrc seems to speed up this process: after using kdrc it is not possible to connect anymore. After restarting the VM the story repeats itself.

comment:2 Changed 6 years ago by frank

How did you start the RDP server? If you use the Enable VRDP server setting in the VM settings dialog and start the VM session from the GUI, the RDP session will not be reliable. This is a regression in VirtualBox 1.5.4 and will be fixed in the next version. Use the VBoxVRDP frontend instead. Or did you already?

comment:3 Changed 6 years ago by cpolleke

Already tried both, although I am not sure at the moment. That is: i have tried both (from GUI and VBoxVRDP) but have not "seen the light" when it did or did not work.

I will try this tonight and will append any further experiences! Thanks for reacting btw!

comment:4 Changed 6 years ago by cpolleke

BTW: is there a way to get a newer (maybe SVN or nightly built version) of virtualbox using aptitude?

comment:5 Changed 6 years ago by frank

No, there isn't. The reason is that we already get enough bug reports for our regular releases. Having nightly builds might be desired by some people but would increase the number of 'false positives'. I hope that the next release 1.5.6 will no take too long. In the meantime we sometimes package experimental builds for some users.

comment:6 Changed 6 years ago by cpolleke

(I have tested the following using VBoxVRDP)

  1. Using rdesktop 8 bit mode works.
  1. Using rdesktop 15 bit mode gives garbage/artifacts/incomplete update operations. This results in messages like "NOT IMPLEMENTED: bitmap opcode 0x5" and "ERROR: Get bitmap 2:8".
  1. Using rdesktop 16 bit mode works.
  1. However: connecting to the RDP using Krdc (16 bit color mode) causes the VRDP server to stop responding. After this, not even rdesktop connections can be made (screen closes right away etc).
  1. Also, connecting using terminal server client ( http://www.gnomepro.com/tsclient) in RDP mode ends up in no connection, connecting in RDPv5 mode causes the screen to be displayed initially but never to be updated anymore. Every time I close the program, the new screen state is shown but as stated before: no updates.

Hopefully this is useful?

comment:7 Changed 6 years ago by sunlover

15bpp mode is not supported by the VRDP server. Only 8, 16 and 24bpp are supported.

Krdc works here, we could not reproduce the problem. Please attach the release log of the Windows XP VM with reproduced Krdc problem.

comment:8 Changed 6 years ago by cpolleke

I have discovered that Krdc also uses rdesktop (embedded in it's own window). There is no apparent reason why but did discover that krdc and rdesktop have had problems in the past working together. As rdesktop does work (when not in 15 bit mode) my problem is not urgent (even existent) anymore.

The logs stated that authentication was succesful and access was granted at which point krdc just keeps silent.

Too bad the brilliant scaling option is not available in rdesktop. I might try to build the two from source to see if that solves anything.

Thanks for the hints guys!

comment:9 Changed 6 years ago by cpolleke

Another followup:

It turned out that the nic the server used was forcedeth. The name forcedeth literally means that the network connection was "forced dead" (there are known issues with this on-board nVidia nic). As a result the network connection just went dead on the server side. I will try the RDP connection again after installing a $5 nic which works....

comment:10 Changed 6 years ago by sandervl73

  • Status changed from new to closed
  • Resolution set to invalid

I assume this now works and was caused by your nvidia nic.

Note: See TracTickets for help on using tickets.

www.oracle.com
ContactPrivacy policyTerms of Use